summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2012-06-18 07:53:26 +0000
committerPatrick Lauer <patrick@gentoo.org>2012-06-18 07:53:26 +0000
commitb2e3fb7c343699ecfa7442eac443f9a4c7ecef0a (patch)
treec1ef88f7ce32a20df317fe85d8d4f954a45882f9 /dev-db
parentsmall bump (diff)
downloadgentoo-2-b2e3fb7c343699ecfa7442eac443f9a4c7ecef0a.tar.gz
gentoo-2-b2e3fb7c343699ecfa7442eac443f9a4c7ecef0a.tar.bz2
gentoo-2-b2e3fb7c343699ecfa7442eac443f9a4c7ecef0a.zip
Bump
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgbouncer/ChangeLog7
-rw-r--r--dev-db/pgbouncer/pgbouncer-1.5.2.ebuild71
2 files changed, 77 insertions, 1 deletions
diff --git a/dev-db/pgbouncer/ChangeLog b/dev-db/pgbouncer/ChangeLog
index 4b5c585066dd..bc967186f1da 100644
--- a/dev-db/pgbouncer/ChangeLog
+++ b/dev-db/pgbouncer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/pgbouncer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgbouncer/ChangeLog,v 1.4 2012/06/04 06:45:39 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgbouncer/ChangeLog,v 1.5 2012/06/18 07:53:26 patrick Exp $
+
+*pgbouncer-1.5.2 (18 Jun 2012)
+
+ 18 Jun 2012; Patrick Lauer <patrick@gentoo.org> +pgbouncer-1.5.2.ebuild:
+ Bump
04 Jun 2012; Zac Medico <zmedico@gentoo.org> pgbouncer-1.4.2.ebuild,
pgbouncer-1.5.1.ebuild, pgbouncer-1.5.ebuild:
diff --git a/dev-db/pgbouncer/pgbouncer-1.5.2.ebuild b/dev-db/pgbouncer/pgbouncer-1.5.2.ebuild
new file mode 100644
index 000000000000..bebd4334de42
--- /dev/null
+++ b/dev-db/pgbouncer/pgbouncer-1.5.2.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgbouncer/pgbouncer-1.5.2.ebuild,v 1.1 2012/06/18 07:53:26 patrick Exp $
+
+EAPI="4"
+
+inherit eutils user
+
+RESTRICT="test"
+
+DESCRIPTION="Lightweight connection pooler for PostgreSQL"
+HOMEPAGE="http://pgfoundry.org/projects/pgbouncer/"
+SRC_URI="mirror://postgresql/projects/pgFoundry/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/libevent"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup pgbouncer
+ enewuser pgbouncer -1 -1 -1 pgbouncer
+}
+
+src_prepare() {
+ local rundir=""
+ [[ ! -d /run ]] && rundir="/var"
+
+ sed -i -e "s,${PN}.log,/var/log/${PN}/${PN}.log," \
+ -e "s,${PN}.pid,/var/run/${PN}/${PN}.pid," \
+ -e "s,etc/userlist.txt,/etc/userlist.txt," \
+ -e "s,;unix_socket_dir = /tmp,unix_socket_dir = ${rundir}/run/${PN}.sock," \
+ "${S}"/etc/pgbouncer.ini || die
+}
+
+src_configure() {
+ # --enable-debug is only used to disable stripping
+ econf \
+ --enable-debug \
+ $(use_enable debug cassert) \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc
+ newins etc/pgbouncer.ini pgbouncer.conf
+ newinitd "${FILESDIR}"/pgbouncer.initd "${PN}"
+
+ dodoc README NEWS AUTHORS
+ dodoc doc/*.txt
+
+ dodir /var/log/pgbouncer/
+ fowners pgbouncer:pgbouncer /var/log/pgbouncer/
+}
+
+pkg_postinst() {
+ einfo "Please read the config.txt for Configuration Directives"
+ einfo
+ einfo "For Administration Commands, see:"
+ einfo " man pgbouncer"
+ einfo
+ einfo "By default, PgBouncer does not have access to any database."
+ einfo "GRANT the permissions needed for your application and make sure that it"
+ einfo "exists in PgBouncer's auth_file."
+
+}