summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-12-07 17:58:33 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-12-07 17:58:33 +0000
commitb07d515cd2798a5f0ca67e5fba1de97a75c2fa3c (patch)
tree1e18decdb9c658e015b22808b94f0fb92a4ddb5d /dev-db
parentCleaning and added same trick for parallel build in 3.6.3 as in 4.0.1 (diff)
downloadgentoo-2-b07d515cd2798a5f0ca67e5fba1de97a75c2fa3c.tar.gz
gentoo-2-b07d515cd2798a5f0ca67e5fba1de97a75c2fa3c.tar.bz2
gentoo-2-b07d515cd2798a5f0ca67e5fba1de97a75c2fa3c.zip
Bump
(Portage version: 2.2_rc56/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/pgadmin3/ChangeLog7
-rw-r--r--dev-db/pgadmin3/pgadmin3-1.10.1.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-db/pgadmin3/ChangeLog b/dev-db/pgadmin3/ChangeLog
index 1df5f02af081..c0fe8d5bbc05 100644
--- a/dev-db/pgadmin3/ChangeLog
+++ b/dev-db/pgadmin3/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/pgadmin3
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.41 2009/09/11 20:38:53 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/ChangeLog,v 1.42 2009/12/07 17:58:33 patrick Exp $
+
+*pgadmin3-1.10.1 (07 Dec 2009)
+
+ 07 Dec 2009; Patrick Lauer <patrick@gentoo.org> +pgadmin3-1.10.1.ebuild:
+ Bump
*pgadmin3-1.10.0 (11 Sep 2009)
diff --git a/dev-db/pgadmin3/pgadmin3-1.10.1.ebuild b/dev-db/pgadmin3/pgadmin3-1.10.1.ebuild
new file mode 100644
index 000000000000..de1b4cd0e988
--- /dev/null
+++ b/dev-db/pgadmin3/pgadmin3-1.10.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgadmin3/pgadmin3-1.10.1.ebuild,v 1.1 2009/12/07 17:58:33 patrick Exp $
+
+EAPI="1"
+
+WX_GTK_VER="2.8"
+
+inherit wxwidgets eutils autotools
+
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="wxWidgets GUI for PostgreSQL."
+HOMEPAGE="http://www.pgadmin.org/"
+SRC_URI="mirror://postgresql/pgadmin3/release/v${PV}/src/${P}.tar.gz"
+LICENSE="Artistic"
+SLOT="0"
+IUSE="debug"
+
+DEPEND="x11-libs/wxGTK:2.8
+ virtual/postgresql-base
+ >=dev-libs/libxml2-2.5
+ >=dev-libs/libxslt-1.1"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/1.8.2-as_needed_ssl_detect_broken.patch"
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --with-wx-version=2.8 \
+ $(use_enable debug)
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "einstall failed"
+
+ insinto /usr/share/pixmaps
+ newins "${S}/pgadmin/include/images/elephant48.xpm" pgadmin3.xpm
+
+ insinto /usr/share/pgadmin3
+ newins "${S}/pgadmin/include/images/elephant48.xpm" pgadmin3.xpm
+
+ insinto /usr/share/applications
+ doins "${S}/pkg/pgadmin3.desktop"
+
+ # Fixing world-writable files
+ chmod -R go-w "${D}/usr/share"
+}