summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-01-24 17:43:32 +0000
committerAchim Gottinger <achim@gentoo.org>2001-01-24 17:43:32 +0000
commita53861b6a1118df00c2a5385db59c7db287c2c22 (patch)
treecbf5b8c95ae567088ed3b171399a3c2985ffe023 /dev-db
parent*** empty log message *** (diff)
downloadgentoo-2-a53861b6a1118df00c2a5385db59c7db287c2c22.tar.gz
gentoo-2-a53861b6a1118df00c2a5385db59c7db287c2c22.tar.bz2
gentoo-2-a53861b6a1118df00c2a5385db59c7db287c2c22.zip
*** empty log message ***
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/postgresql-7.1_beta3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-db/postgresql/postgresql-7.1_beta3.ebuild b/dev-db/postgresql/postgresql-7.1_beta3.ebuild
new file mode 100644
index 000000000000..73c5572a8336
--- /dev/null
+++ b/dev-db/postgresql/postgresql-7.1_beta3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# /home/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.0.3-r1.ebuild,v 1.4 2001/01/23 19:54:43 achim Exp
+
+P=postgresql-7.1beta3
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
+SRC_URI="ftp://ftp.postgresql.org/pub/dev/${A}"
+HOMEPAGE="http://postgresql.readysetnet.com/"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}/src/backend/catalog
+ cp genbki.sh genbki.sh.orig
+# sed -e 's:\\name:\\ name:' genbki.sh.orig > genbki.sh
+}
+
+src_compile() {
+
+ try ./configure --prefix=/usr --host=${CHOST} \
+ --datadir=/usr/share/postgres --includedir=/usr/include/postgres \
+ --enable-locale --with-tcl --enable-syslog
+ try make
+
+}
+
+src_install () {
+
+ try make prefix=${D}/usr includedir=${D}/usr/include/postgres \
+ datadir=${D}/usr/share/postgres install
+}
+