summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2005-09-17 16:35:10 +0000
committerCaleb Tennis <caleb@gentoo.org>2005-09-17 16:35:10 +0000
commita51c6daebdeebd08666a68b29d888fc934f8eab3 (patch)
tree4da59c813f5dd35856f36e4359bac0aaf2ea9ce1 /dev-db
parentNew snapshot for BSD support (bug #105768). (diff)
downloadgentoo-2-a51c6daebdeebd08666a68b29d888fc934f8eab3.tar.gz
gentoo-2-a51c6daebdeebd08666a68b29d888fc934f8eab3.tar.bz2
gentoo-2-a51c6daebdeebd08666a68b29d888fc934f8eab3.zip
Version bump
(Portage version: 2.0.52-r1)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/qt-unixODBC/ChangeLog7
-rw-r--r--dev-db/qt-unixODBC/Manifest6
-rw-r--r--dev-db/qt-unixODBC/files/digest-qt-unixODBC-3.3.51
-rw-r--r--dev-db/qt-unixODBC/qt-unixODBC-3.3.5.ebuild59
4 files changed, 70 insertions, 3 deletions
diff --git a/dev-db/qt-unixODBC/ChangeLog b/dev-db/qt-unixODBC/ChangeLog
index d70208ed382d..0d658389ec9f 100644
--- a/dev-db/qt-unixODBC/ChangeLog
+++ b/dev-db/qt-unixODBC/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/qt-unixODBC
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/qt-unixODBC/ChangeLog,v 1.6 2005/09/17 00:35:00 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/qt-unixODBC/ChangeLog,v 1.7 2005/09/17 16:35:10 caleb Exp $
+
+*qt-unixODBC-3.3.5 (17 Sep 2005)
+
+ 17 Sep 2005; Caleb Tennis <caleb@gentoo.org> +qt-unixODBC-3.3.5.ebuild:
+ Version bump
17 Sep 2005; Aron Griffis <agriffis@gentoo.org> qt-unixODBC-3.3.4.ebuild:
Mark 3.3.4 stable on ia64
diff --git a/dev-db/qt-unixODBC/Manifest b/dev-db/qt-unixODBC/Manifest
index 8935586d8c42..b4b9dceaa3a3 100644
--- a/dev-db/qt-unixODBC/Manifest
+++ b/dev-db/qt-unixODBC/Manifest
@@ -1,4 +1,6 @@
-MD5 512150b47a904b0240101e319856aab1 metadata.xml 156
-MD5 cef22405643382f9e514366234e824ba ChangeLog 886
+MD5 2a1ae045ff7268b117acc2d64cfa5469 qt-unixODBC-3.3.5.ebuild 1575
MD5 2a1ae045ff7268b117acc2d64cfa5469 qt-unixODBC-3.3.4.ebuild 1575
+MD5 cef22405643382f9e514366234e824ba ChangeLog 886
+MD5 512150b47a904b0240101e319856aab1 metadata.xml 156
MD5 07a5c97eddc68da556434cdd09a7a903 files/digest-qt-unixODBC-3.3.4 72
+MD5 d09855ad814a45f5c624cd6680628f96 files/digest-qt-unixODBC-3.3.5 72
diff --git a/dev-db/qt-unixODBC/files/digest-qt-unixODBC-3.3.5 b/dev-db/qt-unixODBC/files/digest-qt-unixODBC-3.3.5
new file mode 100644
index 000000000000..371ee440b155
--- /dev/null
+++ b/dev-db/qt-unixODBC/files/digest-qt-unixODBC-3.3.5
@@ -0,0 +1 @@
+MD5 05d04688c0c0230ed54e89102d689ca4 qt-x11-free-3.3.5.tar.bz2 14431679
diff --git a/dev-db/qt-unixODBC/qt-unixODBC-3.3.5.ebuild b/dev-db/qt-unixODBC/qt-unixODBC-3.3.5.ebuild
new file mode 100644
index 000000000000..8b9576d5e04c
--- /dev/null
+++ b/dev-db/qt-unixODBC/qt-unixODBC-3.3.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/qt-unixODBC/qt-unixODBC-3.3.5.ebuild,v 1.1 2005/09/17 16:35:10 caleb Exp $
+
+inherit eutils
+
+SRCTYPE="free"
+DESCRIPTION="QT version ${PV}"
+HOMEPAGE="http://www.trolltech.com/"
+SRC_URI="ftp://ftp.trolltech.com/qt/source/qt-x11-${SRCTYPE}-${PV}.tar.bz2"
+IUSE=""
+LICENSE="|| ( QPL-1.0 GPL-2 )"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="~x11-libs/qt-$PV
+ dev-db/unixODBC"
+
+S=${WORKDIR}/qt-x11-${SRCTYPE}-${PV}
+
+QTBASE=/usr/qt/3
+export QTDIR=${S}
+export PLATFORM=linux-g++
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ cp configure configure.orig
+ sed -e 's:read acceptance:acceptance=yes:' configure.orig > configure
+}
+
+src_compile() {
+ export QTDIR=${S}
+ export SYSCONF=${D}${QTBASE}/etc/settings
+
+ # Let's just allow writing to these directories during Qt emerge
+ # as it makes Qt much happier.
+ addwrite "${QTBASE}/etc/settings"
+ addwrite "$HOME/.qt"
+
+ export YACC='byacc -d'
+
+ ./configure -sm -thread -stl -system-libjpeg -verbose -largefile \
+ -qt-imgfmt-{jpeg,mng,png} -tablet -system-libmng \
+ -system-libpng -lpthread -xft -platform ${PLATFORM} -xplatform \
+ ${PLATFORM} -xrender -prefix ${QTBASE} -fast ${myconf} \
+ -dlopen-opengl -plugin-sql-odbc -L${QTBASE}/lib || die
+
+ export QTDIR=${S}
+
+ cd $S/plugins/src/sqldrivers/odbc
+ emake || die
+}
+
+src_install() {
+ mkdir -p $D/$QTBASE/plugins/sqldrivers
+ cp $S/plugins/sqldrivers/libqsqlodbc.so $D/$QTBASE/plugins/sqldrivers/ || die
+}