summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2008-03-06 15:40:22 +0000
committerBenedikt Boehm <hollow@gentoo.org>2008-03-06 15:40:22 +0000
commit86e0ceb4801c1e6e014dfdc5064e945fed3041d6 (patch)
tree789adb5d62b1ab23b2ae9ddd389bed331abb123d /dev-db
parentStable on amd64, bug #212505 (diff)
downloadgentoo-2-86e0ceb4801c1e6e014dfdc5064e945fed3041d6.tar.gz
gentoo-2-86e0ceb4801c1e6e014dfdc5064e945fed3041d6.tar.bz2
gentoo-2-86e0ceb4801c1e6e014dfdc5064e945fed3041d6.zip
add patch for custom connection certificates; fix postinstall instructions wrt #212117; remove vulnerable versions wrt #212000
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/phpmyadmin/ChangeLog11
-rw-r--r--dev-db/phpmyadmin/files/phpmyadmin-2.11.5-custom-cert.patch14
-rw-r--r--dev-db/phpmyadmin/files/postinstall-en-2.8.0.txt37
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-2.11.2.2.ebuild60
-rw-r--r--dev-db/phpmyadmin/phpmyadmin-2.11.5-r1.ebuild (renamed from dev-db/phpmyadmin/phpmyadmin-2.11.4.ebuild)14
5 files changed, 53 insertions, 83 deletions
diff --git a/dev-db/phpmyadmin/ChangeLog b/dev-db/phpmyadmin/ChangeLog
index 1f54c882dce9..dbcc71963a23 100644
--- a/dev-db/phpmyadmin/ChangeLog
+++ b/dev-db/phpmyadmin/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-db/phpmyadmin
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.295 2008/03/04 20:54:56 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/ChangeLog,v 1.296 2008/03/06 15:40:21 hollow Exp $
+
+*phpmyadmin-2.11.5-r1 (06 Mar 2008)
+
+ 06 Mar 2008; Benedikt Böhm <hollow@gentoo.org>
+ files/postinstall-en-2.8.0.txt,
+ +files/phpmyadmin-2.11.5-custom-cert.patch, -phpmyadmin-2.11.2.2.ebuild,
+ -phpmyadmin-2.11.4.ebuild, +phpmyadmin-2.11.5-r1.ebuild:
+ add patch for custom connection certificates; fix postinstall instructions
+ wrt #212117; remove vulnerable versions wrt #212000
04 Mar 2008; Tobias Scherbaum <dertobi123@gentoo.org>
phpmyadmin-2.11.5.ebuild:
diff --git a/dev-db/phpmyadmin/files/phpmyadmin-2.11.5-custom-cert.patch b/dev-db/phpmyadmin/files/phpmyadmin-2.11.5-custom-cert.patch
new file mode 100644
index 000000000000..9e75b8d877b0
--- /dev/null
+++ b/dev-db/phpmyadmin/files/phpmyadmin-2.11.5-custom-cert.patch
@@ -0,0 +1,14 @@
+Index: phpMyAdmin-2.11.5-all-languages-utf-8-only/libraries/dbi/mysqli.dbi.lib.php
+===================================================================
+--- phpMyAdmin-2.11.5-all-languages-utf-8-only.orig/libraries/dbi/mysqli.dbi.lib.php
++++ phpMyAdmin-2.11.5-all-languages-utf-8-only/libraries/dbi/mysqli.dbi.lib.php
+@@ -97,6 +97,9 @@ function PMA_DBI_connect($user, $passwor
+ /* Optionally enable SSL */
+ if ($GLOBALS['cfg']['Server']['ssl'] && defined('MYSQLI_CLIENT_SSL')) {
+ $client_flags |= MYSQLI_CLIENT_SSL;
++ if ($GLOBALS['cfg']['Server']['ssl-key'] && $GLOBALS['cfg']['Server']['ssl-cert'] && $GLOBALS['cfg']['Server']['ssl-ca']) {
++ mysqli_ssl_set($link, $GLOBALS['cfg']['Server']['ssl-key'], $GLOBALS['cfg']['Server']['ssl-cert'], $GLOBALS['cfg']['Server']['ssl-ca'], null, null);
++ }
+ }
+
+ $return_value = @mysqli_real_connect($link, $GLOBALS['cfg']['Server']['host'], $user, $password, false, $server_port, $server_socket, $client_flags);
diff --git a/dev-db/phpmyadmin/files/postinstall-en-2.8.0.txt b/dev-db/phpmyadmin/files/postinstall-en-2.8.0.txt
index 3c0db528ad79..d297c7b46220 100644
--- a/dev-db/phpmyadmin/files/postinstall-en-2.8.0.txt
+++ b/dev-db/phpmyadmin/files/postinstall-en-2.8.0.txt
@@ -2,31 +2,34 @@ If this is a new installation:
1. Configure ${PN}:
- a) Create config.inc.php. You can use the web-based installer:
+a) Create config.inc.php. You can use the web-based installer:
- http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/scripts/setup.php
+ mkdir ${MY_INSTALLDIR}/config
+ chown ${VHOST_SERVER_UID}:${VHOST_SERVER_UID} ${MY_INSTALLDIR}/config
- b) Alternatively, use an existing configuration:
+ then go to http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/scripts/setup.php
- mkdir ${MY_INSTALLDIR}/config
- chmod o+rw ${MY_INSTALLDIR}/config
- cp <path to existing config.inc.php file>/config.inc.php ${MY_INSTALLDIR}/config/
- chown -R ${VHOST_SERVER_UID}:${VHOST_SERVER_UID} ${MY_INSTALLDIR}/config
+ once you've saved the configuration:
- C) Alternatively, use the default config file in libraries/config.default.php
+ cp ${MY_INSTALLDIR}/config/config.inc.php ${MY_INSTALLDIR}/config.inc.php
+ rm -rf ${MY_INSTALLDIR}/config
- mkdir ${MY_INSTALLDIR}/config
- chmod o+rw ${MY_INSTALLDIR}/config
- cp ${MY_INSTALLDIR}/libraries/config.default.php ${MY_INSTALLDIR}/config/
- chown -R ${VHOST_SERVER_UID}:${VHOST_SERVER_UID} ${MY_INSTALLDIR}/config
+b) Alternatively, use an existing configuration:
+
+ cp <path to existing config.inc.php file> ${MY_INSTALLDIR}/
+
+c) Alternatively, use the sample config file:
+
+ cp ${MY_INSTALLDIR}/config.sample.inc.php ${MY_INSTALLDIR}/config.inc.php
2. Be sure that the libraries/ directory is not visible. You can use the
-provided .htaccess file.
+ provided .htaccess file.
-===============
+=================================================================
If you are upgrading from an earlier version:
-1. If you are using ${PN}'s features for master/foreign tables, be sure to read
- http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/Documentation.html#col_com
-You will need to perform the ALTER TABLE step yourself.
+1. If you are using ${PN}'s features for master/foreign tables, be sure to read
+ http://${VHOST_HOSTNAME}/${VHOST_APPDIR}/Documentation.html#col_com
+
+ You will need to perform the ALTER TABLE step yourself.
diff --git a/dev-db/phpmyadmin/phpmyadmin-2.11.2.2.ebuild b/dev-db/phpmyadmin/phpmyadmin-2.11.2.2.ebuild
deleted file mode 100644
index 2d2dff4d9c33..000000000000
--- a/dev-db/phpmyadmin/phpmyadmin-2.11.2.2.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.11.2.2.ebuild,v 1.8 2008/02/19 13:35:21 hollow Exp $
-
-inherit eutils webapp depend.php
-
-MY_PV=${PV/_/-}
-MY_P="phpMyAdmin-${MY_PV}-all-languages-utf-8-only"
-
-DESCRIPTION="Web-based administration for MySQL database in PHP"
-HOMEPAGE="http://www.phpmyadmin.net/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-KEYWORDS="alpha amd64 hppa ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=""
-RDEPEND=""
-
-S="${WORKDIR}"/${MY_P}
-
-need_php_httpd
-
-pkg_setup() {
- webapp_pkg_setup
-
- if ! PHPCHECKNODIE="yes" require_php_with_use crypt ctype pcre session unicode \
- || ! PHPCHECKNODIE="yes" require_php_with_any_use mysql mysqli ; then
- eerror
- eerror "${PHP_PKG} needs to be re-installed with all of the following"
- eerror "USE flags enabled:"
- eerror
- eerror "ctype pcre session unicode"
- eerror
- eerror "as well as any of the following USE flags enabled:"
- eerror
- eerror "mysql or mysqli if using dev-lang/php-5"
- eerror "mysql if using dev-lang/php-4"
- eerror
- die "Re-install ${PHP_PKG}"
- fi
-}
-
-src_install() {
- webapp_src_preinst
-
- dodoc CREDITS Documentation.txt INSTALL README RELEASE-DATE-${MY_PV} TODO ChangeLog
- rm -f LICENSE CREDITS INSTALL README RELEASE-DATE-${MY_PV} TODO
-
- insinto "${MY_HTDOCSDIR}"
- doins -r .
-
- webapp_configfile "${MY_HTDOCSDIR}"/libraries/config.default.php
- webapp_serverowned "${MY_HTDOCSDIR}"/libraries/config.default.php
-
- webapp_postinst_txt en "${FILESDIR}"/postinstall-en-2.8.0.txt
- webapp_hook_script "${FILESDIR}"/reconfig-2.8
- webapp_src_install
-}
diff --git a/dev-db/phpmyadmin/phpmyadmin-2.11.4.ebuild b/dev-db/phpmyadmin/phpmyadmin-2.11.5-r1.ebuild
index 2ad15a28ebbd..f9c999ecd9f6 100644
--- a/dev-db/phpmyadmin/phpmyadmin-2.11.4.ebuild
+++ b/dev-db/phpmyadmin/phpmyadmin-2.11.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.11.4.ebuild,v 1.1 2008/02/19 13:35:21 hollow Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/phpmyadmin/phpmyadmin-2.11.5-r1.ebuild,v 1.1 2008/03/06 15:40:21 hollow Exp $
inherit eutils webapp depend.php
@@ -15,13 +15,11 @@ LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE=""
-DEPEND=""
-RDEPEND=""
+need_httpd_cgi
+need_php_httpd
S="${WORKDIR}"/${MY_P}
-need_php_httpd
-
pkg_setup() {
webapp_pkg_setup
@@ -42,6 +40,12 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.11.5-custom-cert.patch
+}
+
src_install() {
webapp_src_preinst