summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-12-31 18:41:47 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-12-31 18:41:47 +0000
commit8586c5507c44f103d70a3a32ce8527185b07e056 (patch)
tree82e8c322322b8d725e161bcc77f3b89c951da300 /dev-db
parentNew version. (diff)
downloadgentoo-2-8586c5507c44f103d70a3a32ce8527185b07e056.tar.gz
gentoo-2-8586c5507c44f103d70a3a32ce8527185b07e056.tar.bz2
gentoo-2-8586c5507c44f103d70a3a32ce8527185b07e056.zip
version bump. masked for testing
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/ChangeLog7
-rw-r--r--dev-db/postgresql/files/7.3.1/postgresql27
-rw-r--r--dev-db/postgresql/files/digest-postgresql-7.3.11
-rwxr-xr-xdev-db/postgresql/files/postgres3
-rw-r--r--dev-db/postgresql/postgresql-7.3.1.ebuild172
5 files changed, 207 insertions, 3 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index 181ac8c5adc2..05655e8c4d9a 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,12 +1,17 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.46 2002/12/22 06:43:53 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.47 2002/12/31 18:41:47 rphillips Exp $
04 Dec 2002: Michael Cummings <mcummings@gentoo.org>
postgresql-7.3.ebuild:
Added sparc64 keyword - installs and runs just fine
+*postgresql-7.3.1 (31 Dec 2002)
+
+ 31 Dec 2002; Ryan Phillips <rphillips@gentoo.org> postgresql-7.3.1.ebuild :
+ Version bump.. Masked for testing.
+
*postgresql-7.3 (1 Dec 2002)
21 Dec 2002; Ryan Phillips <rphillips@gentoo.org> postgresql-7.3.ebuild:
diff --git a/dev-db/postgresql/files/7.3.1/postgresql b/dev-db/postgresql/files/7.3.1/postgresql
new file mode 100644
index 000000000000..e40f2fc37485
--- /dev/null
+++ b/dev-db/postgresql/files/7.3.1/postgresql
@@ -0,0 +1,27 @@
+#!/sbin/runscript
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/dev-db/postgresql/files/postgresql.rc6,v 1.1 2002/01/06 00:53:24 woodchip Exp
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting postgres"
+ su - $PGUSER -c "/usr/bin/pg_ctl start -D '$PGDATA' -s -l '$PGLOG' -o '$PGOPTS'"
+ eend $?
+}
+
+stop () {
+ ebegin "Stopping postgres"
+ su - $PGUSER -c "/usr/bin/pg_ctl stop -D '$PGDATA' -s -m fast"
+ eend $?
+}
+
+svc_restart () {
+ ebegin "Restarting postgres"
+ su - $PGUSER -c "/usr/bin/pg_ctl restart -D '$PGDATA' -s -m fast -l '$PGLOG' -o '$PGOPTS'"
+ eend $?
+}
+
diff --git a/dev-db/postgresql/files/digest-postgresql-7.3.1 b/dev-db/postgresql/files/digest-postgresql-7.3.1
new file mode 100644
index 000000000000..9c133a42d2ab
--- /dev/null
+++ b/dev-db/postgresql/files/digest-postgresql-7.3.1
@@ -0,0 +1 @@
+MD5 924b21c3114f595834e2456277f1bffb postgresql-7.3.1.tar.gz 11171551
diff --git a/dev-db/postgresql/files/postgres b/dev-db/postgresql/files/postgres
index f8f047c19f12..9968708984de 100755
--- a/dev-db/postgresql/files/postgres
+++ b/dev-db/postgresql/files/postgres
@@ -25,7 +25,7 @@ start() {
einfo "Starting ${SERVICE}.."
if [ "${USE_SYSLOG}" = "yes" ]
then
- su - ${PGUSER} -c "${EXE} ${PGOPTS} -p ${PGPORT} 2>&1" | logger -p ${FACILITY}.notice 1>&2 &
+ sudo -u ${PGUSER} "${EXE} ${PGOPTS} -p ${PGPORT} 2>&1" | logger -p ${FACILITY}.notice 1>&2 &
fi
eend $? "Error starting ${SERVICE}."
}
@@ -43,4 +43,3 @@ restart() {
doservice ${@}
-
diff --git a/dev-db/postgresql/postgresql-7.3.1.ebuild b/dev-db/postgresql/postgresql-7.3.1.ebuild
new file mode 100644
index 000000000000..ff82c98754a6
--- /dev/null
+++ b/dev-db/postgresql/postgresql-7.3.1.ebuild
@@ -0,0 +1,172 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.1.ebuild,v 1.1 2002/12/31 18:41:47 rphillips Exp $
+
+IUSE="ssl nls java python tcltk perl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="PostgreSQL is a sophisticated Object-Relational DBMS"
+SRC_URI="ftp://ftp.us.postgresql.org/source/v${PV}/${P}.tar.gz"
+HOMEPAGE="http://www.postgresql.org"
+LICENSE="POSTGRESQL"
+KEYWORDS="~x86 ~ppc ~sparc"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ sys-devel/autoconf
+ app-admin/sudo
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ >=sys-libs/zlib-1.1.3
+ tcltk? ( >=dev-lang/tcl-8 >=dev-lang/tk-8.3.3-r1 )
+ perl? ( >=sys-devel/perl-5.6.1-r2 )
+ python? ( >=dev-lang/python-2.2 )
+ java? ( >=virtual/jdk-1.3* >=dev-java/ant-1.3 )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )
+ nls? ( sys-devel/gettext )"
+# java dep workaround for portage bug
+# x86? ( java? ( =virtual/jdk-1.3* >=dev-java/ant-1.3 ) )
+
+RDEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.3
+ tcltk? ( >=dev-lang/tcl-8 )
+ perl? ( >=sys-devel/perl-5.6.1-r2 )
+ python? ( >=dev-lang/python-2.2 )
+ java? ( >=virtual/jdk-1.3* )
+ ssl? ( >=dev-libs/openssl-0.9.6-r1 )"
+
+SLOT="0"
+
+PG_DIR="/var/lib/postgresql"
+
+pkg_setup() {
+ if [ -f ${PG_DIR}/data/PG_VERSION ] ; then
+ PG_MAJOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f1 -d.`
+ PG_MINOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f2 -d.`
+ if [ ${PG_MAJOR} -lt 7 ] || [ ${PG_MAJOR} -eq 7 -a ${PG_MINOR} -lt 3 ] ; then
+ eerror "Postgres ${PV} cannot upgrade your existing databases, you must"
+ eerror "use pg_dump to export your existing databases to a file, and then"
+ eerror "pg_restore to import them when you have upgraded completely."
+ eerror "You must remove your entire database directory to continue."
+ eerror "(database directory = ${PG_DIR})."
+ exit 1
+ fi
+ fi
+}
+
+src_compile() {
+ local myconf
+ use tcltk && myconf="--with-tcl"
+ use python && myconf="$myconf --with-python"
+ use perl && myconf="$myconf --with-perl"
+ use java && myconf="$myconf --with-java"
+ use ssl && myconf="$myconf --with-openssl"
+ use nls && myconf="$myconf --enable-locale --enable-nls --enable-multibyte"
+ use libg++ && myconf="$myconf --with-CXX"
+
+ # these are the only working CFLAGS I could get on ppc, so locking them
+ # down, anything more aggressive fails (i.e. -mcpu or -Ox)
+ # Gerk - Nov 26, 2002
+ use ppc && CFLAGS="-pipe -fsigned-char"
+
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --host=${CHOST} \
+ --docdir=/usr/share/doc/${P} \
+ --libdir=/usr/lib \
+ --enable-syslog \
+ --enable-depend \
+ --with-gnu-ld \
+ --with-pam \
+ --with-maxbackends=1024 \
+ $myconf || die
+
+
+ make || die
+ cd contrib
+ make || die
+}
+
+src_install () {
+
+ addwrite "/usr/share/man/man3/Pg.3pm"
+
+ if [ "`use perl`" ]
+ then
+ mv ${S}/src/pl/plperl/Makefile ${S}/src/pl/plperl/Makefile_orig
+ sed -e "s:(INST_DYNAMIC) /usr/lib:(INST_DYNAMIC) ${D}/usr/lib:" \
+ ${S}/src/pl/plperl/Makefile_orig > ${S}/src/pl/plperl/Makefile
+ mv ${S}/src/pl/plperl/GNUmakefile ${S}/src/pl/plperl/GNUmakefile_orig
+ sed -e "s:\$(DESTDIR)\$(plperl_installdir):\$(plperl_installdir):" \
+ ${S}/src/pl/plperl/GNUmakefile_orig > ${S}/src/pl/plperl/GNUmakefile
+ fi
+
+ make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ make DESTDIR=${D} install-all-headers || die
+ cd ${S}/contrib
+ make DESTDIR=${D} LIBDIR=${D}/usr/lib install || die
+ cd ${S}
+ dodoc COPYRIGHT HISTORY INSTALL README register.txt
+ dodoc contrib/adddepend/*
+ cd ${S}/doc
+ dodoc FAQ* KNOWN_BUGS MISSING_FEATURES README*
+ dodoc TODO internals.ps bug.template
+ docinto sgml
+ dodoc src/sgml/*.{sgml,dsl}
+ docinto sgml/ref
+ dodoc src/sgml/ref/*.sgml
+ docinto sgml/graphics
+ dodoc src/graphics/*
+ rm -rf ${D}/usr/doc ${D}/mnt
+ exeinto /usr/bin
+
+ if [ `use java` ]; then
+ dojar ${D}/usr/share/postgresql/java/postgresql.jar
+ rm ${D}/usr/share/postgresql/java/postgresql.jar
+ fi
+
+ dodir /usr/include/postgresql/pgsql
+ cp ${D}/usr/include/*.h ${D}/usr/include/postgresql/pgsql
+
+ exeinto /etc/init.d/
+ doexe ${FILESDIR}/${PV}/${PN}
+
+ exeinto /etc/conf.d/
+ doexe ${FILESDIR}/postgresql
+}
+
+pkg_postinst() {
+ einfo ">>> Execute the following command"
+ einfo ">>> ebuild /var/db/pkg/dev-db/${PF}/${PF}.ebuild config"
+ einfo ">>> to setup the initial database environment."
+ einfo ">>> "
+ einfo ">>> Make sure the postgres user in /etc/passwd has an account setup with /bin/bash as the shell, or /bin/true"
+}
+
+
+pkg_config() {
+ einfo ">>> Creating data directory ..."
+ mkdir -p ${PG_DIR}/data
+ chown -Rf postgres.postgres ${PG_DIR}
+ chmod 700 ${PG_DIR}/data
+
+ einfo ">>> Initializing the database ..."
+ if [ -f ${PG_DIR}/data/PG_VERSION ] ; then
+ PG_MAJOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f1 -d.`
+ PG_MINOR=`cat ${PG_DIR}/data/PG_VERSION | cut -f2 -d.`
+ if [ ${PG_MAJOR} -lt 7 ] || [ ${PG_MAJOR} -eq 7 -a ${PG_MINOR} -lt 3 ] ; then
+ eerror "Postgres ${PV} cannot upgrade your existing databases."
+ eerror "You must remove your entire database directory to continue."
+ eerror "(database directory = ${PG_DIR})."
+ exit 1
+ else
+ einfo -n "A postgres data directory already exists from version "; cat ${PG_DIR}/data/PG_VERSION
+ einfo "Read the documentation to check how to upgrade to version ${PV}."
+ fi
+ else
+ sudo -u postgres /usr/bin/initdb --pgdata ${PG_DIR}/data
+ einfo "If you are upgrading from a pre-7.3 version of PostgreSQL, please read"
+ einfo "the README.adddepend file for information on how to properly migrate"
+ einfo "all serial columns, unique keys and foreign keys to this version."
+ fi
+}