summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2007-04-07 20:23:57 +0000
committerRyan Hill <dirtyepic@gentoo.org>2007-04-07 20:23:57 +0000
commit03fc9cc5bfd52000f623562558b4e111d1ceb2f0 (patch)
treeb449f3535f8e6439724719ba72bba94785b280b1 /dev-db
parentUpdate STLport dep to 5.1.2. Bug #172860 (diff)
downloadgentoo-2-03fc9cc5bfd52000f623562558b4e111d1ceb2f0.tar.gz
gentoo-2-03fc9cc5bfd52000f623562558b4e111d1ceb2f0.tar.bz2
gentoo-2-03fc9cc5bfd52000f623562558b4e111d1ceb2f0.zip
Add patch from Debian to fix C/C++ linkage declaration collisions, bug
#167051. (Portage version: 2.1.2.3)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/firebird/ChangeLog7
-rw-r--r--dev-db/firebird/files/firebird-1.5.3-gcc412.patch73
-rw-r--r--dev-db/firebird/firebird-1.5.3-r1.ebuild21
3 files changed, 90 insertions, 11 deletions
diff --git a/dev-db/firebird/ChangeLog b/dev-db/firebird/ChangeLog
index 6b5007159645..57bbef578f0b 100644
--- a/dev-db/firebird/ChangeLog
+++ b/dev-db/firebird/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/firebird
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/ChangeLog,v 1.50 2007/02/02 14:12:27 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/ChangeLog,v 1.51 2007/04/07 20:23:57 dirtyepic Exp $
+
+ 07 Apr 2007; Ryan Hill <dirtyepic@gentoo.org>
+ +files/firebird-1.5.3-gcc412.patch, firebird-1.5.3-r1.ebuild:
+ Add patch from Debian to fix C/C++ linkage declaration collisions, bug
+ #167051.
02 Feb 2007; Simon Stelling <blubb@gentoo.org> firebird-1.5.3-r1.ebuild:
bumping back to ~amd64 because of known problems according to upstream; bug
diff --git a/dev-db/firebird/files/firebird-1.5.3-gcc412.patch b/dev-db/firebird/files/firebird-1.5.3-gcc412.patch
new file mode 100644
index 000000000000..4b5e901d29f9
--- /dev/null
+++ b/dev-db/firebird/files/firebird-1.5.3-gcc412.patch
@@ -0,0 +1,73 @@
+diff -urNad stable~/src/jrd/jrd.cpp stable/src/jrd/jrd.cpp
+--- stable~/src/jrd/jrd.cpp 2006-10-18 21:47:43.000000000 +0300
++++ stable/src/jrd/jrd.cpp 2006-10-18 21:47:43.000000000 +0300
+@@ -135,14 +135,14 @@
+ #endif
+
+ #ifdef SERVER_SHUTDOWN
+-extern "C" {
++//extern "C" {
+ typedef struct dbf {
+ struct dbf *dbf_next;
+ USHORT dbf_length;
+ TEXT dbf_data[2];
+ } *DBF;
+
+-} // extern "C"
++//} // extern "C"
+
+ #include "../jrd/sort.h"
+ #endif /* SERVER_SHUTDOWN */
+@@ -159,9 +159,9 @@
+ /*TMN: fwd. decl. SHOULD BE IN A HEADER FILE*/
+ void ALL_print_memory_pool_info(IB_FILE * fptr, DBB databases);
+ void ALLD_print_memory_pool_info(IB_FILE * fptr);
+-extern "C" {
++//extern "C" {
+ void gds_print_delta_counters(IB_FILE *);
+-} // extern "C"
++//} // extern "C"
+
+ #endif /* SUPERSERVER */
+
+@@ -201,10 +201,10 @@
+
+ #ifdef SUPERSERVER
+
+-extern "C" {
++//extern "C" {
+ extern SLONG trace_pools;
+ static REC_MUTX_T databases_rec_mutex;
+-} // extern "C"
++//} // extern "C"
+
+ // BRS. 03/23/2003
+ // Those empty defines was substituted with #if defined(V4_THREADING) && !defined(SUPERSERVER)
+@@ -289,7 +289,7 @@
+ return TRUE;
+ }
+
+-extern "C" {
++//extern "C" {
+
+
+ #ifdef WIN_NT
+@@ -592,10 +592,10 @@
+
+
+ #ifdef SHLIB_DEFS
+-} // extern "C"
++//} // extern "C"
+ /** Use shdef.h which has all shared lib defs **/
+ #include "shdef.h"
+-extern "C" {
++//extern "C" {
+ #endif
+
+
+@@ -6620,4 +6620,4 @@
+ return true;
+ }
+
+-} // extern "C"
++//} // extern "C"
diff --git a/dev-db/firebird/firebird-1.5.3-r1.ebuild b/dev-db/firebird/firebird-1.5.3-r1.ebuild
index 0d13c674fe5e..3b6f5e2fc773 100644
--- a/dev-db/firebird/firebird-1.5.3-r1.ebuild
+++ b/dev-db/firebird/firebird-1.5.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/firebird-1.5.3-r1.ebuild,v 1.10 2007/02/02 14:12:27 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/firebird/firebird-1.5.3-r1.ebuild,v 1.11 2007/04/07 20:23:57 dirtyepic Exp $
inherit flag-o-matic eutils
@@ -9,7 +9,7 @@ MY_P=${P}.${extra_ver}
DESCRIPTION="A relational database offering many ANSI SQL-99 features"
HOMEPAGE="http://firebird.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2
- mirror://gentoo/${PN}-1.5-gcc4.patch.bz2
+ mirror://gentoo/${PN}-1.5-gcc4.patch.bz2
doc? ( http://firebird.sourceforge.net/pdfmanual/Firebird-1.5-QuickStart.pdf
ftp://ftpc.inprise.com/pub/interbase/techpubs/ib_b60_doc.zip )"
@@ -23,7 +23,6 @@ RDEPEND="xinetd? ( virtual/inetd )"
DEPEND="${RDEPEND}
doc? ( app-arch/unzip )"
-
S="${WORKDIR}"/${MY_P}
pkg_setup() {
@@ -33,11 +32,11 @@ pkg_setup() {
src_unpack() {
if use doc; then
- # Unpack docs
- mkdir ${WORKDIR}/manuals
- cd ${WORKDIR}/manuals
- unpack ib_b60_doc.zip
- cd ${WORKDIR}
+ # Unpack docs
+ mkdir ${WORKDIR}/manuals
+ cd ${WORKDIR}/manuals
+ unpack ib_b60_doc.zip
+ cd ${WORKDIR}
fi
unpack ${MY_P}.tar.bz2
@@ -46,6 +45,8 @@ src_unpack() {
epatch ${FILESDIR}/${PN}-1.5-build.patch
epatch ${WORKDIR}/${PN}-1.5-gcc4.patch
+ # Bug #167051
+ epatch ${FILESDIR}/${P}-gcc412.patch
# This file must be regenerated during build
rm ${S}/src/dsql/parse.cpp
@@ -132,8 +133,8 @@ src_install() {
# Install docs
if use doc; then
- dodoc ${DISTDIR}/Firebird-1.5-QuickStart.pdf
- dodoc ${WORKDIR}/manuals/*
+ dodoc ${DISTDIR}/Firebird-1.5-QuickStart.pdf
+ dodoc ${WORKDIR}/manuals/*
fi
}