summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-02-22 13:57:13 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-02-22 13:57:13 +0000
commitdf52d876d9dd719d3242436bb2e7a0044a58c3f5 (patch)
tree9facc86658aeff26acdcee684b93d7726db43374 /dev-db/qt-unixODBC
parentNew version see bug #161800 for details (diff)
downloadgentoo-2-df52d876d9dd719d3242436bb2e7a0044a58c3f5.tar.gz
gentoo-2-df52d876d9dd719d3242436bb2e7a0044a58c3f5.tar.bz2
gentoo-2-df52d876d9dd719d3242436bb2e7a0044a58c3f5.zip
Bump to Qt 3.3.8
(Portage version: 2.1.2-r8)
Diffstat (limited to 'dev-db/qt-unixODBC')
-rw-r--r--dev-db/qt-unixODBC/ChangeLog7
-rw-r--r--dev-db/qt-unixODBC/files/digest-qt-unixODBC-3.3.83
-rw-r--r--dev-db/qt-unixODBC/qt-unixODBC-3.3.8.ebuild62
3 files changed, 71 insertions, 1 deletions
diff --git a/dev-db/qt-unixODBC/ChangeLog b/dev-db/qt-unixODBC/ChangeLog
index d47b14eba5be..7cacdf904318 100644
--- a/dev-db/qt-unixODBC/ChangeLog
+++ b/dev-db/qt-unixODBC/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/qt-unixODBC
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/qt-unixODBC/ChangeLog,v 1.25 2007/02/22 01:09:12 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/qt-unixODBC/ChangeLog,v 1.26 2007/02/22 13:57:13 caleb Exp $
+
+*qt-unixODBC-3.3.8 (22 Feb 2007)
+
+ 22 Feb 2007; Caleb Tennis <caleb@gentoo.org> +qt-unixODBC-3.3.8.ebuild:
+ Bump to Qt 3.3.8
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/dev-db/qt-unixODBC/files/digest-qt-unixODBC-3.3.8 b/dev-db/qt-unixODBC/files/digest-qt-unixODBC-3.3.8
new file mode 100644
index 000000000000..ab51ee68ab10
--- /dev/null
+++ b/dev-db/qt-unixODBC/files/digest-qt-unixODBC-3.3.8
@@ -0,0 +1,3 @@
+MD5 37aec12c8c7b0e164957ec1aa3fd0189 qt-x11-free-3.3.8.tar.gz 17393124
+RMD160 65188370f6aa7093c9601783264825cf66b74eb4 qt-x11-free-3.3.8.tar.gz 17393124
+SHA256 975fa7b0c1e02f84d9013a9cde2123695fdd512ff4394ba89f530f4ee8597139 qt-x11-free-3.3.8.tar.gz 17393124
diff --git a/dev-db/qt-unixODBC/qt-unixODBC-3.3.8.ebuild b/dev-db/qt-unixODBC/qt-unixODBC-3.3.8.ebuild
new file mode 100644
index 000000000000..1f8d25b35cd7
--- /dev/null
+++ b/dev-db/qt-unixODBC/qt-unixODBC-3.3.8.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/qt-unixODBC/qt-unixODBC-3.3.8.ebuild,v 1.1 2007/02/22 13:57:13 caleb Exp $
+
+inherit eutils
+
+SRCTYPE="free"
+DESCRIPTION="QT version ${PV}"
+HOMEPAGE="http://www.trolltech.com/"
+SRC_URI="ftp://ftp.trolltech.com/qt/source/qt-x11-${SRCTYPE}-${PV}.tar.gz"
+IUSE=""
+LICENSE="|| ( QPL-1.0 GPL-2 )"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="~x11-libs/qt-$PV
+ dev-db/unixODBC"
+
+S=${WORKDIR}/qt-x11-${SRCTYPE}-${PV}
+
+QTBASE=/usr/qt/3
+export QTDIR=${S}
+export PLATFORM=linux-g++
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/qt-no-rpath.patch
+
+
+ cp configure configure.orig
+ sed -e 's:read acceptance:acceptance=yes:' configure.orig > configure
+}
+
+src_compile() {
+ export QTDIR=${S}
+ export SYSCONF=${D}${QTBASE}/etc/settings
+
+ # Let's just allow writing to these directories during Qt emerge
+ # as it makes Qt much happier.
+ addwrite "${QTBASE}/etc/settings"
+ addwrite "$HOME/.qt"
+
+ export YACC='byacc -d'
+
+ ./configure -sm -thread -stl -system-libjpeg -verbose -largefile \
+ -qt-imgfmt-{jpeg,mng,png} -tablet -system-libmng \
+ -system-libpng -lpthread -xft -platform ${PLATFORM} -xplatform \
+ ${PLATFORM} -xrender -prefix ${QTBASE} -fast ${myconf} \
+ -dlopen-opengl -plugin-sql-odbc -L${QTBASE}/lib || die
+
+ export QTDIR=${S}
+
+ cd $S/plugins/src/sqldrivers/odbc
+ emake || die
+}
+
+src_install() {
+ mkdir -p $D/$QTBASE/plugins/sqldrivers
+ cp $S/plugins/sqldrivers/libqsqlodbc.so $D/$QTBASE/plugins/sqldrivers/ || die
+}