summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2012-11-13 02:54:25 +0000
committerAaron W. Swenson <titanofold@gentoo.org>2012-11-13 02:54:25 +0000
commite924dffe9470726a53dfe12ce70e167b1f3282cb (patch)
treeb941ed00c1766d0cfd90016944b3c19dd44562dd /dev-db/pgbouncer
parentversion bump (diff)
downloadgentoo-2-e924dffe9470726a53dfe12ce70e167b1f3282cb.tar.gz
gentoo-2-e924dffe9470726a53dfe12ce70e167b1f3282cb.tar.bz2
gentoo-2-e924dffe9470726a53dfe12ce70e167b1f3282cb.zip
Version bump. Fixes bugs 419171 and 440940.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/pgbouncer')
-rw-r--r--dev-db/pgbouncer/ChangeLog7
-rw-r--r--dev-db/pgbouncer/pgbouncer-1.5.3.ebuild70
2 files changed, 76 insertions, 1 deletions
diff --git a/dev-db/pgbouncer/ChangeLog b/dev-db/pgbouncer/ChangeLog
index bc967186f1da..63d17b0b0e08 100644
--- a/dev-db/pgbouncer/ChangeLog
+++ b/dev-db/pgbouncer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/pgbouncer
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pgbouncer/ChangeLog,v 1.5 2012/06/18 07:53:26 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgbouncer/ChangeLog,v 1.6 2012/11/13 02:54:25 titanofold Exp $
+
+*pgbouncer-1.5.3 (13 Nov 2012)
+
+ 13 Nov 2012; <titan@gentoo.org> +pgbouncer-1.5.3.ebuild:
+ Version bump. Fixes bugs 419171 and 440940.
*pgbouncer-1.5.2 (18 Jun 2012)
diff --git a/dev-db/pgbouncer/pgbouncer-1.5.3.ebuild b/dev-db/pgbouncer/pgbouncer-1.5.3.ebuild
new file mode 100644
index 000000000000..09c1a14a0099
--- /dev/null
+++ b/dev-db/pgbouncer/pgbouncer-1.5.3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pgbouncer/pgbouncer-1.5.3.ebuild,v 1.1 2012/11/13 02:54:25 titanofold Exp $
+
+EAPI="4"
+
+inherit eutils user
+
+RESTRICT="test"
+
+DESCRIPTION="Lightweight connection pooler for PostgreSQL"
+HOMEPAGE="http://pgfoundry.org/projects/pgbouncer/"
+SRC_URI="http://pgfoundry.org/frs/download.php/3369/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="dev-libs/libevent"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ enewgroup pgbouncer
+ enewuser pgbouncer -1 -1 -1 pgbouncer
+}
+
+src_prepare() {
+ local rundir=""
+ [[ ! -d /run ]] && rundir="/var"
+
+ sed -i -e "s,${PN}.log,/var/log/${PN}/${PN}.log," \
+ -e "s,${PN}.pid,/var/run/${PN}/${PN}.pid," \
+ -e "s,etc/userlist.txt,/etc/userlist.txt," \
+ -e "s,;unix_socket_dir = /tmp,unix_socket_dir = ${rundir}/run/${PN}.sock," \
+ "${S}"/etc/pgbouncer.ini || die
+}
+
+src_configure() {
+ # --enable-debug is only used to disable stripping
+ econf \
+ --enable-debug \
+ $(use_enable debug cassert) \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ insinto /etc
+ newins etc/pgbouncer.ini pgbouncer.conf
+ newinitd "${FILESDIR}"/pgbouncer.initd "${PN}"
+
+ dodoc README NEWS AUTHORS
+ dodoc doc/*.txt
+
+ dodir /var/log/pgbouncer/
+ fowners pgbouncer:pgbouncer /var/log/pgbouncer/
+}
+
+pkg_postinst() {
+ einfo "Please read the config.txt for Configuration Directives"
+ einfo
+ einfo "For Administration Commands, see:"
+ einfo " man pgbouncer"
+ einfo
+ einfo "By default, PgBouncer does not have access to any database."
+ einfo "GRANT the permissions needed for your application and make sure that it"
+ einfo "exists in PgBouncer's auth_file."
+}