summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2014-04-04 08:21:39 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2014-04-04 08:21:39 +0000
commit12dd04425bb213fda1f5e435d215d4a3167cdda4 (patch)
tree23ec9fb995837164357506880e6c76c7573a5342 /dev-db/oracle-instantclient-sqlplus
parent+oracle-instantclient-basic-11.2.0.4: Revbump. Fix bugs #505522, #505536. Con... (diff)
downloadgentoo-2-12dd04425bb213fda1f5e435d215d4a3167cdda4.tar.gz
gentoo-2-12dd04425bb213fda1f5e435d215d4a3167cdda4.tar.bz2
gentoo-2-12dd04425bb213fda1f5e435d215d4a3167cdda4.zip
+oracle-instantclient-sqlplus-11.2.0.4: Revbump. Add RESTRICT=splitdebug.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A630CCB8)
Diffstat (limited to 'dev-db/oracle-instantclient-sqlplus')
-rw-r--r--dev-db/oracle-instantclient-sqlplus/ChangeLog10
-rw-r--r--dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.4.ebuild72
2 files changed, 80 insertions, 2 deletions
diff --git a/dev-db/oracle-instantclient-sqlplus/ChangeLog b/dev-db/oracle-instantclient-sqlplus/ChangeLog
index f712269dd2eb..e3000dfc7e1f 100644
--- a/dev-db/oracle-instantclient-sqlplus/ChangeLog
+++ b/dev-db/oracle-instantclient-sqlplus/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/oracle-instantclient-sqlplus
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-sqlplus/ChangeLog,v 1.39 2013/05/25 11:11:27 ago Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-sqlplus/ChangeLog,v 1.40 2014/04/04 08:21:39 haubi Exp $
+
+*oracle-instantclient-sqlplus-11.2.0.4 (04 Apr 2014)
+
+ 04 Apr 2014; Michael Haubenwallner <haubi@gentoo.org>
+ +oracle-instantclient-sqlplus-11.2.0.4.ebuild:
+ Revbump. Add RESTRICT=splitdebug.
25 May 2013; Agostino Sarubbo <ago@gentoo.org>
oracle-instantclient-sqlplus-11.2.0.3-r1.ebuild:
diff --git a/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.4.ebuild b/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.4.ebuild
new file mode 100644
index 000000000000..ae427247265b
--- /dev/null
+++ b/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.4.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/oracle-instantclient-sqlplus/oracle-instantclient-sqlplus-11.2.0.4.ebuild,v 1.1 2014/04/04 08:21:39 haubi Exp $
+
+EAPI="4"
+
+inherit eutils pax-utils
+
+MY_PLAT_x86="Linux x86"
+MY_A_x86="${PN#oracle-}-linux-${PV}.0.zip"
+
+MY_PLAT_amd64="Linux x86-64"
+MY_A_amd64="${PN#oracle-}-linux.x64-${PV}.0.zip"
+
+DESCRIPTION="Oracle 11g Instant Client: SQL*Plus"
+HOMEPAGE="http://www.oracle.com/technetwork/database/features/instant-client/index.html"
+SRC_URI="
+ x86? ( ${MY_A_x86} )
+ amd64? ( ${MY_A_amd64} )
+"
+
+LICENSE="OTN"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="fetch splitdebug"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+RDEPEND="~dev-db/oracle-instantclient-basic-${PV}"
+
+S="${WORKDIR}"/instantclient_11_2
+
+QA_PREBUILT="
+ usr/lib*/oracle/${PV}/client/lib*/lib*
+ usr/lib*/oracle/${PV}/client/bin/sqlplus
+"
+
+my_arch() {
+ # platform name
+ MY_PLAT=MY_PLAT_${ARCH}
+ export MY_PLAT=${!MY_PLAT}
+ # distfile
+ MY_A=MY_A_${ARCH}
+ export MY_A=${!MY_A}
+}
+
+pkg_nofetch() {
+ my_arch
+ eerror "Please go to"
+ eerror " ${HOMEPAGE%/*}/index-097480.html"
+ eerror " and download"
+ eerror "Instant Client for ${MY_PLAT}"
+ eerror " SQL*Plus: ${MY_A}"
+ eerror "After downloading, put it in:"
+ eerror " ${DISTDIR}/"
+}
+
+src_install() {
+ # all binaries go here
+ local oracle_home=usr/$(get_libdir)/oracle/${PV}/client
+ into /"${oracle_home}"
+
+ dolib.so libsqlplus$(get_libname) libsqlplusic$(get_libname)
+ dobin sqlplus
+
+ insinto /"${oracle_home}"/sqlplus/admin
+ doins glogin.sql
+
+ pax-mark -c "${ED}${oracle_home}"/bin/sqlplus || die
+
+ dosym /"${oracle_home}"/bin/sqlplus /usr/bin/sqlplus
+}