summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-11-14 06:30:20 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-11-14 06:30:20 +0000
commit85476860294f8a8a997358596a7098ca9b17c28f (patch)
tree179f7f853553c1b5318e6bbabe2c6efb1899c0c9 /dev-db/mysql-super-smack
parentVersion bump per bug #229381. (diff)
downloadgentoo-2-85476860294f8a8a997358596a7098ca9b17c28f.tar.gz
gentoo-2-85476860294f8a8a997358596a7098ca9b17c28f.tar.bz2
gentoo-2-85476860294f8a8a997358596a7098ca9b17c28f.zip
Bug #245090 - fix for GCC4.3. Bug #169538 - avoid binary filename collisions with gen-data, install as super-smack-gen-data instead.
(Portage version: 2.2_rc14/cvs/Linux 2.6.28-rc3-00249-ga622cf6 x86_64)
Diffstat (limited to 'dev-db/mysql-super-smack')
-rw-r--r--dev-db/mysql-super-smack/ChangeLog11
-rw-r--r--dev-db/mysql-super-smack/files/mysql-super-smack-1.3-gen-data.patch45
-rw-r--r--dev-db/mysql-super-smack/files/mysql-super-smack-1.3.gcc4.3.patch9
-rw-r--r--dev-db/mysql-super-smack/mysql-super-smack-1.3-r1.ebuild59
4 files changed, 123 insertions, 1 deletions
diff --git a/dev-db/mysql-super-smack/ChangeLog b/dev-db/mysql-super-smack/ChangeLog
index c7025e5e35ae..69137441a5ae 100644
--- a/dev-db/mysql-super-smack/ChangeLog
+++ b/dev-db/mysql-super-smack/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-db/mysql-super-smack
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/ChangeLog,v 1.11 2008/05/21 15:55:31 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/ChangeLog,v 1.12 2008/11/14 06:30:20 robbat2 Exp $
+
+*mysql-super-smack-1.3-r1 (14 Nov 2008)
+
+ 14 Nov 2008; Robin H. Johnson <robbat2@gentoo.org>
+ +files/mysql-super-smack-1.3-gen-data.patch,
+ +files/mysql-super-smack-1.3.gcc4.3.patch,
+ +mysql-super-smack-1.3-r1.ebuild:
+ Bug #245090 - fix for GCC4.3. Bug #169538 - avoid binary filename
+ collisions with gen-data, install as super-smack-gen-data instead.
21 May 2008; Tiziano Müller <dev-zero@gentoo.org>
mysql-super-smack-1.2.ebuild, mysql-super-smack-1.3.ebuild:
diff --git a/dev-db/mysql-super-smack/files/mysql-super-smack-1.3-gen-data.patch b/dev-db/mysql-super-smack/files/mysql-super-smack-1.3-gen-data.patch
new file mode 100644
index 000000000000..37abfe35ec97
--- /dev/null
+++ b/dev-db/mysql-super-smack/files/mysql-super-smack-1.3-gen-data.patch
@@ -0,0 +1,45 @@
+diff -Nuar super-smack-1.3.orig/smacks/select-key.smack super-smack-1.3/smacks/select-key.smack
+--- super-smack-1.3.orig/smacks/select-key.smack 2005-05-30 03:04:38.000000000 -0700
++++ super-smack-1.3/smacks/select-key.smack 2008-11-13 22:27:48.125627179 -0800
+@@ -24,7 +24,7 @@
+ min_rows "90000"; // the table must have at least that many rows
+ data_file "words.dat"; // if the table is empty, load the data from
+ //this file
+- gen_data_file "gen-data -n 90000 -f %12-12s%n,%25-25s,%n,%d";
++ gen_data_file "super-smack-gen-data -n 90000 -f %12-12s%n,%25-25s,%n,%d";
+ // if the file above does not exist, generate it with the above shell command
+ // you can replace this command with anything that prints comma-delimited
+ // data to stdout, just make sure you have the right number of columns
+diff -Nuar super-smack-1.3.orig/smacks/update-select.smack super-smack-1.3/smacks/update-select.smack
+--- super-smack-1.3.orig/smacks/update-select.smack 2005-05-30 03:04:51.000000000 -0700
++++ super-smack-1.3/smacks/update-select.smack 2008-11-13 22:27:45.070167829 -0800
+@@ -24,7 +24,7 @@
+ min_rows "90000"; // the table must have at least that many rows
+ data_file "words.dat"; // if the table is empty, load the data from
+ //this file
+- gen_data_file "gen-data -n 90000 -f %12-12s%n,%25-25s,%n,%d";
++ gen_data_file "super-smack-gen-data -n 90000 -f %12-12s%n,%25-25s,%n,%d";
+ // if the file above does not exist, generate it with the above command
+ }
+
+diff -Nuar super-smack-1.3.orig/src/Makefile.am super-smack-1.3/src/Makefile.am
+--- super-smack-1.3.orig/src/Makefile.am 2001-02-24 03:44:30.000000000 -0800
++++ super-smack-1.3/src/Makefile.am 2008-11-13 22:27:37.693573246 -0800
+@@ -19,7 +19,7 @@
+ INCLUDES = @MYSQL_INCLUDE@ @PGSQL_INCLUDE@ @ORACLE_INCLUDE@
+
+ noinst_PROGRAMS=test-dictionary test-client test_tcp_client
+-bin_PROGRAMS=super-smack gen-data
++bin_PROGRAMS=super-smack super-smack-gen-data
+ test_dictionary_SOURCES=test-dictionary.cc \
+ dictionary.cc dictionary.h \
+ die.cc die.h \
+@@ -57,7 +57,7 @@
+ tcp_client.h tcp_client.cc
+ super_smack_LDADD = @MYSQL_LIB@ @PGSQL_LIB@ @ORACLE_LIB@
+
+-gen_data_SOURCES=gen-data.cc die.cc die.h
++super_smack_gen_data_SOURCES=gen-data.cc die.cc die.h
+
+ # yacc needs to generate a y.tab.h
+ YFLAGS = -d
diff --git a/dev-db/mysql-super-smack/files/mysql-super-smack-1.3.gcc4.3.patch b/dev-db/mysql-super-smack/files/mysql-super-smack-1.3.gcc4.3.patch
new file mode 100644
index 000000000000..23bcd56e019c
--- /dev/null
+++ b/dev-db/mysql-super-smack/files/mysql-super-smack-1.3.gcc4.3.patch
@@ -0,0 +1,9 @@
+--- src/dictionary.h.orig 2008-10-31 19:12:51.000000000 +0100
++++ src/dictionary.h 2008-10-31 19:13:12.000000000 +0100
+@@ -23,6 +23,7 @@
+
+ #include <string>
+ #include <vector>
++#include <cstring>
+ #include <time.h>
+ #include <stdlib.h>
diff --git a/dev-db/mysql-super-smack/mysql-super-smack-1.3-r1.ebuild b/dev-db/mysql-super-smack/mysql-super-smack-1.3-r1.ebuild
new file mode 100644
index 000000000000..fcbe9131d656
--- /dev/null
+++ b/dev-db/mysql-super-smack/mysql-super-smack-1.3-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-super-smack/mysql-super-smack-1.3-r1.ebuild,v 1.1 2008/11/14 06:30:20 robbat2 Exp $
+
+WANT_AUTOMAKE="1.4"
+
+inherit eutils autotools
+
+MY_PN="super-smack"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="MySQL Super Smack is a benchmarking, stress testing, and load generation tool for MySQL & PostGreSQL."
+HOMEPAGE="http://vegan.net/tony/supersmack/"
+SRC_URI="http://vegan.net/tony/supersmack/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mysql postgres"
+
+DEPEND="mysql? ( virtual/mysql )
+ postgres? ( virtual/postgresql-server )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use !mysql && use !postgres && die "You need to use at least one of USE=mysql or USE=postgres for benchmarking!"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.2.destdir.patch
+ epatch "${FILESDIR}"/${PN}-1.3.amd64.patch
+ epatch "${FILESDIR}"/${PN}-1.3.gcc4.3.patch
+ epatch "${FILESDIR}"/${PN}-1.3-gen-data.patch
+
+ eautomake || die "automake failed"
+}
+
+src_compile() {
+ local myconf=""
+ use mysql && myconf="${myconf} --with-mysql"
+ use postgres && myconf="${myconf} --with-pgsql"
+ myconf="${myconf} --with-datadir=/var/tmp/${MY_PN}"
+ myconf="${myconf} --with-smacks-dir=/usr/share/${MY_PN}"
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc CHANGES INSTALL MANUAL README TUTORIAL
+}
+
+pkg_postinst() {
+ elog "The gen-data binary is now installed as super-smack-gen-data"
+}