summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Briesenick <sbriesen@gentoo.org>2011-10-19 12:15:37 +0000
committerStefan Briesenick <sbriesen@gentoo.org>2011-10-19 12:15:37 +0000
commitf71889611e0ffa1eabc948f8c16b324cccc34b97 (patch)
tree1201e7ab1555bd164d9ffe6e2e0807db4d179b65 /dev-db/lib_mysqludf_log
parentinitial commit (diff)
downloadgentoo-2-f71889611e0ffa1eabc948f8c16b324cccc34b97.tar.gz
gentoo-2-f71889611e0ffa1eabc948f8c16b324cccc34b97.tar.bz2
gentoo-2-f71889611e0ffa1eabc948f8c16b324cccc34b97.zip
initial commit
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/lib_mysqludf_log')
-rw-r--r--dev-db/lib_mysqludf_log/ChangeLog11
-rw-r--r--dev-db/lib_mysqludf_log/files/lib_mysqludf_log-warnings.patch11
-rw-r--r--dev-db/lib_mysqludf_log/lib_mysqludf_log-0.0.2.ebuild57
-rw-r--r--dev-db/lib_mysqludf_log/metadata.xml9
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-db/lib_mysqludf_log/ChangeLog b/dev-db/lib_mysqludf_log/ChangeLog
new file mode 100644
index 000000000000..5a05221dc667
--- /dev/null
+++ b/dev-db/lib_mysqludf_log/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for dev-db/lib_mysqludf_log
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/lib_mysqludf_log/ChangeLog,v 1.1 2011/10/19 12:15:36 sbriesen Exp $
+
+*lib_mysqludf_log-0.0.2 (19 Oct 2011)
+
+ 19 Oct 2011; Stefan Briesenick <sbriesen@gentoo.org>
+ +lib_mysqludf_log-0.0.2.ebuild, +files/lib_mysqludf_log-warnings.patch,
+ +metadata.xml:
+ initial commit
+
diff --git a/dev-db/lib_mysqludf_log/files/lib_mysqludf_log-warnings.patch b/dev-db/lib_mysqludf_log/files/lib_mysqludf_log-warnings.patch
new file mode 100644
index 000000000000..64b59639a328
--- /dev/null
+++ b/dev-db/lib_mysqludf_log/files/lib_mysqludf_log-warnings.patch
@@ -0,0 +1,11 @@
+--- lib_mysqludf_log.c.orig 2008-07-07 01:17:06.000000000 +0200
++++ lib_mysqludf_log.c 2011-10-18 12:50:52.000000000 +0200
+@@ -159,7 +159,7 @@
+ } else {
+ fmt = (char *)initid->ptr;
+ memcpy(fmt, "%0.", 3);
+- sprintf(fmt+3, "%d", args->lengths[0]<=9999? args->lengths[0]: 9999);
++ sprintf(fmt+3, "%d", (int)(args->lengths[0]<=9999? args->lengths[0]: 9999));
+ numDigits = strlen(fmt + 4);
+ memcpy(fmt + 4 + numDigits, "s\n\0", 3);
+ fprintf(stderr, fmt, args->args[0]);
diff --git a/dev-db/lib_mysqludf_log/lib_mysqludf_log-0.0.2.ebuild b/dev-db/lib_mysqludf_log/lib_mysqludf_log-0.0.2.ebuild
new file mode 100644
index 000000000000..69cf1a9f8f17
--- /dev/null
+++ b/dev-db/lib_mysqludf_log/lib_mysqludf_log-0.0.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/lib_mysqludf_log/lib_mysqludf_log-0.0.2.ebuild,v 1.1 2011/10/19 12:15:36 sbriesen Exp $
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="MySQL UDF to write to log files"
+HOMEPAGE="http://www.mysqludf.org/lib_mysqludf_log/"
+SRC_URI="http://www.mysqludf.org/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/mysql-5.1"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+# compile helper
+_compile() {
+ local CC="$(tc-getCC)"
+ echo "${CC} ${@}" && "${CC}" "${@}"
+}
+
+pkg_setup() {
+ MYSQL_PLUGINDIR="$(mysql_config --plugindir)"
+ MYSQL_INCLUDE="$(mysql_config --include)"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-warnings.patch"
+}
+
+src_compile() {
+ _compile ${CFLAGS} -Wall -fPIC ${MYSQL_INCLUDE} \
+ -shared ${LDFLAGS} -o ${PN}.so ${PN}.c
+}
+
+src_install() {
+ exeinto "${MYSQL_PLUGINDIR}"
+ doexe ${PN}.so
+ dodoc ${PN}.sql
+}
+
+pkg_postinst() {
+ elog
+ elog "Please have a look at the documentation, how to"
+ elog "enable/disable the UDF functions of ${PN}."
+ elog
+ elog "The documentation is located here:"
+ elog "/usr/share/doc/${PF}"
+ elog
+}
diff --git a/dev-db/lib_mysqludf_log/metadata.xml b/dev-db/lib_mysqludf_log/metadata.xml
new file mode 100644
index 000000000000..abc550987baf
--- /dev/null
+++ b/dev-db/lib_mysqludf_log/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>sbriesen@gentoo.org</email>
+ <name>Stefan Briesenick</name>
+ </maintainer>
+</pkgmetadata>