summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-09-19 05:25:54 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-09-19 05:25:54 +0000
commitec72bef4d37ca5d06de762aa60d58fd5ae06e504 (patch)
tree31035bd7a93cfb42c8cae6ccb69ecf6804d72c1f /dev-db/drizzle
parentMask drizzle 7.2 for testing. (diff)
downloadgentoo-2-ec72bef4d37ca5d06de762aa60d58fd5ae06e504.tar.gz
gentoo-2-ec72bef4d37ca5d06de762aa60d58fd5ae06e504.tar.bz2
gentoo-2-ec72bef4d37ca5d06de762aa60d58fd5ae06e504.zip
Version bump (masked).
(Portage version: 2.2.0_alpha128/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/drizzle')
-rw-r--r--dev-db/drizzle/ChangeLog8
-rw-r--r--dev-db/drizzle/drizzle-7.2.3.ebuild156
-rw-r--r--dev-db/drizzle/files/drizzle-7.2.3+automake-1.12.patch33
-rw-r--r--dev-db/drizzle/files/drizzle-7.2.3-libtool.patch13
4 files changed, 209 insertions, 1 deletions
diff --git a/dev-db/drizzle/ChangeLog b/dev-db/drizzle/ChangeLog
index 22396731feba..9e42b3fa7973 100644
--- a/dev-db/drizzle/ChangeLog
+++ b/dev-db/drizzle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/drizzle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/drizzle/ChangeLog,v 1.29 2012/06/24 21:19:11 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/drizzle/ChangeLog,v 1.30 2012/09/19 05:25:54 flameeyes Exp $
+
+*drizzle-7.2.3 (19 Sep 2012)
+
+ 19 Sep 2012; Diego E. Pettenò <flameeyes@gentoo.org> +drizzle-7.2.3.ebuild,
+ +files/drizzle-7.2.3+automake-1.12.patch, +files/drizzle-7.2.3-libtool.patch:
+ Version bump (masked).
24 Jun 2012; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
Update metadata, helps my own bug templating script.
diff --git a/dev-db/drizzle/drizzle-7.2.3.ebuild b/dev-db/drizzle/drizzle-7.2.3.ebuild
new file mode 100644
index 000000000000..6658c3e8080a
--- /dev/null
+++ b/dev-db/drizzle/drizzle-7.2.3.ebuild
@@ -0,0 +1,156 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/drizzle/drizzle-7.2.3.ebuild,v 1.1 2012/09/19 05:25:54 flameeyes Exp $
+
+EAPI=4
+
+inherit flag-o-matic libtool autotools eutils pam user versionator
+
+DESCRIPTION="Database optimized for Cloud and Net applications"
+HOMEPAGE="http://drizzle.org"
+SRC_URI="http://launchpad.net/drizzle/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug tcmalloc doc memcache curl pam gearman +md5 ldap"
+
+RDEPEND="tcmalloc? ( dev-util/google-perftools )
+ sys-libs/readline
+ sys-apps/util-linux
+ dev-libs/libpcre
+ dev-libs/openssl
+ >=dev-libs/libevent-1.4
+ >=dev-libs/protobuf-2.1.0
+ gearman? ( >=sys-cluster/gearmand-0.12 )
+ pam? ( sys-libs/pam )
+ curl? ( net-misc/curl )
+ memcache? ( >=dev-libs/libmemcached-0.39 )
+ md5? ( >=dev-libs/libgcrypt-1.4.2 )
+ >=dev-libs/boost-1.32
+ ldap? ( net-nds/openldap )
+ !dev-db/libdrizzle"
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/intltool
+ dev-util/gperf
+ sys-devel/flex
+ doc? ( app-doc/doxygen )
+ >=dev-util/boost-build-1.32"
+
+pkg_setup() {
+ enewuser drizzle -1 -1 /dev/null nogroup
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libtool.patch
+ epatch "${FILESDIR}"/${P}+automake-1.12.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+
+ if use debug; then
+ append-cppflags -DDEBUG
+ fi
+
+ # while I applaud upstreams goal of 0 compiler warnings
+ # the 1412 release didn't achieve it.
+ append-flags -Wno-error
+
+ # NOTE disable-all and without-all no longer recognized options
+ # NOTE using --enable on some plugins can cause test failures.
+ # --with should be used instead. A discussion about this here:
+ # https://bugs.launchpad.net/drizzle/+bug/598659
+ # TODO (upstream)
+ # $(use_with memcache memcached-stats-plugin) \
+ # $(use_with memcache memcached-functions-plugin) \
+
+ econf \
+ --disable-static \
+ --disable-dependency-tracking \
+ --disable-mtmalloc \
+ --without-hello-world-plugin \
+ --disable-rabbitmq-plugin --without-rabbitmq-plugin \
+ --disable-zeromq-plugin --without-zeromq-plugin \
+ --with-auth-test-plugin \
+ --with-auth-file-plugin \
+ --with-simple-user-policy-plugin \
+ --enable-logging-stats-plugin \
+ --with-logging-stats-plugin \
+ --enable-console-plugin \
+ $(use_enable tcmalloc) \
+ $(use_enable memcache libmemcached) \
+ $(use_enable gearman libgearman) \
+ $(use_enable ldap libldap) \
+ $(use_with curl auth-http-plugin) \
+ $(use_with pam auth-pam-plugin) \
+ $(use_with md5 md5-plugin) \
+ $(use_with gearman gearman-udf-plugin) \
+ $(use_with gearman logging-gearman-plugin) \
+ $(use_with ldap auth-ldap-plugin) \
+ ${myconf}
+}
+
+src_compile() {
+ emake V=1 all $(use doc && echo doxygen)
+}
+
+# currently not working as of 7.2.3
+RESTRICT=test
+
+src_test() {
+ if [[ ${EUID} == 0 ]]; then
+ eerror "You cannot run tests as root."
+ eerror "Please enable FEATURES=userpriv before proceeding."
+ return 1
+ fi
+
+ # If you want to turn off a test, rename to suffix of .DISABLED
+ # Explicitly allow parallel make check
+ emake check
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS NEWS README
+
+ find "${D}" -name '*.la' -delete || die
+
+ if use doc; then
+ docinto apidoc
+ pushd docs/html
+ dohtml -r .
+ popd
+ fi
+
+ newinitd "${FILESDIR}"/drizzle.init.d drizzled
+ newconfd "${FILESDIR}"/drizzle.conf.d drizzled
+
+ if ! use gearman; then
+ sed -i -e '/need gearmand/d' "${D}"/etc/init.d/drizzled \
+ || die "unable to sed init script (gearman)"
+ fi
+
+ if ! use memcache; then
+ sed -i -e '/need memcached/d' "${D}"/etc/init.d/drizzled \
+ || die "unable to sed init script (memcache)"
+ fi
+
+ keepdir /var/run/drizzle
+ keepdir /var/log/drizzle
+ keepdir /var/lib/drizzle/drizzled
+ keepdir /etc/drizzle
+
+ fperms 0755 /var/run/drizzle
+ fperms 0755 /var/log/drizzle
+ fperms -R 0700 /var/lib/drizzle
+
+ fowners drizzle:nogroup /var/run/drizzle
+ fowners drizzle:nogroup /var/log/drizzle
+ fowners -R drizzle:nogroup /var/lib/drizzle
+
+ pamd_mimic system-auth drizzle auth account session
+}
diff --git a/dev-db/drizzle/files/drizzle-7.2.3+automake-1.12.patch b/dev-db/drizzle/files/drizzle-7.2.3+automake-1.12.patch
new file mode 100644
index 000000000000..4f33dc557a5a
--- /dev/null
+++ b/dev-db/drizzle/files/drizzle-7.2.3+automake-1.12.patch
@@ -0,0 +1,33 @@
+Index: drizzle-7.2.3/m4/pandora_canonical.m4
+===================================================================
+--- drizzle-7.2.3.orig/m4/pandora_canonical.m4
++++ drizzle-7.2.3/m4/pandora_canonical.m4
+@@ -98,9 +98,9 @@ AC_DEFUN([PANDORA_CANONICAL_TARGET],[
+ AC_CANONICAL_TARGET
+
+ m4_if(PCT_DONT_SUPRESS_INCLUDE,yes,[
+- AM_INIT_AUTOMAKE(-Wall -Werror -Wno-portability subdir-objects foreign tar-ustar)
++ AM_INIT_AUTOMAKE(-Wall -Wno-portability subdir-objects foreign tar-ustar)
+ ],[
+- AM_INIT_AUTOMAKE(-Wall -Werror -Wno-portability nostdinc subdir-objects foreign tar-ustar)
++ AM_INIT_AUTOMAKE(-Wall -Wno-portability nostdinc subdir-objects foreign tar-ustar)
+ ])
+
+ m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
+Index: drizzle-7.2.3/tests/include.am
+===================================================================
+--- drizzle-7.2.3.orig/tests/include.am
++++ drizzle-7.2.3/tests/include.am
+@@ -101,10 +101,10 @@ EXTRA_DIST += \
+ check-local: tests/var/drizzle test-drizzle
+
+ tests/var:
+- $(mkdir_p) tests/var
++ $(MKDIR_P) tests/var
+
+ tests/var/drizzle: tests/var
+- $(mkdir_p) tests/var/drizzle
++ $(MKDIR_P) tests/var/drizzle
+
+
+ # dtr - a shortcut for executing test-run.pl
diff --git a/dev-db/drizzle/files/drizzle-7.2.3-libtool.patch b/dev-db/drizzle/files/drizzle-7.2.3-libtool.patch
new file mode 100644
index 000000000000..609b8adfd67e
--- /dev/null
+++ b/dev-db/drizzle/files/drizzle-7.2.3-libtool.patch
@@ -0,0 +1,13 @@
+Index: drizzle-7.2.3/libdrizzle-1.0/include.am
+===================================================================
+--- drizzle-7.2.3.orig/libdrizzle-1.0/include.am
++++ drizzle-7.2.3/libdrizzle-1.0/include.am
+@@ -48,7 +48,7 @@ libdrizzle_1_0_libdrizzle_la_LDFLAGS= \
+ -version-info \
+ $(LIBDRIZZLE_LIBRARY_VERSION)
+
+-libdrizzle_1_0_libdrizzle_la_LIBADD= $(LIBSSL)
++libdrizzle_1_0_libdrizzle_la_LIBADD= $(LTLIBSSL)
+
+ libdrizzle_1_0_libdrizzle_la_SOURCES= \
+ libdrizzle/column.cc \