summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-21 16:11:47 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-06-21 16:11:47 +0000
commitc5d16283fa6d0930188ab755690c09e646d7fd4b (patch)
treeb34d9368a430c0351525f33f02d08a0d4e343b43 /dev-db/drizzle
parentStable for HPPA (bug #419473). (diff)
downloadgentoo-2-c5d16283fa6d0930188ab755690c09e646d7fd4b.tar.gz
gentoo-2-c5d16283fa6d0930188ab755690c09e646d7fd4b.tar.bz2
gentoo-2-c5d16283fa6d0930188ab755690c09e646d7fd4b.zip
Remove old; use append-cppflags where it makes sense; fix on automake 1.11 as it fails with 1.12.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/drizzle')
-rw-r--r--dev-db/drizzle/ChangeLog8
-rw-r--r--dev-db/drizzle/drizzle-7.0.2011.03.13.ebuild174
-rw-r--r--dev-db/drizzle/drizzle-7.1.33.ebuild10
-rw-r--r--dev-db/drizzle/files/drizzle-2009.12.1240-nolint.patch10
4 files changed, 12 insertions, 190 deletions
diff --git a/dev-db/drizzle/ChangeLog b/dev-db/drizzle/ChangeLog
index 1eef30086d4b..89da56ed185b 100644
--- a/dev-db/drizzle/ChangeLog
+++ b/dev-db/drizzle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/drizzle
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/drizzle/ChangeLog,v 1.27 2012/06/04 06:27:25 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/drizzle/ChangeLog,v 1.28 2012/06/21 16:11:46 flameeyes Exp $
+
+ 21 Jun 2012; Diego E. Pettenò <flameeyes@gentoo.org>
+ -drizzle-7.0.2011.03.13.ebuild, -files/drizzle-2009.12.1240-nolint.patch,
+ drizzle-7.1.33.ebuild:
+ Remove old; use append-cppflags where it makes sense; fix on automake 1.11 as
+ it fails with 1.12.
04 Jun 2012; Zac Medico <zmedico@gentoo.org> drizzle-7.0.2011.03.13.ebuild,
drizzle-7.1.33.ebuild:
diff --git a/dev-db/drizzle/drizzle-7.0.2011.03.13.ebuild b/dev-db/drizzle/drizzle-7.0.2011.03.13.ebuild
deleted file mode 100644
index 074b6986c138..000000000000
--- a/dev-db/drizzle/drizzle-7.0.2011.03.13.ebuild
+++ /dev/null
@@ -1,174 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/drizzle/drizzle-7.0.2011.03.13.ebuild,v 1.2 2012/06/04 06:27:25 zmedico Exp $
-
-EAPI=2
-
-inherit flag-o-matic libtool autotools eutils pam user versionator
-
-# Upstream version numbers live in a directory that is [+-][1-2] days either
-# side of the name the tarball! eg:
-# https://launchpad.net/drizzle/7.0/2011-03-14/+download/drizzle7-2011.03.13.tar.gz
-# If the tarball falls on the last day of the month, be really careful!
-# We name the ebuild for the tarball, and deal with the mess of the name instead
-
-MY_PN="${PN}$(get_version_component_range 1-1)"
-MY_PV="$(get_version_component_range 3-5)"
-MY_P="${MY_PN}-${MY_PV}"
-
-# This is the mess of the name
-DIR_PV_B="$(get_version_component_range 1-2)"
-DIR_PV_DATE="2011-03-14"
-DIR_PV="${DIR_PV_B}/${DIR_PV_DATE}"
-
-S="${WORKDIR}/${MY_P}"
-
-DESCRIPTION="Database optimized for Cloud and Net applications"
-HOMEPAGE="http://drizzle.org"
-SRC_URI="http://launchpad.net/drizzle/${DIR_PV}/+download/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug tcmalloc doc memcache curl pam gearman +md5 ldap haildb"
-
-RDEPEND="tcmalloc? ( dev-util/google-perftools )
- sys-libs/readline
- sys-apps/util-linux
- dev-libs/libpcre
- >=dev-libs/libevent-1.4
- >=dev-libs/protobuf-2.1.0
- gearman? ( >=sys-cluster/gearmand-0.12 )
- pam? ( sys-libs/pam )
- curl? ( net-misc/curl )
- memcache? ( >=dev-libs/libmemcached-0.39 )
- md5? ( >=dev-libs/libgcrypt-1.4.2 )
- haildb? ( >=dev-db/haildb-2.3.2 )
- >=dev-libs/boost-1.32
- ldap? ( net-nds/openldap )
- !dev-db/libdrizzle"
-
-DEPEND="${RDEPEND}
- sys-devel/gettext
- dev-util/intltool
- dev-util/gperf
- sys-devel/flex
- doc? ( app-doc/doxygen )
- >=dev-util/boost-build-1.32"
-
-pkg_setup() {
- enewuser drizzle -1 -1 /dev/null nogroup
-}
-
-src_prepare() {
- #epatch "${FILESDIR}/${PN}-2009.12.1240-nolint.patch"
-
- AT_M4DIR="m4" eautoreconf
- elibtoolize
-}
-
-src_configure() {
- local myconf=
-
- if use debug; then
- append-flags -DDEBUG
- fi
-
- # while I applaud upstreams goal of 0 compiler warnings
- # the 1412 release didn't achieve it.
- append-flags -Wno-error
-
- # Bug #362901
- append-flags -DBOOST_FILESYSTEM_VERSION=2
-
- # NOTE disable-all and without-all no longer recognized options
- # NOTE using --enable on some plugins can cause test failures.
- # --with should be used instead. A discussion about this here:
- # https://bugs.launchpad.net/drizzle/+bug/598659
- # TODO (upstream)
- # $(use_with memcache memcached-stats-plugin) \
- # $(use_with memcache memcached-functions-plugin) \
-
- econf \
- --disable-static \
- --disable-dependency-tracking \
- --disable-mtmalloc \
- $(use_enable tcmalloc) \
- $(use_enable memcache libmemcached) \
- $(use_enable gearman libgearman) \
- $(use_enable ldap libldap) \
- $(use_with curl auth-http-plugin) \
- $(use_with pam auth-pam-plugin) \
- $(use_with md5 md5-plugin) \
- $(use_with gearman gearman-udf-plugin) \
- $(use_with gearman logging-gearman-plugin) \
- $(use_with ldap auth-ldap-plugin) \
- --without-hello-world-plugin \
- --disable-pbxt-plugin --without-pbxt-plugin \
- --disable-rabbitmq-plugin --without-rabbitmq-plugin \
- $(use_enable haildb libhaildb) \
- $(use_enable haildb haildb-plugin) \
- $(use_with haildb haildb-plugin) \
- --with-auth-test-plugin \
- --with-auth-file-plugin \
- --with-simple-user-policy-plugin \
- --enable-logging-stats-plugin \
- --with-logging-stats-plugin \
- --enable-console-plugin \
- --enable-archive-plugin \
- ${myconf}
-
-}
-
-src_compile() {
- emake all $(use doc && echo doxygen) || die "build failed"
-}
-
-# 5-10 min eta
-src_test() {
- # If you want to turn off a test, rename to suffix of .DISABLED
- # Explicitly allow parallel make check
- emake check || die "tests failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "install failed"
- dodoc AUTHORS NEWS README || die
-
- find "${D}" -name '*.la' -delete || die
-
- if use doc; then
- docinto apidoc
- pushd docs/html
- dohtml -r .
- popd
- fi
-
- newinitd "${FILESDIR}"/drizzle.init.d drizzled || die
- newconfd "${FILESDIR}"/drizzle.conf.d drizzled || die
-
- if ! use gearman; then
- sed -i -e '/need gearmand/d' "${D}"/etc/init.d/drizzled \
- || die "unable to sed init script (gearman)"
- fi
-
- if ! use memcache; then
- sed -i -e '/need memcached/d' "${D}"/etc/init.d/drizzled \
- || die "unable to sed init script (memcache)"
- fi
-
- keepdir /var/run/drizzle || die
- keepdir /var/log/drizzle || die
- keepdir /var/lib/drizzle/drizzled || die
- keepdir /etc/drizzle || die
-
- fperms 0755 /var/run/drizzle || die
- fperms 0755 /var/log/drizzle || die
- fperms -R 0700 /var/lib/drizzle || die
-
- fowners drizzle:nogroup /var/run/drizzle || die
- fowners drizzle:nogroup /var/log/drizzle || die
- fowners -R drizzle:nogroup /var/lib/drizzle || die
-
- pamd_mimic system-auth drizzle auth account session
-}
diff --git a/dev-db/drizzle/drizzle-7.1.33.ebuild b/dev-db/drizzle/drizzle-7.1.33.ebuild
index eb1ed66a4bc6..4bffad561b39 100644
--- a/dev-db/drizzle/drizzle-7.1.33.ebuild
+++ b/dev-db/drizzle/drizzle-7.1.33.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/drizzle/drizzle-7.1.33.ebuild,v 1.2 2012/06/04 06:27:25 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/drizzle/drizzle-7.1.33.ebuild,v 1.3 2012/06/21 16:11:46 flameeyes Exp $
EAPI=2
+WANT_AUTOMAKE=1.11
+
inherit flag-o-matic libtool autotools eutils pam user versionator
MY_P="${P}-stable"
@@ -48,8 +50,6 @@ pkg_setup() {
}
src_prepare() {
- #epatch "${FILESDIR}/${PN}-2009.12.1240-nolint.patch"
-
AT_M4DIR="m4" eautoreconf
elibtoolize
}
@@ -58,7 +58,7 @@ src_configure() {
local myconf=
if use debug; then
- append-flags -DDEBUG
+ append-cppflags -DDEBUG
fi
# while I applaud upstreams goal of 0 compiler warnings
@@ -66,7 +66,7 @@ src_configure() {
append-flags -Wno-error
# Bug #362901
- append-flags -DBOOST_FILESYSTEM_VERSION=2
+ append-cppflags -DBOOST_FILESYSTEM_VERSION=2
# NOTE disable-all and without-all no longer recognized options
# NOTE using --enable on some plugins can cause test failures.
diff --git a/dev-db/drizzle/files/drizzle-2009.12.1240-nolint.patch b/dev-db/drizzle/files/drizzle-2009.12.1240-nolint.patch
deleted file mode 100644
index 242d6f00b381..000000000000
--- a/dev-db/drizzle/files/drizzle-2009.12.1240-nolint.patch
+++ /dev/null
@@ -1,10 +0,0 @@
-Index: drizzle-2009.12.1240/config/lint-source.am
-===================================================================
---- drizzle-2009.12.1240.orig/config/lint-source.am
-+++ drizzle-2009.12.1240/config/lint-source.am
-@@ -27,4 +27,4 @@ lint-rules-gen:
- .PHONY: cleanlints lint-rules-gen
-
- # dynamic rules
--include config/lint-rules.am
-+#include config/lint-rules.am