summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris White <chriswhite@gentoo.org>2005-09-03 01:02:57 +0000
committerChris White <chriswhite@gentoo.org>2005-09-03 01:02:57 +0000
commitab21d73e5c743a0b82922b2ea52676c7dd3fe09c (patch)
treecea1dd19132e031e8b9cbaa487d68b3a899925b6 /dev-db/cdb
parentbug 94893 and bug 97448 (diff)
downloadgentoo-2-ab21d73e5c743a0b82922b2ea52676c7dd3fe09c.tar.gz
gentoo-2-ab21d73e5c743a0b82922b2ea52676c7dd3fe09c.tar.bz2
gentoo-2-ab21d73e5c743a0b82922b2ea52676c7dd3fe09c.zip
Ok first off, I made uinit32.h actually get installed. If it's not, cdb.h cries about not having it. Also, I installed cdb.a and symlinked it to libcdb.a, as there's programs that check for cdb.a and will break if it's not there. Symlink so -lcdb doesn't break as well.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-db/cdb')
-rw-r--r--dev-db/cdb/ChangeLog8
-rw-r--r--dev-db/cdb/Manifest2
-rw-r--r--dev-db/cdb/cdb-0.75.ebuild16
3 files changed, 21 insertions, 5 deletions
diff --git a/dev-db/cdb/ChangeLog b/dev-db/cdb/ChangeLog
index 3308ca310019..07e0b271cd3f 100644
--- a/dev-db/cdb/ChangeLog
+++ b/dev-db/cdb/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/cdb
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/ChangeLog,v 1.16 2005/08/28 20:04:53 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/ChangeLog,v 1.17 2005/09/03 01:02:57 chriswhite Exp $
+
+ 03 Sep 2005; Chris White <chriswhite@gentoo.org> cdb-0.75.ebuild:
+ Ok first off, I made uinit32.h actually get installed. If it's not, cdb.h
+ cries about not having it. Also, I installed cdb.a and symlinked it to
+ libcdb.a, as there's programs that check for cdb.a and will break if it's
+ not there. Symlink so -lcdb doesn't break as well.
28 Aug 2005; Fabian Groffen <grobian@gentoo.org> cdb-0.75.ebuild:
Marking ~ppc-macos (bug #87701)
diff --git a/dev-db/cdb/Manifest b/dev-db/cdb/Manifest
index 7e51461710d2..9d7b333be4e5 100644
--- a/dev-db/cdb/Manifest
+++ b/dev-db/cdb/Manifest
@@ -1,4 +1,4 @@
-MD5 8709ac7967095f30e74de756c3db8d21 cdb-0.75.ebuild 1187
MD5 8c2d5b8f14b4a0de52ec9f3c29682ba0 ChangeLog 1947
+MD5 1f3262a5fae1a8313ae9e3e06b816633 cdb-0.75.ebuild 1511
MD5 1a3e347b6ebfe24f60f255100a2af4a0 files/cdb-0.75-errno.diff 243
MD5 7f28ce1d896bd4416c27bb55d6f63cdf files/digest-cdb-0.75 59
diff --git a/dev-db/cdb/cdb-0.75.ebuild b/dev-db/cdb/cdb-0.75.ebuild
index 996cede11b64..dc786d22c024 100644
--- a/dev-db/cdb/cdb-0.75.ebuild
+++ b/dev-db/cdb/cdb-0.75.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75.ebuild,v 1.22 2005/08/28 20:04:53 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75.ebuild,v 1.23 2005/09/03 01:02:57 chriswhite Exp $
inherit eutils toolchain-funcs
@@ -38,9 +38,19 @@ src_compile() {
src_install() {
dobin cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest || \
die "dobin failed"
- newlib.a cdb.a libcdb.a || die "newlib.a failed"
+
+ # ok so.. first off, some automakes fail at not finding
+ # cdb.a, so install that
+ dolib cdb.a
+
+ # then do this pretty little symlinking to solve the somewhat
+ # cosmetic library issue at hand
+ dosym /usr/$(get_libdir)/cdb.a /usr/$(get_libdir)/libcdb.a || die "newlib.a failed"
+
+ # uint32.h needs installation too, otherwise compiles depending
+ # on it will fail
insinto /usr/include
- doins cdb.h || die "doins failed"
+ doins cdb.h uint32.h || die "doins failed"
dodoc CHANGES FILES README SYSDEPS TARGETS TODO VERSION || \
die "dodoc failed"