summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Longinotti <chtekk@gentoo.org>2007-04-24 17:30:05 +0000
committerLuca Longinotti <chtekk@gentoo.org>2007-04-24 17:30:05 +0000
commit82d4af0408bfb29cc6a6b93a997407f6c829a328 (patch)
tree4ead245c7a5da36190e93ac9f19d9687037ec88f /dev-db/cdb/cdb-0.75-r2.ebuild
parentBump to 4.4.1 (diff)
downloadgentoo-2-82d4af0408bfb29cc6a6b93a997407f6c829a328.tar.gz
gentoo-2-82d4af0408bfb29cc6a6b93a997407f6c829a328.tar.bz2
gentoo-2-82d4af0408bfb29cc6a6b93a997407f6c829a328.zip
Cleanup.
(Portage version: 2.1.2.3)
Diffstat (limited to 'dev-db/cdb/cdb-0.75-r2.ebuild')
-rw-r--r--dev-db/cdb/cdb-0.75-r2.ebuild30
1 files changed, 15 insertions, 15 deletions
diff --git a/dev-db/cdb/cdb-0.75-r2.ebuild b/dev-db/cdb/cdb-0.75-r2.ebuild
index 188c2ce4b192..9e91be6d4894 100644
--- a/dev-db/cdb/cdb-0.75-r2.ebuild
+++ b/dev-db/cdb/cdb-0.75-r2.ebuild
@@ -1,30 +1,30 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75-r2.ebuild,v 1.2 2007/03/26 07:48:10 antarus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/cdb/cdb-0.75-r2.ebuild,v 1.3 2007/04/24 17:30:05 chtekk Exp $
inherit eutils toolchain-funcs
-DESCRIPTION="fast, reliable, simple package for creating and reading constant databases"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+
+DESCRIPTION="Fast, reliable, simple package for creating and reading constant databases."
HOMEPAGE="http://cr.yp.to/cdb.html"
SRC_URI="http://cr.yp.to/cdb/${P}.tar.gz"
-
LICENSE="as-is"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
IUSE=""
DEPEND=">=sys-apps/sed-4
- !dev-db/freecdb"
-RDEPEND=""
+ !dev-db/freecdb
+ !dev-db/tinycdb"
+RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
cd "${S}"
epatch "${FILESDIR}"/${P}-errno.diff
- sed -i \
- -e 's/head -1/head -n 1/g' Makefile || \
- die "sed Makefile failed"
+ sed -i -e 's/head -1/head -n 1/g' Makefile \
+ || die "sed Makefile failed"
}
src_compile() {
@@ -35,16 +35,16 @@ src_compile() {
}
src_install() {
- dobin cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest || \
- die "dobin failed"
+ dobin cdbdump cdbget cdbmake cdbmake-12 cdbmake-sv cdbstats cdbtest \
+ || die "dobin failed"
- # ok so.. first off, some automakes fail at not finding
- # cdb.a, so install that
- dolib *.a || die
+ # ok so ... first off, some automakes fail at finding
+ # cdb.a, so install that now
+ dolib *.a || die "dolib failed"
# then do this pretty little symlinking to solve the somewhat
# cosmetic library issue at hand
- dosym cdb.a /usr/$(get_libdir)/libcdb.a || die "newlib.a failed"
+ dosym cdb.a /usr/$(get_libdir)/libcdb.a || die "dosym failed"
# uint32.h needs installation too, otherwise compiles depending
# on it will fail