summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-03-27 02:35:20 +0000
committerMike Frysinger <vapier@gentoo.org>2014-03-27 02:35:20 +0000
commite832bcee4013186cee0463937f174802ecf48745 (patch)
tree4f5a31473eba58c02a47135e5988afd59415da00 /dev-cpp
parentVersion bump. (diff)
downloadgentoo-2-e832bcee4013186cee0463937f174802ecf48745.tar.gz
gentoo-2-e832bcee4013186cee0463937f174802ecf48745.tar.bz2
gentoo-2-e832bcee4013186cee0463937f174802ecf48745.zip
Add multilib build support.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/gmock/ChangeLog7
-rw-r--r--dev-cpp/gmock/gmock-1.7.0-r1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-cpp/gmock/ChangeLog b/dev-cpp/gmock/ChangeLog
index 55c06fc3020f..34c28d6cfde2 100644
--- a/dev-cpp/gmock/ChangeLog
+++ b/dev-cpp/gmock/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-cpp/gmock
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gmock/ChangeLog,v 1.19 2014/02/14 15:46:56 hattya Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gmock/ChangeLog,v 1.20 2014/03/27 02:35:20 vapier Exp $
+
+*gmock-1.7.0-r1 (27 Mar 2014)
+
+ 27 Mar 2014; Mike Frysinger <vapier@gentoo.org> +gmock-1.7.0-r1.ebuild:
+ Add multilib build support.
14 Feb 2014; Akinori Hattori <hattya@gentoo.org> gmock-1.6.0.ebuild:
ia64 stable wrt bug #493400
diff --git a/dev-cpp/gmock/gmock-1.7.0-r1.ebuild b/dev-cpp/gmock/gmock-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..f968d5f82b69
--- /dev/null
+++ b/dev-cpp/gmock/gmock-1.7.0-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gmock/gmock-1.7.0-r1.ebuild,v 1.1 2014/03/27 02:35:20 vapier Exp $
+
+EAPI="4"
+
+inherit libtool multilib-minimal
+
+DESCRIPTION="Google's C++ mocking framework"
+HOMEPAGE="http://code.google.com/p/googlemock/"
+SRC_URI="http://googlemock.googlecode.com/files/${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="static-libs"
+
+RDEPEND="=dev-cpp/gtest-${PV}*[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+src_unpack() {
+ default
+ # make sure we always use the system one
+ rm -r "${S}"/gtest/{Makefile,configure}* || die
+}
+
+src_prepare() {
+ sed -i -r \
+ -e '/^install-(data|exec)-local:/s|^.*$|&\ndisabled-&|' \
+ Makefile.in
+ elibtoolize
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} econf $(use_enable static-libs static)
+}
+
+multilib_src_install() {
+ default
+ dobin scripts/gmock-config
+}
+
+multilib_src_install_all() {
+ use static-libs || find "${ED}" -name '*.la' -delete
+}