summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-11-12 19:07:49 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-11-12 19:07:49 +0000
commit150afccbbcc4ac7b4a006db31a99699b957beaa8 (patch)
treee3941160e75b0bd4fc611dbbbac546ba5d042b5d /dev-cpp
parentSet qt@g.o as maintainer, minor cleanups (quoting, whitespace, etc.) (diff)
downloadgentoo-2-150afccbbcc4ac7b4a006db31a99699b957beaa8.tar.gz
gentoo-2-150afccbbcc4ac7b4a006db31a99699b957beaa8.tar.bz2
gentoo-2-150afccbbcc4ac7b4a006db31a99699b957beaa8.zip
Add new branch
(Portage version: 2.1.10.34/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp')
-rw-r--r--dev-cpp/clucene/ChangeLog8
-rw-r--r--dev-cpp/clucene/clucene-2.3.3.4.ebuild49
2 files changed, 56 insertions, 1 deletions
diff --git a/dev-cpp/clucene/ChangeLog b/dev-cpp/clucene/ChangeLog
index 531927119f6f..4e1c1a503fab 100644
--- a/dev-cpp/clucene/ChangeLog
+++ b/dev-cpp/clucene/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/clucene
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/clucene/ChangeLog,v 1.41 2011/05/31 10:36:14 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/clucene/ChangeLog,v 1.42 2011/11/12 19:07:49 dilfridge Exp $
+
+*clucene-2.3.3.4 (12 Nov 2011)
+
+ 12 Nov 2011; Andreas K. Huettel <dilfridge@gentoo.org>
+ +clucene-2.3.3.4.ebuild:
+ Add new branch
31 May 2011; Tomáš Chvátal <scarabeus@gentoo.org> metadata.xml:
Drop maintainership as only user of this thing is KDE.
diff --git a/dev-cpp/clucene/clucene-2.3.3.4.ebuild b/dev-cpp/clucene/clucene-2.3.3.4.ebuild
new file mode 100644
index 000000000000..948acf0a6928
--- /dev/null
+++ b/dev-cpp/clucene/clucene-2.3.3.4.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/clucene/clucene-2.3.3.4.ebuild,v 1.1 2011/11/12 19:07:49 dilfridge Exp $
+
+EAPI=4
+
+MY_PN="${PN}"-core
+MY_P="${MY_PN}"-"${PV}"
+
+inherit cmake-utils
+
+DESCRIPTION="High-performance, full-featured text search engine based off of lucene in C++"
+HOMEPAGE="http://clucene.sourceforge.net/"
+SRC_URI="mirror://sourceforge/clucene/${MY_P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 LGPL-2.1 )"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd
+~amd64-linux ~x86-linux ~ppc-macos"
+
+IUSE="debug doc static-libs"
+
+DEPEND="
+ doc? ( >=app-doc/doxygen-1.4.2 )
+"
+RDEPEND="!<app-misc/strigi-0.7.5-r3"
+
+DOCS=(AUTHORS ChangeLog README README.PACKAGE REQUESTS)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-9999-cmake.patch"
+)
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ # Disabled threads: see upstream bug
+ # https://sourceforge.net/tracker/?func=detail&aid=3237301&group_id=80013&atid=558446
+ local mycmakeargs=(
+ -DENABLE_ASCII_MODE=OFF
+ -DENABLE_PACKAGING=OFF
+ -DDISABLE_MULTITHREADING=OFF
+ $(cmake-utils_use_enable debug)
+ $(cmake-utils_use_enable doc CLDOCS)
+ $(cmake-utils_use_build static-libs STATIC_LIBRARIES)
+ )
+
+ cmake-utils_src_configure
+}