summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2008-11-05 09:55:57 +0000
committerIlya Volynets <iluxa@gentoo.org>2008-11-05 09:55:57 +0000
commita430af2b61473dd91a25b5005b370cb361210599 (patch)
tree13a9b08f6a5d64901d94c45a68ef7da0134e61dd /dev-cpp/sptk
parentminimium libtool version as per bug #245544 thanks to Vasileios and Lars. (diff)
downloadgentoo-2-a430af2b61473dd91a25b5005b370cb361210599.tar.gz
gentoo-2-a430af2b61473dd91a25b5005b370cb361210599.tar.bz2
gentoo-2-a430af2b61473dd91a25b5005b370cb361210599.zip
Add sptk 3.5.8.4
(Portage version: 2.1.4.5)
Diffstat (limited to 'dev-cpp/sptk')
-rw-r--r--dev-cpp/sptk/ChangeLog8
-rw-r--r--dev-cpp/sptk/sptk-3.5.8.4.ebuild78
2 files changed, 85 insertions, 1 deletions
diff --git a/dev-cpp/sptk/ChangeLog b/dev-cpp/sptk/ChangeLog
index 14101f3cd61f..19e3e752d9bd 100644
--- a/dev-cpp/sptk/ChangeLog
+++ b/dev-cpp/sptk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-cpp/sptk
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.40 2008/10/09 14:44:58 iluxa Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/ChangeLog,v 1.41 2008/11/05 09:55:57 iluxa Exp $
+
+*sptk-3.5.8.4 (05 Nov 2008)
+
+ 05 Nov 2008; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
+ +sptk-3.5.8.4.ebuild:
+ Add SPTK 3.5.8.4
09 Oct 2008; Ilya A. Volynets-Evenbakh <iluxa@gentoo.org>
sptk-3.5.8.ebuild:
diff --git a/dev-cpp/sptk/sptk-3.5.8.4.ebuild b/dev-cpp/sptk/sptk-3.5.8.4.ebuild
new file mode 100644
index 000000000000..62b8ef66d71f
--- /dev/null
+++ b/dev-cpp/sptk/sptk-3.5.8.4.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2006-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/sptk/sptk-3.5.8.4.ebuild,v 1.1 2008/11/05 09:55:57 iluxa Exp $
+
+inherit eutils flag-o-matic autotools multilib
+
+IUSE="fltk odbc doc sqlite3 examples excel postgres aspell mysql"
+
+DESCRIPTION="C++ user interface toolkit for X with database and Excel support"
+SRC_URI="http://www.sptk.net/sptk-${PV}.tbz2"
+HOMEPAGE="http://www.sptk.net"
+
+SLOT="3"
+LICENSE="|| ( BSD )"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc ~sparc ~x86"
+
+RDEPEND="fltk? ( >=x11-libs/fltk-1.1.6 )
+ odbc? ( >=dev-db/unixODBC-2.2.6 )
+ sqlite3? ( >=dev-db/sqlite-3 )
+ postgres? ( >=virtual/postgresql-base-8.0 )
+ mysql? ( dev-db/mysql )
+ aspell? ( >=app-text/aspell-0.50 )"
+
+DEPEND="${RDEPEND}
+ dev-util/cmake
+ doc? ( app-doc/doxygen )"
+
+check_use() {
+ if use ${1}; then
+ SPTK_OPTIONS="${SPTK_OPTIONS} -DNO_${2}:BOOLEAN=FALSE"
+ else
+ SPTK_OPTIONS="${SPTK_OPTIONS} -DNO_${2}:BOOLEAN=TRUE"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ check_use examples EXAMPLES
+ check_use postgres POSTGRESQL
+ check_use mysql MYSQL
+ check_use sqlite3 SQLITE3
+ check_use odbc ODBC
+ check_use aspell ASPELL
+ check_use fltk FLTK
+ check_use excel EXCEL
+
+ cmake -D CMAKE_INSTALL_PREFIX:PATH=/usr -D LIBDIR=$(get_libdir) ${SPTK_OPTIONS} . || die "Configuration Failed"
+}
+
+src_compile() {
+
+ emake || die "Parallel Make Failed"
+
+ if use doc; then
+ cd "${S}"
+ einfo "Fixing sptk3.doxygen"
+ sed -i -e 's,/cvs/sptk3/,,g' sptk3.doxygen
+ einfo "Building docs"
+ doxygen sptk3.doxygen
+ fi
+
+}
+
+src_install () {
+
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc README AUTHORS
+
+ dodir /usr/share/doc/${PF}
+ cp -r "${S}"/docs/* "${D}"/usr/share/doc/${PF}
+ if use doc; then
+ rm -fr "${D}/usr/share/doc/${PF}/latex"
+ cp -rf "${S}/pictures" "${D}/usr/share/doc/${PF}"
+ fi
+}