summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-11-16 15:17:46 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-11-16 15:17:46 +0000
commit0bb010c8a5669e35d72fda3bc9695fa94a3b5151 (patch)
tree431d461b300cd753f58355a7ae46ebd03bfec58a /dev-cpp/gccxml
parentversion bump (also fixes bug #285442), removed old versions (diff)
downloadgentoo-2-0bb010c8a5669e35d72fda3bc9695fa94a3b5151.tar.gz
gentoo-2-0bb010c8a5669e35d72fda3bc9695fa94a3b5151.tar.bz2
gentoo-2-0bb010c8a5669e35d72fda3bc9695fa94a3b5151.zip
QA: fix cmake issues. Drop all packages violating QA. Thanks to Yury Fedorchenko for ebuild. Per bug #287594 NOTE: this package is moving from p.mask to ~ thus the dropped stable..
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/gccxml')
-rw-r--r--dev-cpp/gccxml/ChangeLog11
-rw-r--r--dev-cpp/gccxml/files/gccxml-0.6.0-gcc43.patch21
-rw-r--r--dev-cpp/gccxml/files/obstack.h.diff99
-rw-r--r--dev-cpp/gccxml/gccxml-0.6.0-r1.ebuild36
-rw-r--r--dev-cpp/gccxml/gccxml-0.9.0_pre20080607.ebuild46
-rw-r--r--dev-cpp/gccxml/gccxml-0.9.0_pre20090516-r1.ebuild23
-rw-r--r--dev-cpp/gccxml/gccxml-0.9.0_pre20090516.ebuild46
7 files changed, 33 insertions, 249 deletions
diff --git a/dev-cpp/gccxml/ChangeLog b/dev-cpp/gccxml/ChangeLog
index 8b5980f366bc..edf0320aae09 100644
--- a/dev-cpp/gccxml/ChangeLog
+++ b/dev-cpp/gccxml/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-cpp/gccxml
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gccxml/ChangeLog,v 1.28 2009/05/25 13:49:53 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gccxml/ChangeLog,v 1.29 2009/11/16 15:17:46 scarabeus Exp $
+
+*gccxml-0.9.0_pre20090516-r1 (16 Nov 2009)
+
+ 16 Nov 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ -gccxml-0.6.0-r1.ebuild, -files/gccxml-0.6.0-gcc43.patch,
+ -gccxml-0.9.0_pre20080607.ebuild, -gccxml-0.9.0_pre20090516.ebuild,
+ +gccxml-0.9.0_pre20090516-r1.ebuild, -files/obstack.h.diff:
+ QA: fix cmake issues. Drop all packages violating QA. Thanks to Yury
+ Fedorchenko for ebuild. Per bug #287594.
25 May 2009; Raúl Porcel <armin76@gentoo.org>
gccxml-0.9.0_pre20090516.ebuild:
diff --git a/dev-cpp/gccxml/files/gccxml-0.6.0-gcc43.patch b/dev-cpp/gccxml/files/gccxml-0.6.0-gcc43.patch
deleted file mode 100644
index ed65ca2758a9..000000000000
--- a/dev-cpp/gccxml/files/gccxml-0.6.0-gcc43.patch
+++ /dev/null
@@ -1,21 +0,0 @@
---- GCC_XML/GXFront/gxConfiguration.cxx 2004-01-22 22:51:36.000000000 +0100
-+++ GCC_XML/GXFront/gxConfiguration.cxx 2008-11-26 18:17:34.000000000 +0100
-@@ -15,6 +15,7 @@
-
- =========================================================================*/
- #include "gxConfiguration.h"
-+#include <cstring>
-
- //----------------------------------------------------------------------------
- const char* gxConfigurationVc6Registry =
---- GCC_XML/KWSys/SystemTools.cxx 2004-01-22 16:30:01.000000000 +0100
-+++ GCC_XML/KWSys/SystemTools.cxx 2008-11-26 18:16:53.000000000 +0100
-@@ -17,6 +17,7 @@
-
- #include KWSYS_HEADER(ios/iostream)
- #include KWSYS_HEADER(ios/fstream)
-+#include <cstring>
-
- #ifdef _MSC_VER
- # pragma warning (disable: 4786)
-
diff --git a/dev-cpp/gccxml/files/obstack.h.diff b/dev-cpp/gccxml/files/obstack.h.diff
deleted file mode 100644
index 99e0406d8db9..000000000000
--- a/dev-cpp/gccxml/files/obstack.h.diff
+++ /dev/null
@@ -1,99 +0,0 @@
---- GCC/include/obstack.h 2001/03/14 19:44:38 1.5
-+++ GCC/include/obstack.h 2004/03/02 02:18:16 1.5.50.1
-@@ -343,7 +343,7 @@
-
- #endif
-
--#define obstack_1grow_fast(h,achar) (*((h)->next_free)++ = achar)
-+#define obstack_1grow_fast(h,achar) (*((h)->next_free)++ = (achar))
-
- #define obstack_blank_fast(h,n) ((h)->next_free += (n))
-
-@@ -411,7 +411,7 @@
- ({ struct obstack *__o = (OBSTACK); \
- if (__o->next_free + 1 > __o->chunk_limit) \
- _obstack_newchunk (__o, 1); \
-- *(__o->next_free)++ = (datum); \
-+ obstack_1grow_fast (__o, datum); \
- (void) 0; })
-
- /* These assume that the obstack alignment is good enough for pointers or ints,
-@@ -423,19 +423,28 @@
- ({ struct obstack *__o = (OBSTACK); \
- if (__o->next_free + sizeof (void *) > __o->chunk_limit) \
- _obstack_newchunk (__o, sizeof (void *)); \
-- *((void **)__o->next_free)++ = ((void *)datum); \
-- (void) 0; })
-+ obstack_ptr_grow_fast (__o, datum); })
-
- # define obstack_int_grow(OBSTACK,datum) \
- __extension__ \
- ({ struct obstack *__o = (OBSTACK); \
- if (__o->next_free + sizeof (int) > __o->chunk_limit) \
- _obstack_newchunk (__o, sizeof (int)); \
-- *((int *)__o->next_free)++ = ((int)datum); \
-+ obstack_int_grow_fast (__o, datum); })
-+
-+# define obstack_ptr_grow_fast(OBSTACK,aptr) \
-+__extension__ \
-+({ struct obstack *__o1 = (OBSTACK); \
-+ *(const void **) __o1->next_free = (aptr); \
-+ __o1->next_free += sizeof (const void *); \
- (void) 0; })
-
--# define obstack_ptr_grow_fast(h,aptr) (*((void **) (h)->next_free)++ = (void *)aptr)
--# define obstack_int_grow_fast(h,aint) (*((int *) (h)->next_free)++ = (int) aint)
-+# define obstack_int_grow_fast(OBSTACK,aint) \
-+__extension__ \
-+({ struct obstack *__o1 = (OBSTACK); \
-+ *(int *) __o1->next_free = (aint); \
-+ __o1->next_free += sizeof (int); \
-+ (void) 0; })
-
- # define obstack_blank(OBSTACK,length) \
- __extension__ \
-@@ -443,7 +452,7 @@
- int __len = (length); \
- if (__o->chunk_limit - __o->next_free < __len) \
- _obstack_newchunk (__o, __len); \
-- __o->next_free += __len; \
-+ obstack_blank_fast (__o, __len); \
- (void) 0; })
-
- # define obstack_alloc(OBSTACK,length) \
-@@ -530,26 +539,29 @@
- # define obstack_1grow(h,datum) \
- ( (((h)->next_free + 1 > (h)->chunk_limit) \
- ? (_obstack_newchunk ((h), 1), 0) : 0), \
-- (*((h)->next_free)++ = (datum)))
-+ obstack_1grow_fast (h, datum))
-
- # define obstack_ptr_grow(h,datum) \
- ( (((h)->next_free + sizeof (char *) > (h)->chunk_limit) \
- ? (_obstack_newchunk ((h), sizeof (char *)), 0) : 0), \
-- (*((char **) (((h)->next_free+=sizeof(char *))-sizeof(char *))) = ((char *) datum)))
-+ obstack_ptr_grow_fast (h, datum))
-
- # define obstack_int_grow(h,datum) \
- ( (((h)->next_free + sizeof (int) > (h)->chunk_limit) \
- ? (_obstack_newchunk ((h), sizeof (int)), 0) : 0), \
-- (*((int *) (((h)->next_free+=sizeof(int))-sizeof(int))) = ((int) datum)))
-+ obstack_int_grow_fast (h, datum))
-+
-+# define obstack_ptr_grow_fast(h,aptr) \
-+ (((const void **) ((h)->next_free += sizeof (void *)))[-1] = (aptr))
-
--# define obstack_ptr_grow_fast(h,aptr) (*((char **) (h)->next_free)++ = (char *) aptr)
--# define obstack_int_grow_fast(h,aint) (*((int *) (h)->next_free)++ = (int) aint)
-+# define obstack_int_grow_fast(h,aint) \
-+ (((int *) ((h)->next_free += sizeof (int)))[-1] = (aptr))
-
- # define obstack_blank(h,length) \
- ( (h)->temp = (length), \
- (((h)->chunk_limit - (h)->next_free < (h)->temp) \
- ? (_obstack_newchunk ((h), (h)->temp), 0) : 0), \
-- ((h)->next_free += (h)->temp))
-+ obstack_blank_fast (h, (h)->temp))
-
- # define obstack_alloc(h,length) \
- (obstack_blank ((h), (length)), obstack_finish ((h)))
diff --git a/dev-cpp/gccxml/gccxml-0.6.0-r1.ebuild b/dev-cpp/gccxml/gccxml-0.6.0-r1.ebuild
deleted file mode 100644
index c18642f32c2a..000000000000
--- a/dev-cpp/gccxml/gccxml-0.6.0-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gccxml/gccxml-0.6.0-r1.ebuild,v 1.7 2009/01/02 01:37:51 halcy0n Exp $
-
-inherit versionator eutils
-PVM="$(get_version_component_range 1-2)"
-DESCRIPTION="XML output extension to GCC"
-HOMEPAGE="http://www.gccxml.org/"
-SRC_URI="http://www.gccxml.org/files/v${PVM}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm ia64 mips ppc s390 sh ~sparc x86"
-IUSE=""
-
-DEPEND="dev-util/cmake"
-RDEPEND=""
-
-MYBUILDDIR="${WORKDIR}"/build
-src_unpack() {
- mkdir "${MYBUILDDIR}"
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/obstack.h.diff
- epatch "${FILESDIR}"/${P}-gcc43.patch
-}
-src_compile() {
- cd "${MYBUILDDIR}"
- cmake ../${P} -DCMAKE_INSTALL_PREFIX:PATH=/usr || die "cmake failed"
- emake || die "emake failed"
-}
-
-src_install() {
- cd "${MYBUILDDIR}"
- make DESTDIR="${D}" install || die
-}
diff --git a/dev-cpp/gccxml/gccxml-0.9.0_pre20080607.ebuild b/dev-cpp/gccxml/gccxml-0.9.0_pre20080607.ebuild
deleted file mode 100644
index 8dc19d18ec4a..000000000000
--- a/dev-cpp/gccxml/gccxml-0.9.0_pre20080607.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gccxml/gccxml-0.9.0_pre20080607.ebuild,v 1.1 2008/06/07 16:57:59 dev-zero Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="XML output extension to GCC"
-HOMEPAGE="http://www.gccxml.org/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86"
-IUSE=""
-
-DEPEND=">=dev-util/cmake-2.4.6"
-RDEPEND=""
-
-S="${WORKDIR}/${P}"
-MYBUILDDIR="${WORKDIR}/build"
-
-src_unpack() {
- mkdir "${MYBUILDDIR}"
- unpack ${A}
-
- cd "${S}"
- # patch below taken from Debian
- sed -i \
- -e 's/xatexit.c//' \
- "${S}/GCC/libiberty/CMakeLists.txt" || die "sed failed"
-}
-src_compile() {
- cd "${MYBUILDDIR}"
- cmake "${S}" \
- -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DCMAKE_CXX_COMPILER:FILEPATH="$(tc-getCXX)" \
- -DCMAKE_CXX_FLAGS="${CXXFLAGS}" \
- -DCMAKE_C_COMPILER:FILEPATH="$(tc-getCC)" \
- -DCMAKE_C_FLAGS="${CFLAGS}" \
- || die "cmake failed"
- emake || die "emake failed"
-}
-
-src_install() {
- cd "${MYBUILDDIR}"
- emake DESTDIR="${D}" install || die "emake install failed"
-}
diff --git a/dev-cpp/gccxml/gccxml-0.9.0_pre20090516-r1.ebuild b/dev-cpp/gccxml/gccxml-0.9.0_pre20090516-r1.ebuild
new file mode 100644
index 000000000000..9f9a2a438857
--- /dev/null
+++ b/dev-cpp/gccxml/gccxml-0.9.0_pre20090516-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gccxml/gccxml-0.9.0_pre20090516-r1.ebuild,v 1.1 2009/11/16 15:17:46 scarabeus Exp $
+
+EAPI="2"
+
+inherit cmake-utils
+
+DESCRIPTION="XML output extension to GCC"
+HOMEPAGE="http://www.gccxml.org/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ # patch below taken from Debian
+ sed -i \
+ -e 's/xatexit.c//' \
+ "${S}/GCC/libiberty/CMakeLists.txt" || die "sed failed"
+}
diff --git a/dev-cpp/gccxml/gccxml-0.9.0_pre20090516.ebuild b/dev-cpp/gccxml/gccxml-0.9.0_pre20090516.ebuild
deleted file mode 100644
index e69c4d6c0d59..000000000000
--- a/dev-cpp/gccxml/gccxml-0.9.0_pre20090516.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/gccxml/gccxml-0.9.0_pre20090516.ebuild,v 1.5 2009/05/25 13:49:53 armin76 Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="XML output extension to GCC"
-HOMEPAGE="http://www.gccxml.org/"
-SRC_URI="mirror://gentoo/${P}.tar.bz2"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm ia64 ~mips ppc s390 sh ~sparc x86"
-IUSE=""
-
-DEPEND=">=dev-util/cmake-2.4.6"
-RDEPEND=""
-
-S="${WORKDIR}/${P}"
-MYBUILDDIR="${WORKDIR}/build"
-
-src_unpack() {
- mkdir "${MYBUILDDIR}"
- unpack ${A}
-
- cd "${S}"
- # patch below taken from Debian
- sed -i \
- -e 's/xatexit.c//' \
- "${S}/GCC/libiberty/CMakeLists.txt" || die "sed failed"
-}
-src_compile() {
- cd "${MYBUILDDIR}"
- cmake "${S}" \
- -DCMAKE_INSTALL_PREFIX:PATH=/usr \
- -DCMAKE_CXX_COMPILER:FILEPATH="$(tc-getCXX)" \
- -DCMAKE_CXX_FLAGS="${CXXFLAGS}" \
- -DCMAKE_C_COMPILER:FILEPATH="$(tc-getCC)" \
- -DCMAKE_C_FLAGS="${CFLAGS}" \
- || die "cmake failed"
- emake || die "emake failed"
-}
-
-src_install() {
- cd "${MYBUILDDIR}"
- emake DESTDIR="${D}" install || die "emake install failed"
-}