summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCaleb Tennis <caleb@gentoo.org>2007-03-13 13:31:28 +0000
committerCaleb Tennis <caleb@gentoo.org>2007-03-13 13:31:28 +0000
commitddd225747442a757d2b14815f80e0a6e15119d2c (patch)
tree11536233595363bf9ad3bf4435ba7f76e5d4e385 /dev-cpp/Ice
parentx86 stable (diff)
downloadgentoo-2-ddd225747442a757d2b14815f80e0a6e15119d2c.tar.gz
gentoo-2-ddd225747442a757d2b14815f80e0a6e15119d2c.tar.bz2
gentoo-2-ddd225747442a757d2b14815f80e0a6e15119d2c.zip
Some fixes
(Portage version: 2.1.2.1)
Diffstat (limited to 'dev-cpp/Ice')
-rw-r--r--dev-cpp/Ice/files/Ice-3.2.0-Makefile.patch65
1 files changed, 46 insertions, 19 deletions
diff --git a/dev-cpp/Ice/files/Ice-3.2.0-Makefile.patch b/dev-cpp/Ice/files/Ice-3.2.0-Makefile.patch
index 93fc3770cc88..92cfd5162f79 100644
--- a/dev-cpp/Ice/files/Ice-3.2.0-Makefile.patch
+++ b/dev-cpp/Ice/files/Ice-3.2.0-Makefile.patch
@@ -1,11 +1,11 @@
---- config/Make.rules.orig 2007-02-27 15:49:03.000000000 -0500
-+++ config/Make.rules 2007-02-27 15:51:08.000000000 -0500
+--- config/Make.rules.orig 2007-03-13 09:07:05.000000000 -0400
++++ config/Make.rules 2007-03-13 09:07:13.000000000 -0400
@@ -11,13 +11,13 @@
# Select an installation base directory. The directory will be created
# if it does not exist.
#
-prefix ?= /opt/Ice-$(VERSION)
-+prefix ?= $(DESTDIR)/usr
++prefix ?= /$(DESTDIR)/usr
#
# The "root directory" for runpath embedded in executables. Can be unset
@@ -16,7 +16,7 @@
#
# Define OPTIMIZE as yes if you want to build with
-@@ -125,9 +125,9 @@
+@@ -125,9 +125,10 @@
install_bindir = $(prefix)/bin
install_includedir = $(prefix)/include
@@ -25,35 +25,62 @@
-install_docdir = $(prefix)/doc
+install_slicedir = $(prefix)/share/Ice/slice
+install_schemadir = $(prefix)/share/Ice/schema
++install_configdir = $(prefix)/share/Ice/config
+install_docdir = $(prefix)/share/doc/Ice-$(VERSION)
INSTALL = cp -fp
INSTALL_PROGRAM = ${INSTALL}
-@@ -184,9 +184,9 @@
- DB_LIBS = -L$(DB_HOME)/$(libsubdir) -ldb_cxx
- DB_RPATH_LINK = $(call rpathlink,$(DB_HOME)/$(libsubdir))
- else
+@@ -179,18 +180,8 @@
+ BZIP2_LIBS = $(if $(BZIP2_HOME),-L$(BZIP2_HOME)/$(libsubdir)) -lbz2
+ BZIP2_RPATH_LINK = $(if $(BZIP2_HOME),$(call rpathlink,$(BZIP2_HOME)/$(libsubdir)))
+
+-ifneq ($(DB_HOME),)
+- DB_FLAGS = -I$(DB_HOME)/include
+- DB_LIBS = -L$(DB_HOME)/$(libsubdir) -ldb_cxx
+- DB_RPATH_LINK = $(call rpathlink,$(DB_HOME)/$(libsubdir))
+-else
- ifeq ($(shell if [ -d /usr/include/db45 -a -d /usr/$(libsubdir)/db45 ] ; then echo yes; fi), yes)
- DB_FLAGS = -I/usr/include/db45
- DB_LIBS = -L/usr/$(libsubdir)/db45 -ldb_cxx
-+ ifeq ($(shell if [ -d /usr/include/db4.5 -a -d /usr/$(libsubdir) ] ; then echo yes; fi), yes)
-+ DB_FLAGS = -I/usr/include/db4.5
-+ DB_LIBS = -L/usr/$(libsubdir) -ldb_cxx-4.5
- else
- DB_LIBS = -ldb_cxx
- endif
---- Makefile.orig 2007-02-27 15:53:01.000000000 -0500
-+++ Makefile 2007-02-27 15:54:20.000000000 -0500
-@@ -11,7 +11,7 @@
+- else
+- DB_LIBS = -ldb_cxx
+- endif
+-endif
++DB_FLAGS = -I/usr/include/db4.5
++DB_LIBS = -L/usr/$(libsubdir) -ldb_cxx-4.5
+
+ EXPAT_FLAGS = $(if $(EXPAT_HOME),-I$(EXPAT_HOME)/include)
+ EXPAT_LIBS = $(if $(EXPAT_HOME),-L$(EXPAT_HOME)/$(libsubdir)) -lexpat
+--- config/Makefile.orig 2007-03-13 09:08:50.000000000 -0400
++++ config/Makefile 2007-03-13 09:09:22.000000000 -0400
+@@ -20,9 +20,9 @@
+ echo "Creating $(prefix)/config..." ; \
+ $(call mkdir,$(prefix)/config) ; \
+ fi
+- $(call installdata,templates.xml,$(prefix)/config)
+- $(call installdata,convertssl.py,$(prefix)/config)
+- $(call installdata,upgradeicegrid.py,$(prefix)/config)
+- $(call installdata,upgradeicestorm.py,$(prefix)/config)
+- $(call installdata,icegrid-slice.3.1.ice.gz,$(prefix)/config)
++ $(call installdata,templates.xml,$(install_configdir))
++ $(call installdata,convertssl.py,$(install_configdir))
++ $(call installdata,upgradeicegrid.py,$(install_configdir))
++ $(call installdata,upgradeicestorm.py,$(install_configdir))
++ $(call installdata,icegrid-slice.3.1.ice.gz,$(install_configdir))
+
+--- Makefile.orig 2007-03-13 09:07:20.000000000 -0400
++++ Makefile 2007-03-13 09:08:44.000000000 -0400
+@@ -11,15 +11,15 @@
include $(top_srcdir)/config/Make.rules
-SUBDIRS = config src include test demo slice doc
+SUBDIRS = config src include slice doc
- INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_slicedir) $(install_docdir)
+-INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_slicedir) $(install_docdir)
++INSTALL_SUBDIRS = $(install_bindir) $(install_libdir) $(install_includedir) $(install_slicedir) $(install_docdir) $(install_configdir)
-@@ -19,7 +19,7 @@
+ install::
@if test ! -d $(prefix) ; \
then \
echo "Creating $(prefix)..." ; \