summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2009-03-26 11:55:54 +0000
committerGeorge Shapovalov <george@gentoo.org>2009-03-26 11:55:54 +0000
commit1936cbd708debc91799be2ddb6c1caacff3c7e9c (patch)
treedc306470856a0c4891888eb8b213d1dccb7299ce /dev-ada
parentMake the ebuild actualy work. I dont see how it could be marked stable since ... (diff)
downloadgentoo-2-1936cbd708debc91799be2ddb6c1caacff3c7e9c.tar.gz
gentoo-2-1936cbd708debc91799be2ddb6c1caacff3c7e9c.tar.bz2
gentoo-2-1936cbd708debc91799be2ddb6c1caacff3c7e9c.zip
fixed collisions (#250064)
(Portage version: 2.2_rc27/cvs/Linux x86_64)
Diffstat (limited to 'dev-ada')
-rw-r--r--dev-ada/glade/ChangeLog5
-rw-r--r--dev-ada/glade/glade-2006.0.ebuild14
2 files changed, 16 insertions, 3 deletions
diff --git a/dev-ada/glade/ChangeLog b/dev-ada/glade/ChangeLog
index 5a097dd9f548..4c535fc85e92 100644
--- a/dev-ada/glade/ChangeLog
+++ b/dev-ada/glade/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ada/glade
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/glade/ChangeLog,v 1.4 2009/03/26 10:05:49 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/glade/ChangeLog,v 1.5 2009/03/26 11:55:54 george Exp $
+
+ 26 Mar 2009; George Shapovalov <george@gentoo.org> glade-2006.0.ebuild:
+ fixed collisions (#250064)
26 Mar 2009; George Shapovalov <george@gentoo.org> glade-2006.0.ebuild:
limited DEPEND to Ada-95 compilers (#250064)
diff --git a/dev-ada/glade/glade-2006.0.ebuild b/dev-ada/glade/glade-2006.0.ebuild
index bcc9aba4b7af..15e1acb01986 100644
--- a/dev-ada/glade/glade-2006.0.ebuild
+++ b/dev-ada/glade/glade-2006.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ada/glade/glade-2006.0.ebuild,v 1.5 2009/03/26 10:05:49 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ada/glade/glade-2006.0.ebuild,v 1.6 2009/03/26 11:55:54 george Exp $
inherit gnat
@@ -39,7 +39,7 @@ lib_compile()
# NOTE: we are using $1 - the passed gnat profile name
lib_install()
{
- # This package expands the libs and sources rovided by compiler. Therefore
+ # This package expands the libs and sources provided by compiler. Therefore
# we install in yet another local location, to bypass gnat's automation.
# The compiler specific stuf is then moved to ${D} directly. Not ideal, as
# this hook is called from within src_compile, but alternatives are more
@@ -58,6 +58,16 @@ lib_install()
mkdir -p "${DN}/${Gnat_Incdir}"
mv "${DN}/lib/garlic"/*.ad? "${DN}/${Gnat_Incdir}"
rm -rf "${DN}/lib"
+
+ # remove files already provided by compiler
+ pushd "${DN}"
+ for fn in "${Gnat_Libdir:1}"/*.ali "${Gnat_Incdir:1}"/*.ad?; do
+ # Gnat_Lib/Incdir are global, need to remove leading /
+ if [[ -e /${fn} ]]; then
+ rm -f ${fn}
+ fi
+ done
+ popd
}
src_install ()