summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-10-18 04:03:19 +0000
committerTim Harder <radhermit@gentoo.org>2014-10-18 04:03:19 +0000
commit054637141d881f1444e55b2dfb51b41a39ece344 (patch)
tree18f18da8171a19d69737f8f4dc1c59148049fab5 /app-vim
parentVersion bump. (diff)
downloadgentoo-2-054637141d881f1444e55b2dfb51b41a39ece344.tar.gz
gentoo-2-054637141d881f1444e55b2dfb51b41a39ece344.tar.bz2
gentoo-2-054637141d881f1444e55b2dfb51b41a39ece344.zip
Version bump.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-vim')
-rw-r--r--app-vim/easytags/ChangeLog7
-rw-r--r--app-vim/easytags/easytags-3.7.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/app-vim/easytags/ChangeLog b/app-vim/easytags/ChangeLog
index 0bfca9b09b1f..53d6141ace40 100644
--- a/app-vim/easytags/ChangeLog
+++ b/app-vim/easytags/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-vim/easytags
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/easytags/ChangeLog,v 1.17 2014/06/26 06:27:06 radhermit Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/easytags/ChangeLog,v 1.18 2014/10/18 04:03:19 radhermit Exp $
+
+*easytags-3.7 (18 Oct 2014)
+
+ 18 Oct 2014; Tim Harder <radhermit@gentoo.org> +easytags-3.7.ebuild:
+ Version bump.
26 Jun 2014; Tim Harder <radhermit@gentoo.org> -easytags-2.7.2.ebuild,
-easytags-2.8.1.ebuild:
diff --git a/app-vim/easytags/easytags-3.7.ebuild b/app-vim/easytags/easytags-3.7.ebuild
new file mode 100644
index 000000000000..34cadc0b230e
--- /dev/null
+++ b/app-vim/easytags/easytags-3.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/easytags/easytags-3.7.ebuild,v 1.1 2014/10/18 04:03:19 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1 vim-plugin
+
+DESCRIPTION="vim plugin: automated tag file generation and syntax highlighting"
+HOMEPAGE="http://peterodding.com/code/vim/easytags/"
+SRC_URI="https://github.com/xolox/vim-${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ >=app-vim/vim-misc-1.16.1
+ dev-util/ctags"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+S=${WORKDIR}/vim-${P}
+
+src_prepare() {
+ # remove unnecessary files
+ rm addon-info.json INSTALL.md README.md || die
+}
+
+src_install() {
+ vim-plugin_src_install
+
+ # fix scripts
+ fperms 755 /usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
+ python_fix_shebang "${ED}"/usr/share/vim/vimfiles/misc/easytags/{normalize-tags,why-so-slow}.py
+}