summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2010-03-12 10:16:57 +0000
committerPacho Ramos <pacho@gentoo.org>2010-03-12 10:16:57 +0000
commite117db4f71d55cd441db4e02aac75b8a423b0154 (patch)
tree9d1de843aa346253cdc395522bb2a3620a6d715f /app-text
parentx86 stable wrt bug #309027 (diff)
downloadgentoo-2-e117db4f71d55cd441db4e02aac75b8a423b0154.tar.gz
gentoo-2-e117db4f71d55cd441db4e02aac75b8a423b0154.tar.bz2
gentoo-2-e117db4f71d55cd441db4e02aac75b8a423b0154.zip
Version bump, lots of fixes
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/wv/ChangeLog9
-rw-r--r--app-text/wv/wv-1.2.7.ebuild53
2 files changed, 60 insertions, 2 deletions
diff --git a/app-text/wv/ChangeLog b/app-text/wv/ChangeLog
index 81a72341a1fa..fa994861cc20 100644
--- a/app-text/wv/ChangeLog
+++ b/app-text/wv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/wv
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/wv/ChangeLog,v 1.52 2008/02/19 15:09:59 caleb Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wv/ChangeLog,v 1.53 2010/03/12 10:16:57 pacho Exp $
+
+*wv-1.2.7 (12 Mar 2010)
+
+ 12 Mar 2010; Pacho Ramos <pacho@gentoo.org> +wv-1.2.7.ebuild:
+ Version bump, lots of fixes
*wv-1.2.4 (19 Feb 2008)
diff --git a/app-text/wv/wv-1.2.7.ebuild b/app-text/wv/wv-1.2.7.ebuild
new file mode 100644
index 000000000000..5eb1f803272e
--- /dev/null
+++ b/app-text/wv/wv-1.2.7.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/wv/wv-1.2.7.ebuild,v 1.1 2010/03/12 10:16:57 pacho Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Tool for conversion of MSWord doc and rtf files to something readable"
+SRC_URI="http://abiword.org/downloads/${PN}/${PV}/${P}.tar.gz"
+HOMEPAGE="http://wvware.sourceforge.net/"
+
+IUSE="wmf"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+SLOT="0"
+LICENSE="GPL-2"
+
+RDEPEND=">=dev-libs/glib-2
+ >=gnome-extra/libgsf-1.13
+ sys-libs/zlib
+ media-libs/libpng
+ dev-libs/libxml2
+ wmf? ( >=media-libs/libwmf-0.2.2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+src_prepare() {
+ # Workaround incorrect soname bump as fedora does
+ sed -i 's/^LT_CURRENT=`expr $WV_MICRO_VERSION - $WV_INTERFACE_AGE`/LT_CURRENT=3/' configure \
+ || die
+}
+
+src_configure() {
+ econf `use_with wmf libwmf` || die "./configure failed"
+}
+
+src_compile() {
+ emake || die "Compilation failed"
+}
+
+src_install () {
+ make DESTDIR="${D}" install || die "Installation failed"
+ dodoc README
+
+ rm -f "${D}"/usr/share/man/man1/wvConvert.1
+ dosym /usr/share/man/man1/wvWare.1 /usr/share/man/man1/wvConvert.1
+}
+
+pkg_postinst() {
+ ewarn "You have to re-emerge packages that linked against wv by running:"
+ ewarn "revdep-rebuild"
+}