summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-03-26 23:38:57 +0000
committerMike Frysinger <vapier@gentoo.org>2015-03-26 23:38:57 +0000
commitd9c5063399ed1c8b4fb73402db139aadb8570c19 (patch)
tree490c0786b57492806eee003f3672919a2a021e46 /app-text
parentremove unused empty dodir (bug #534584) (diff)
downloadgentoo-2-d9c5063399ed1c8b4fb73402db139aadb8570c19.tar.gz
gentoo-2-d9c5063399ed1c8b4fb73402db139aadb8570c19.tar.bz2
gentoo-2-d9c5063399ed1c8b4fb73402db139aadb8570c19.zip
Update to distutils-r1 #543960 by Andrew Udvare.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/nfoview/ChangeLog10
-rw-r--r--app-text/nfoview/nfoview-1.15.1.ebuild44
-rw-r--r--app-text/nfoview/nfoview-9999.ebuild14
3 files changed, 57 insertions, 11 deletions
diff --git a/app-text/nfoview/ChangeLog b/app-text/nfoview/ChangeLog
index d090bfe00cd1..2afaf010f02e 100644
--- a/app-text/nfoview/ChangeLog
+++ b/app-text/nfoview/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/nfoview
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/nfoview/ChangeLog,v 1.24 2013/04/21 03:22:48 vapier Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/nfoview/ChangeLog,v 1.25 2015/03/26 23:38:57 vapier Exp $
+
+*nfoview-1.15.1 (26 Mar 2015)
+
+ 26 Mar 2015; Mike Frysinger <vapier@gentoo.org> +nfoview-1.15.1.ebuild,
+ nfoview-9999.ebuild:
+ Update to distutils-r1 #543960 by Andrew Udvare.
*nfoview-1.12.1 (21 Apr 2013)
diff --git a/app-text/nfoview/nfoview-1.15.1.ebuild b/app-text/nfoview/nfoview-1.15.1.ebuild
new file mode 100644
index 000000000000..dffa61a38332
--- /dev/null
+++ b/app-text/nfoview/nfoview-1.15.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/nfoview/nfoview-1.15.1.ebuild,v 1.1 2015/03/26 23:38:57 vapier Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{3_3,3_4} )
+
+inherit distutils-r1 fdo-mime gnome2-utils
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="git://github.com/otsaloma/nfoview.git
+ http://github.com/otsaloma/nfoview.git"
+ inherit git-2
+ SRC_URI=""
+ #KEYWORDS=""
+else
+ SRC_URI="http://download.gna.org/nfoview/${PV:0:4}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="simple viewer for NFO files, which are ASCII art in the CP437 codepage"
+HOMEPAGE="http://home.gna.org/nfoview/"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-python/pygobject:3"
+RDEPEND="${DEPEND}
+ media-fonts/terminus-font"
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
diff --git a/app-text/nfoview/nfoview-9999.ebuild b/app-text/nfoview/nfoview-9999.ebuild
index a8755b6868dd..01d86fa9243e 100644
--- a/app-text/nfoview/nfoview-9999.ebuild
+++ b/app-text/nfoview/nfoview-9999.ebuild
@@ -1,14 +1,12 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/nfoview/nfoview-9999.ebuild,v 1.12 2013/04/21 03:22:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/nfoview/nfoview-9999.ebuild,v 1.13 2015/03/26 23:38:57 vapier Exp $
-EAPI=3
+EAPI="5"
-PYTHON_DEPEND="3:3.2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.*"
+PYTHON_COMPAT=( python{3_3,3_4} )
-inherit distutils fdo-mime gnome2-utils
+inherit distutils-r1 fdo-mime gnome2-utils
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://github.com/otsaloma/nfoview.git
http://github.com/otsaloma/nfoview.git"
@@ -38,11 +36,9 @@ pkg_preinst() {
pkg_postinst() {
gnome2_icon_cache_update
fdo-mime_desktop_database_update
- distutils_pkg_postinst
}
pkg_postrm() {
gnome2_icon_cache_update
fdo-mime_desktop_database_update
- distutils_pkg_postrm
}