summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Turk <satai@gentoo.org>2002-12-20 07:14:01 +0000
committerMatthew Turk <satai@gentoo.org>2002-12-20 07:14:01 +0000
commitd73b6152f39f914c78bc117fa5554e03647b5b73 (patch)
treec143be8dda6435ec05e99a68ae072f49f784bcad /app-text
parentupdated ebuild should fix some issues (diff)
downloadgentoo-2-d73b6152f39f914c78bc117fa5554e03647b5b73.tar.gz
gentoo-2-d73b6152f39f914c78bc117fa5554e03647b5b73.tar.bz2
gentoo-2-d73b6152f39f914c78bc117fa5554e03647b5b73.zip
Closing 10734, updating to the latest version. I hope this doesn't mess things
up TOO badly.
Diffstat (limited to 'app-text')
-rw-r--r--app-text/docbook-xsl-stylesheets/ChangeLog8
-rw-r--r--app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.57.0.ebuild81
-rw-r--r--app-text/docbook-xsl-stylesheets/files/digest-docbook-xsl-stylesheets-1.57.01
3 files changed, 89 insertions, 1 deletions
diff --git a/app-text/docbook-xsl-stylesheets/ChangeLog b/app-text/docbook-xsl-stylesheets/ChangeLog
index f3010f919ddf..66b41c2552e5 100644
--- a/app-text/docbook-xsl-stylesheets/ChangeLog
+++ b/app-text/docbook-xsl-stylesheets/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/docbook-xsl-stylesheets
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-xsl-stylesheets/ChangeLog,v 1.7 2002/12/13 10:56:19 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-xsl-stylesheets/ChangeLog,v 1.8 2002/12/20 07:14:01 satai Exp $
+
+*docbook-xsl-stylesheets-1.57.0 (20 Dec 2002)
+
+ 20 Dec 2002; Matthew Turk <satai@gentoo.org> :
+ New version. Had to hardcode a remove command to clean up after 1.52.2.
+ This will be removed in some future revision.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.57.0.ebuild b/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.57.0.ebuild
new file mode 100644
index 000000000000..2ffb9ef055a7
--- /dev/null
+++ b/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.57.0.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.57.0.ebuild,v 1.1 2002/12/20 07:14:01 satai Exp $
+
+S=${WORKDIR}/docbook-xsl-${PV}
+DESCRIPTION="XSL Stylesheets for Docbook"
+SRC_URI="mirror://sourceforge/docbook/docbook-xsl-${PV}.tar.gz"
+HOMEPAGE="http://www.oasis-open.org/docbook/"
+
+DEPEND="dev-libs/libxml2"
+
+SLOT="0"
+LICENSE="as-is | BSD"
+KEYWORDS="x86"
+
+src_install() {
+ DEST="/usr/share/sgml/docbook/xsl-stylesheets-${PV}"
+ dodir ${DEST}
+ dodir /usr/share/doc/${P}
+ cp -af doc ${D}/usr/share/doc/${P}/html
+ cp VERSION ${D}/${DEST}
+
+ for i in common extensions fo html htmlhelp images javahelp lib template xhtml
+ do
+ cd ${S}
+ cp -af ${i} ${D}/${DEST}
+ cd ${D}/${DEST}/${i}
+
+ for j in ChangeLog LostLog README
+ do
+ if [ -e ${j} ]
+ then
+ mv ${j} ${D}/usr/share/doc/${P}/${j}.${i}
+ fi
+ done
+ done
+
+ prepalldocs
+ cd ${S}
+ dodoc BUGS TODO WhatsNew
+
+ dodir /etc/xml
+}
+
+pkg_postinst() {
+ CATALOG=/etc/xml/catalog
+
+ [ -e $CATALOG ] || /usr/bin/xmlcatalog --noout --create $CATALOG
+
+
+ # I REALLY don't want to do this, but I see no other way.
+ # We need to clean out the old entries, and this is the only way I can
+ # guarantee it... I will remove this once the next version is released.
+
+ /usr/bin/xmlcatalog --noout --del \
+ "/usr/share/sgml/docbook/xsl-stylesheets-1.52.2" $CATALOG
+
+ /usr/bin/xmlcatalog --noout --add "rewriteSystem" \
+ "http://docbook.sourceforge.net/release/xsl/${PV}" \
+ "/usr/share/sgml/docbook/xsl-stylesheets-${PV}" $CATALOG
+ /usr/bin/xmlcatalog --noout --add "rewriteURI" \
+ "http://docbook.sourceforge.net/release/xsl/${PV}" \
+ "/usr/share/sgml/docbook/xsl-stylesheets-${PV}" $CATALOG
+ /usr/bin/xmlcatalog --noout --add "rewriteSystem" \
+ "http://docbook.sourceforge.net/release/xsl/current" \
+ "/usr/share/sgml/docbook/xsl-stylesheets-${PV}" $CATALOG
+ /usr/bin/xmlcatalog --noout --add "rewriteURI" \
+ "http://docbook.sourceforge.net/release/xsl/current" \
+ "/usr/share/sgml/docbook/xsl-stylesheets-${PV}" $CATALOG
+
+}
+
+pkg_postrm() {
+ CATALOG=/etc/xml/catalog
+
+ # Let's clean up after ourselves.
+
+ /usr/bin/xmlcatalog --noout --del \
+ "/usr/share/sgml/docbook/xsl-stylesheets-${PV}" $CATALOG
+
+}
diff --git a/app-text/docbook-xsl-stylesheets/files/digest-docbook-xsl-stylesheets-1.57.0 b/app-text/docbook-xsl-stylesheets/files/digest-docbook-xsl-stylesheets-1.57.0
new file mode 100644
index 000000000000..397414bbee5f
--- /dev/null
+++ b/app-text/docbook-xsl-stylesheets/files/digest-docbook-xsl-stylesheets-1.57.0
@@ -0,0 +1 @@
+MD5 954cab6e9731150f0c108b929a19df49 docbook-xsl-1.57.0.tar.gz 1177980