summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2003-01-02 09:46:39 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2003-01-02 09:46:39 +0000
commit972993e245b6cf1f88a3fe49a3f97f44e7bbf88b (patch)
tree4c73e22e5ed22be0762f5dd16130824beba5f91a /app-text
parentNew ebuild for support of ardour-cvs. (diff)
downloadgentoo-2-972993e245b6cf1f88a3fe49a3f97f44e7bbf88b.tar.gz
gentoo-2-972993e245b6cf1f88a3fe49a3f97f44e7bbf88b.tar.bz2
gentoo-2-972993e245b6cf1f88a3fe49a3f97f44e7bbf88b.zip
Security update
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xpdf/ChangeLog7
-rw-r--r--app-text/xpdf/files/digest-xpdf-2.012
-rw-r--r--app-text/xpdf/xpdf-2.01.ebuild78
3 files changed, 86 insertions, 1 deletions
diff --git a/app-text/xpdf/ChangeLog b/app-text/xpdf/ChangeLog
index 7c7b50977d5f..74fdf14a9746 100644
--- a/app-text/xpdf/ChangeLog
+++ b/app-text/xpdf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/xpdf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-text/xpdf/ChangeLog,v 1.9 2002/12/13 10:56:21 blizzy Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xpdf/ChangeLog,v 1.10 2003/01/02 09:46:39 aliz Exp $
+
+*xpdf-2.01 (02 Jan 2003)
+
+ 02 Jan 2003; Daniel Ahlberg <aliz@gentoo.org> xpdf-2.01.ebuild :
+ Security update.
06 Dec 2002; Rodney Rees <manson@gentoo.org> : changed sparc ~sparc keywords
diff --git a/app-text/xpdf/files/digest-xpdf-2.01 b/app-text/xpdf/files/digest-xpdf-2.01
new file mode 100644
index 000000000000..6d1b74669005
--- /dev/null
+++ b/app-text/xpdf/files/digest-xpdf-2.01
@@ -0,0 +1,2 @@
+MD5 90326075b7bdabe85dc011882365824c xpdf-2.01.tar.gz 465004
+MD5 f27f2bb23dcf7d68c402c7ba50eae22c xpdf-2.01-patch1 1038
diff --git a/app-text/xpdf/xpdf-2.01.ebuild b/app-text/xpdf/xpdf-2.01.ebuild
new file mode 100644
index 000000000000..b5d2b8f80b95
--- /dev/null
+++ b/app-text/xpdf/xpdf-2.01.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xpdf/xpdf-2.01.ebuild,v 1.1 2003/01/02 09:46:39 aliz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="An X Viewer for PDF Files"
+SRC_URI="ftp://ftp.foolabs.com/pub/xpdf/${P}.tar.gz
+ ftp://ftp.foolabs.com/pub/xpdf/${P}-patch1"
+HOMEPAGE="http://www.foolabs.com/xpdf/xpdf.html"
+IUSE=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc"
+
+DEPEND="virtual/x11
+ x11-libs/lesstif
+ >=media-libs/freetype-2.0.9
+ >=media-libs/t1lib-1.3
+ app-text/ghostscript"
+
+src_unpack() {
+ unpack ${P}.tar.gz
+ cd ${S}/xpdf
+ patch -p0 < ${DISTDIR}/${P}-patch1 || die
+}
+
+src_compile() {
+ ./configure --enable-freetype2 \
+ --with-freetype2-library=/usr/lib \
+ --with-freetype2-includes=/usr/include/freetype2 \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --sysconfdir=/etc \
+ --with-gzip || die
+
+ cat > ${S}/xpdfrc << EOF
+# use the Base-14 Type 1 fonts from ghostscript
+displayFontT1 Times-Roman /usr/share/ghostscript/fonts/n021003l.pfb
+displayFontT1 Times-Italic /usr/share/ghostscript/fonts/n021023l.pfb
+displayFontT1 Times-Bold /usr/share/ghostscript/fonts/n021004l.pfb
+displayFontT1 Times-BoldItalic /usr/share/ghostscript/fonts/n021024l.pfb
+displayFontT1 Helvetica /usr/share/ghostscript/fonts/n019003l.pfb
+displayFontT1 Helvetica-Oblique /usr/share/ghostscript/fonts/n019023l.pfb
+displayFontT1 Helvetica-Bold /usr/share/ghostscript/fonts/n019004l.pfb
+displayFontT1 Helvetica-BoldOblique /usr/share/ghostscript/fonts/n019024l.pfb
+displayFontT1 Courier /usr/share/ghostscript/fonts/n022003l.pfb
+displayFontT1 Courier-Oblique /usr/share/ghostscript/fonts/n022023l.pfb
+displayFontT1 Courier-Bold /usr/share/ghostscript/fonts/n022004l.pfb
+displayFontT1 Courier-BoldOblique /usr/share/ghostscript/fonts/n022024l.pfb
+displayFontT1 Symbol /usr/share/ghostscript/fonts/s050000l.pfb
+displayFontT1 ZapfDingbats /usr/share/ghostscript/fonts/d050000l.pfb
+EOF
+
+ make || die
+}
+
+
+src_install() {
+ # don't use builtin make install, as it doesn't compress manpages
+ into /usr
+ dodoc README ANNOUNCE CHANGES
+ doman doc/*.[1-8]
+ dobin xpdf/pdfimages xpdf/pdfinfo xpdf/pdftopbm
+ dobin xpdf/pdftops xpdf/pdftotext xpdf/xpdf
+ insinto /etc
+ doins xpdfrc
+}
+
+pkg_postinst() {
+ einfo
+ einfo "HINT: To have even nicer results add these lines to your ~/.xpdfrc"
+ einfo
+ einfo " include /etc/xpdfrc"
+ einfo " t1libControl high"
+ einfo " freetypeControl high"
+ einfo
+}
+