summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2012-07-26 07:04:22 +0000
committerBen de Groot <yngwin@gentoo.org>2012-07-26 07:04:22 +0000
commit2dd44fc2d30ff1f012fa4f4127398724a1a8cc2d (patch)
treeba2ec54f57c19244b99055031073cf25f434c609 /app-text
parentAdd locales needed for goldendict (diff)
downloadgentoo-2-2dd44fc2d30ff1f012fa4f4127398724a1a8cc2d.tar.gz
gentoo-2-2dd44fc2d30ff1f012fa4f4127398724a1a8cc2d.tar.bz2
gentoo-2-2dd44fc2d30ff1f012fa4f4127398724a1a8cc2d.zip
Use l10n.eclass for handling locales. Bump eapi to 4.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/goldendict/ChangeLog5
-rw-r--r--app-text/goldendict/goldendict-1.0.1.ebuild35
2 files changed, 19 insertions, 21 deletions
diff --git a/app-text/goldendict/ChangeLog b/app-text/goldendict/ChangeLog
index d393d8fe7b83..980a8582d7a1 100644
--- a/app-text/goldendict/ChangeLog
+++ b/app-text/goldendict/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/goldendict
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/goldendict/ChangeLog,v 1.8 2012/07/19 17:36:12 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/goldendict/ChangeLog,v 1.9 2012/07/26 07:04:22 yngwin Exp $
+
+ 26 Jul 2012; Ben de Groot <yngwin@gentoo.org> goldendict-1.0.1.ebuild:
+ Use l10n.eclass for handling locales. Bump eapi to 4.
19 Jul 2012; Michael Palimaka <kensington@gentoo.org>
+files/goldendict-1.0.1-gcc-4.7.patch, goldendict-1.0.1.ebuild:
diff --git a/app-text/goldendict/goldendict-1.0.1.ebuild b/app-text/goldendict/goldendict-1.0.1.ebuild
index d7e273be4b85..31e5df7cf3bc 100644
--- a/app-text/goldendict/goldendict-1.0.1.ebuild
+++ b/app-text/goldendict/goldendict-1.0.1.ebuild
@@ -1,14 +1,14 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/goldendict/goldendict-1.0.1.ebuild,v 1.7 2012/07/19 17:36:12 kensington Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/goldendict/goldendict-1.0.1.ebuild,v 1.8 2012/07/26 07:04:22 yngwin Exp $
-EAPI=3
-LANGSLONG="ar_SA bg_BG cs_CZ de_DE el_GR it_IT lt_LT ru_RU uk_UA vi_VN zh_CN"
+EAPI=4
+PLOCALES="ar_SA bg_BG cs_CZ de_DE el_GR it_IT lt_LT ru_RU uk_UA vi_VN zh_CN"
-inherit qt4-r2
+inherit l10n qt4-r2
DESCRIPTION="Feature-rich dictionary lookup program"
-HOMEPAGE="http://goldendict.org"
+HOMEPAGE="http://goldendict.org/"
SRC_URI="mirror://sourceforge/${PN}/${P}-src.tar.bz2"
LICENSE="GPL-3"
@@ -42,17 +42,10 @@ PATCHES=( "${FILESDIR}/${P}-gcc-4.7.patch" )
src_prepare() {
qt4-r2_src_prepare
- # linguas
- for x in ${LANGSLONG}; do
- if use !linguas_${x%_*}; then
- sed -e "s,locale/${x}.ts,," \
- -i ${PN}.pro || die
- fi
- done
+ l10n_for_each_disabled_locale_do editpro
# do not install duplicates
- sed -e '/[icon,desktop]s2/d' \
- -i ${PN}.pro || die
+ sed -e '/[icon,desktop]s2/d' -i ${PN}.pro || die
}
src_configure() {
@@ -61,12 +54,14 @@ src_configure() {
src_install() {
qt4-r2_src_install
+ l10n_for_each_locale_do insqm
+}
+
+editpro() {
+ sed -e "s;locale/${1}.ts;;" -i ${PN}.pro || die
+}
- # install translations
+insqm() {
insinto /usr/share/apps/${PN}/locale
- for x in ${LANGSLONG}; do
- if use linguas_${x%_*}; then
- doins locale/${x}.qm || die
- fi
- done
+ doins locale/${1}.qm
}