summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2010-02-28 20:08:37 +0000
committerDaniel Pielmeier <billie@gentoo.org>2010-02-28 20:08:37 +0000
commit0fa4d1e281d3998f95d3e5a837e32480e5ed1427 (patch)
tree47628e98ed866b9160b67cd32d707b253ae583fb /app-text
parentRemove debugger plugin use flag wrt bug #298852 (diff)
downloadgentoo-2-0fa4d1e281d3998f95d3e5a837e32480e5ed1427.tar.gz
gentoo-2-0fa4d1e281d3998f95d3e5a837e32480e5ed1427.tar.bz2
gentoo-2-0fa4d1e281d3998f95d3e5a837e32480e5ed1427.zip
Verson bump.
(Portage version: 2.1.7.17/cvs/Linux i686)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gocr/ChangeLog7
-rw-r--r--app-text/gocr/gocr-0.45.ebuild4
-rw-r--r--app-text/gocr/gocr-0.46.ebuild4
-rw-r--r--app-text/gocr/gocr-0.48.ebuild44
4 files changed, 54 insertions, 5 deletions
diff --git a/app-text/gocr/ChangeLog b/app-text/gocr/ChangeLog
index a36f7cdd46e2..0df18f044553 100644
--- a/app-text/gocr/ChangeLog
+++ b/app-text/gocr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/gocr
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/ChangeLog,v 1.59 2010/02/22 20:58:34 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/ChangeLog,v 1.60 2010/02/28 20:08:37 billie Exp $
+
+*gocr-0.48 (28 Feb 2010)
+
+ 28 Feb 2010; Daniel Pielmeier <billie@gentoo.org> +gocr-0.48.ebuild:
+ Verson bump.
22 Feb 2010; Jonathan Callen <abcd@gentoo.org> gocr-0.47.ebuild:
Transfer prefix keywords, bump EAPI
diff --git a/app-text/gocr/gocr-0.45.ebuild b/app-text/gocr/gocr-0.45.ebuild
index 510c2508e6ab..18c45a51759f 100644
--- a/app-text/gocr/gocr-0.45.ebuild
+++ b/app-text/gocr/gocr-0.45.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/gocr-0.45.ebuild,v 1.8 2009/12/26 17:31:31 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/gocr-0.45.ebuild,v 1.9 2010/02/28 20:08:37 billie Exp $
inherit eutils
diff --git a/app-text/gocr/gocr-0.46.ebuild b/app-text/gocr/gocr-0.46.ebuild
index aabdcba676a2..c048fd9bc3b1 100644
--- a/app-text/gocr/gocr-0.46.ebuild
+++ b/app-text/gocr/gocr-0.46.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/gocr-0.46.ebuild,v 1.2 2009/12/26 17:31:31 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/gocr-0.46.ebuild,v 1.3 2010/02/28 20:08:37 billie Exp $
inherit eutils
diff --git a/app-text/gocr/gocr-0.48.ebuild b/app-text/gocr/gocr-0.48.ebuild
new file mode 100644
index 000000000000..1fcdb58a5c3b
--- /dev/null
+++ b/app-text/gocr/gocr-0.48.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/gocr/gocr-0.48.ebuild,v 1.1 2010/02/28 20:08:37 billie Exp $
+
+EAPI=3
+
+inherit base eutils
+
+DESCRIPTION="An OCR (Optical Character Recognition) reader"
+HOMEPAGE="http://jocr.sourceforge.net"
+SRC_URI="http://www-e.uni-magdeburg.de/jschulen/ocr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc tk"
+
+DEPEND=">=media-libs/netpbm-9.12
+ doc? ( >=media-gfx/transfig-3.2 app-text/ghostscript-gpl )
+ tk? ( dev-lang/tk )"
+
+DOCS="AUTHORS BUGS CREDITS HISTORY RE* TODO"
+
+src_compile() {
+ local mymakes="src man"
+
+ use doc && mymakes="${mymakes} doc examples"
+
+ emake ${mymakes} || die "make ${mymakes} failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" exec_prefix="${EPREFIX}/usr" install || die "make install failed"
+ # remove the tk frontend if tk is not selected
+ use tk || rm "${ED}"/usr/bin/gocr.tcl
+ # and install the documentation and examples
+ if use doc ; then
+ DOCS="${DOCS} doc/gocr.html doc/examples.txt doc/unicode.txt"
+ insinto /usr/share/doc/${PF}/examples
+ doins "${S}"/examples/*.{fig,tex,pcx}
+ fi
+ # and then install all the docs
+ dodoc ${DOCS}
+}