summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-08-19 15:23:41 +0000
committerMike Frysinger <vapier@gentoo.org>2011-08-19 15:23:41 +0000
commit091b0b5a66ced8af1f5179b84cd4aaf8cf16ff97 (patch)
tree4b5d7aeacea2ffcca48ad10911a19d21ed2e3893 /app-text
parentRemove old (diff)
downloadgentoo-2-091b0b5a66ced8af1f5179b84cd4aaf8cf16ff97.tar.gz
gentoo-2-091b0b5a66ced8af1f5179b84cd4aaf8cf16ff97.tar.bz2
gentoo-2-091b0b5a66ced8af1f5179b84cd4aaf8cf16ff97.zip
Use portable fix for parallel make, include man pages in the dist to avoid CBUILD vs CHOST issues, and drop autotool regeneration to speed things up.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xmlto/ChangeLog9
-rw-r--r--app-text/xmlto/files/xmlto-0.0.24-parallelmake.patch56
-rw-r--r--app-text/xmlto/xmlto-0.0.24-r1.ebuild47
3 files changed, 111 insertions, 1 deletions
diff --git a/app-text/xmlto/ChangeLog b/app-text/xmlto/ChangeLog
index 5b078142de90..a1c4980b2e94 100644
--- a/app-text/xmlto/ChangeLog
+++ b/app-text/xmlto/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/xmlto
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/ChangeLog,v 1.68 2011/07/30 22:10:37 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/ChangeLog,v 1.69 2011/08/19 15:23:41 vapier Exp $
+
+*xmlto-0.0.24-r1 (19 Aug 2011)
+
+ 19 Aug 2011; Mike Frysinger <vapier@gentoo.org> +xmlto-0.0.24-r1.ebuild,
+ +files/xmlto-0.0.24-parallelmake.patch:
+ Use portable fix for parallel make, include man pages in the dist to avoid
+ CBUILD vs CHOST issues, and drop autotool regeneration to speed things up.
*xmlto-0.0.24 (30 Jul 2011)
diff --git a/app-text/xmlto/files/xmlto-0.0.24-parallelmake.patch b/app-text/xmlto/files/xmlto-0.0.24-parallelmake.patch
new file mode 100644
index 000000000000..6d18724dd771
--- /dev/null
+++ b/app-text/xmlto/files/xmlto-0.0.24-parallelmake.patch
@@ -0,0 +1,56 @@
+From f2ada08ce5b92de1869419f1ed50aa1190a8bfb4 Mon Sep 17 00:00:00 2001
+From: Mike Frysinger <vapier@gentoo.org>
+Date: Fri, 19 Aug 2011 10:47:10 -0400
+Subject: [PATCH] fix building manpages in parallel
+
+The current man page rules allow make to fire off two children (1 per
+man page), but each child will attempt to create all the required man
+pages. So it's possible for the children to collide on their outputs.
+Rewrite the rules so that each man page will fire off one child and
+only process its specific man page.
+
+Signed-off-by: Mike Frysinger <vapier@gentoo.org>
+---
+ Makefile.am | 8 +++-----
+ 1 files changed, 3 insertions(+), 5 deletions(-)
+
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -68,11 +68,9 @@ EXTRA_DIST = xmlto.spec \
+ doc/xmlif.xml \
+ xmlto.mak
+
+-$(man1_MANS): $(top_srcdir)/doc/xmlto.xml $(top_srcdir)/doc/xmlif.xml
+- for xml in xmlif.xml xmlto.xml; do \
+- FORMAT_DIR=$(top_srcdir)/format \
+- $(BASH) ./xmlto -o man/man1 man $(top_srcdir)/doc/$$xml ; \
+- done || ( RC=$$?; exit $$RC )
++GEN_MANPAGE = FORMAT_DIR=$(top_srcdir)/format $(BASH) ./xmlto -o $(@D) man $<
++man/man1/xmlto.1: doc/xmlto.xml ; $(GEN_MANPAGE)
++man/man1/xmlif.1: doc/xmlif.xml ; $(GEN_MANPAGE)
+
+ TESTS_ENVIRONMENT = top_srcdir=$(top_srcdir) top_builddir=$(top_builddir)
+ TESTS = xmlif/test/run-test
+
+The Makefile.in patch is trivial, so avoid autotools just for this
+
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -959,11 +959,9 @@
+ uninstall-man uninstall-man1 uninstall-nobase_pkgdataDATA
+
+
+-$(man1_MANS): $(top_srcdir)/doc/xmlto.xml $(top_srcdir)/doc/xmlif.xml
+- for xml in xmlif.xml xmlto.xml; do \
+- FORMAT_DIR=$(top_srcdir)/format \
+- $(BASH) ./xmlto -o man/man1 man $(top_srcdir)/doc/$$xml ; \
+- done || ( RC=$$?; exit $$RC )
++GEN_MANPAGE = FORMAT_DIR=$(top_srcdir)/format $(BASH) ./xmlto -o $(@D) man $<
++man/man1/xmlto.1: doc/xmlto.xml ; $(GEN_MANPAGE)
++man/man1/xmlif.1: doc/xmlif.xml ; $(GEN_MANPAGE)
+
+ tag:
+ cvs tag -c `echo V@VERSION@ | tr . _`
+--
+1.7.6
+
diff --git a/app-text/xmlto/xmlto-0.0.24-r1.ebuild b/app-text/xmlto/xmlto-0.0.24-r1.ebuild
new file mode 100644
index 000000000000..5ec7acdce9eb
--- /dev/null
+++ b/app-text/xmlto/xmlto-0.0.24-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/xmlto/xmlto-0.0.24-r1.ebuild,v 1.1 2011/08/19 15:23:41 vapier Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="script for converting XML and DocBook formatted documents to a variety of output formats"
+HOMEPAGE="https://fedorahosted.org/xmlto/"
+SRC_URI="https://fedorahosted.org/releases/x/m/xmlto/${P}.tar.bz2
+ mirror://gentoo/${P}-mans.tar.bz2
+ http://dev.gentoo.org/~vapier/dist/${P}-mans.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="latex"
+
+RDEPEND="app-shells/bash
+ || ( sys-apps/which sys-freebsd/freebsd-ubin )
+ dev-libs/libxslt
+ >=app-text/docbook-xsl-stylesheets-1.62.0-r1
+ ~app-text/docbook-xml-dtd-4.2
+ || ( sys-apps/util-linux app-misc/getopt )
+ || ( >=sys-apps/coreutils-6.10-r1 sys-freebsd/freebsd-ubin )
+ latex? ( >=app-text/passivetex-1.25 >=dev-tex/xmltex-1.9-r2 )"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.0.22-format_fo_passivetex_check.patch
+ epatch "${FILESDIR}"/${PN}-0.0.24-parallelmake.patch
+}
+
+src_configure() {
+ export BASH
+ has_version sys-apps/util-linux || export GETOPT="getopt-long"
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog FAQ NEWS README THANKS
+ insinto /usr/share/doc/${PF}/xml
+ doins doc/*.xml
+}