summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnders Rune Jensen <arj@gentoo.org>2005-07-12 16:14:52 +0000
committerAnders Rune Jensen <arj@gentoo.org>2005-07-12 16:14:52 +0000
commit00edb3e656f70a98a2215cdc002ba76621120552 (patch)
tree89017af96a219ac1c0fdf2be32f51f1d4b2548c2 /app-text
parentAdd ~alpha to gcc-3.4.4 (diff)
downloadgentoo-2-00edb3e656f70a98a2215cdc002ba76621120552.tar.gz
gentoo-2-00edb3e656f70a98a2215cdc002ba76621120552.tar.bz2
gentoo-2-00edb3e656f70a98a2215cdc002ba76621120552.zip
new version
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/aspell/ChangeLog7
-rw-r--r--app-text/aspell/Manifest14
-rw-r--r--app-text/aspell/aspell-0.60.3.ebuild68
-rw-r--r--app-text/aspell/files/digest-aspell-0.60.31
4 files changed, 78 insertions, 12 deletions
diff --git a/app-text/aspell/ChangeLog b/app-text/aspell/ChangeLog
index c53ace45c567..57bb8a1ed3fa 100644
--- a/app-text/aspell/ChangeLog
+++ b/app-text/aspell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/aspell
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.71 2005/02/19 23:57:08 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/ChangeLog,v 1.72 2005/07/12 16:14:51 arj Exp $
+
+*aspell-0.60.3 (12 Jul 2005)
+
+ 12 Jul 2005; Anders Rune Jensen <arj@gentoo.org> +aspell-0.60.3.ebuild:
+ Version bump.
20 Feb 2005; David Holm <dholm@gentoo.org> :
Added to ~ppc.
diff --git a/app-text/aspell/Manifest b/app-text/aspell/Manifest
index 1855269b4cfc..07cf3822908f 100644
--- a/app-text/aspell/Manifest
+++ b/app-text/aspell/Manifest
@@ -1,10 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 99edcd1146a80e07289b6c5d1b975063 ChangeLog 11368
MD5 d40ff6a488da2fdffb038f21cea2aedf aspell-0.50.5-r4.ebuild 1888
-MD5 eb03775ece62e57725480e782cd84ee8 metadata.xml 162
MD5 c80cb44776fc951ad669a37112e50f65 aspell-0.60.2.ebuild 1753
+MD5 eb03775ece62e57725480e782cd84ee8 metadata.xml 162
+MD5 c80cb44776fc951ad669a37112e50f65 aspell-0.60.3.ebuild 1753
MD5 4fa550930c5e5fb38177ac9f77619891 files/01-gcc3.3-assert.patch 309
MD5 f956a4b48687a0823d0d5d7608b567e9 files/02-gcc3.3-constcast.patch 453
MD5 d2091b79a60b395e1ce3c496b7e3d45a files/aspell-0.50.5-charcount.patch 2264
@@ -12,10 +10,4 @@ MD5 02560c627d075d243720f1067bf45bcf files/aspell-buffer-fix.patch 1556
MD5 ec7c300a1661ae94b55736f74a045bab files/aspell-quotechar-fix.patch 473
MD5 1b5d84b6b88a3dfe388ad2e4b1f48155 files/digest-aspell-0.50.5-r4 66
MD5 ea58a3b4827dbc2d3a5606ab927de6a6 files/digest-aspell-0.60.2 66
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCv81CTM53OX+9xmMRAnzzAJ0dMRA++vFmozgjcfIGEtXQZ9xtKQCgySOa
-0rx7kRy+OHfgxzPKPYVhOsw=
-=8NXq
------END PGP SIGNATURE-----
+MD5 1b48dc4c225359e25d93946c0f313adb files/digest-aspell-0.60.3 66
diff --git a/app-text/aspell/aspell-0.60.3.ebuild b/app-text/aspell/aspell-0.60.3.ebuild
new file mode 100644
index 000000000000..bd55d1691788
--- /dev/null
+++ b/app-text/aspell/aspell-0.60.3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/aspell/aspell-0.60.3.ebuild,v 1.1 2005/07/12 16:14:51 arj Exp $
+
+inherit libtool eutils flag-o-matic
+
+DESCRIPTION="A spell checker replacement for ispell"
+HOMEPAGE="http://aspell.net/"
+SRC_URI="mirror://gnu/aspell/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc-macos ~ppc"
+IUSE="gpm"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( sys-libs/gpm )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+}
+
+src_compile() {
+ [ "${ARCH}" == "ppc" ] && append-flags -O2 -fsigned-char
+ use gpm && append-ldflags -lgpm
+ filter-flags -fno-rtti
+ filter-flags -fvisibility=hidden #77109
+ elibtoolize --reverse-deps
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/aspell \
+ --enable-docdir=/usr/share/doc/${PF} || die
+
+ emake || die
+}
+
+src_install() {
+ dodoc README* TODO
+
+ make DESTDIR="${D}" install || die
+ mv ${D}/usr/share/doc/${PF}/man-html ${D}/usr/share/doc/${PF}/html
+ mv ${D}/usr/share/doc/${PF}/man-text ${D}/usr/share/doc/${PF}/text
+
+ # install ispell/aspell compatibility scripts
+ exeinto /usr/bin
+ newexe scripts/ispell ispell-aspell
+ newexe scripts/spell spell-aspell
+
+ cd examples
+ make clean || die
+ docinto examples
+ dodoc ${S}/examples/*
+}
+
+pkg_postinst() {
+ einfo "You will need to install a dictionary now. Please choose an"
+ einfo "aspell-<LANG> dictionary from the app-dicts category"
+ einfo "After installing an aspell dictionary for your language(s),"
+ einfo "You may use the aspell-import utility to import your personal"
+ einfo "dictionaries from ispell, pspell and the older aspell"
+
+ ewarn ""
+ ewarn "Please re-emerge ALL your aspell-LANG dictionaries"
+ ewarn ""
+ ebeep 5
+}
diff --git a/app-text/aspell/files/digest-aspell-0.60.3 b/app-text/aspell/files/digest-aspell-0.60.3
new file mode 100644
index 000000000000..5e5e1865bf1c
--- /dev/null
+++ b/app-text/aspell/files/digest-aspell-0.60.3
@@ -0,0 +1 @@
+MD5 ca44ac2fcfdc7213e03d3b5610ce141a aspell-0.60.3.tar.gz 1635824