summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2004-01-04 17:23:07 +0000
committerSeemant Kulleen <seemant@gentoo.org>2004-01-04 17:23:07 +0000
commit9af84b5d1bf3129415c677bb87b0623b5b584a88 (patch)
tree4aec82a6111c2e00702a30b6df7ac33c2ba09dc2 /app-text/xml2doc/xml2doc-20030510.ebuild
parentnever mind, DOES work for me (diff)
downloadgentoo-2-9af84b5d1bf3129415c677bb87b0623b5b584a88.tar.gz
gentoo-2-9af84b5d1bf3129415c677bb87b0623b5b584a88.tar.bz2
gentoo-2-9af84b5d1bf3129415c677bb87b0623b5b584a88.zip
SRC_URI fix thanks to: James Cloos <cloos@jhcloos.com> in bug #37201
Diffstat (limited to 'app-text/xml2doc/xml2doc-20030510.ebuild')
-rw-r--r--app-text/xml2doc/xml2doc-20030510.ebuild23
1 files changed, 9 insertions, 14 deletions
diff --git a/app-text/xml2doc/xml2doc-20030510.ebuild b/app-text/xml2doc/xml2doc-20030510.ebuild
index 5051e751d693..bd1976df4395 100644
--- a/app-text/xml2doc/xml2doc-20030510.ebuild
+++ b/app-text/xml2doc/xml2doc-20030510.ebuild
@@ -1,33 +1,29 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/xml2doc/xml2doc-20030510.ebuild,v 1.1 2003/10/16 15:11:39 obz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/xml2doc/xml2doc-20030510.ebuild,v 1.2 2004/01/04 17:23:01 seemant Exp $
+IUSE="pdflib"
+
+S=${WORKDIR}/${PN}
DESCRIPTION="An XML processor tool that allows for converting documents written in simple XML to a variety of document formats (eg pdf,html,txt,manpage)"
-SRC_URI="mirror://sourceforge/${PN}/src/${P}.tgz"
HOMEPAGE="http://xml2doc.sourceforge.net"
-LICENSE="GPL-2"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz"
-IUSE="pdflib"
-KEYWORDS="~x86"
SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~amd64 ~ia64 ~ppc64"
DEPEND=">=dev-libs/libxml2-2.5
pdflib? ( >=media-libs/pdflib-4 )"
-S=${WORKDIR}/${PN}
-
src_compile() {
-
- local myconf=""
use pdflib || myconf="${myconf} --disable-pdf"
- econf ${myconf} || die
+ econf `use_enable pdflib pdf` || die
emake || die
-
}
src_install() {
-
# xml2doc's make install is unfortunately broken
# binary
dobin ${S}/src/xml2doc
@@ -39,5 +35,4 @@ src_install() {
cd ${S}/doc
${S}/src/xml2doc -oM manpage.xml xml2doc.1
doman xml2doc.1
-
}