summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Hood <squinky86@gentoo.org>2006-06-13 22:25:33 +0000
committerJon Hood <squinky86@gentoo.org>2006-06-13 22:25:33 +0000
commit80209318ff17a52fb9387c2127f4f895e7c24da5 (patch)
tree323a8fc1c880787d43c229d34d97e092515582da /app-text/sword
parentadd lucene support to sword (diff)
downloadgentoo-2-80209318ff17a52fb9387c2127f4f895e7c24da5.tar.gz
gentoo-2-80209318ff17a52fb9387c2127f4f895e7c24da5.tar.bz2
gentoo-2-80209318ff17a52fb9387c2127f4f895e7c24da5.zip
Version bump, add lucene support and fix icu build issues.
(Portage version: 2.1_rc4-r5)
Diffstat (limited to 'app-text/sword')
-rw-r--r--app-text/sword/ChangeLog7
-rw-r--r--app-text/sword/files/digest-sword-1.5.82
-rw-r--r--app-text/sword/files/digest-sword-1.5.8-r13
-rw-r--r--app-text/sword/sword-1.5.8-r1.ebuild49
4 files changed, 60 insertions, 1 deletions
diff --git a/app-text/sword/ChangeLog b/app-text/sword/ChangeLog
index c345f14047c9..a92c2a6811db 100644
--- a/app-text/sword/ChangeLog
+++ b/app-text/sword/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/sword
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sword/ChangeLog,v 1.27 2006/04/28 00:40:41 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/ChangeLog,v 1.28 2006/06/13 22:25:33 squinky86 Exp $
+
+*sword-1.5.8-r1 (13 Jun 2006)
+
+ 13 Jun 2006; Jon Hood <squinky86@gentoo.org> +sword-1.5.8-r1.ebuild:
+ Version bump, add lucene support and fix icu build issues.
28 Apr 2006; Jon Hood <squinky86@gentoo.org> metadata.xml,
-sword-1.5.8_pre1.ebuild:
diff --git a/app-text/sword/files/digest-sword-1.5.8 b/app-text/sword/files/digest-sword-1.5.8
index d8397f8e0ec6..21fc3f6e2cb4 100644
--- a/app-text/sword/files/digest-sword-1.5.8
+++ b/app-text/sword/files/digest-sword-1.5.8
@@ -1 +1,3 @@
MD5 c36398c84bfb044c0c66ef3ffcf29400 sword-1.5.8.tar.gz 1714799
+RMD160 ce896322d6c4389d4db17cb3d780b8d2a305498c sword-1.5.8.tar.gz 1714799
+SHA256 aeb57fe89716807f331eb17fcf23ef1ba3ad3e7018cd2d32560677ffe6937ce9 sword-1.5.8.tar.gz 1714799
diff --git a/app-text/sword/files/digest-sword-1.5.8-r1 b/app-text/sword/files/digest-sword-1.5.8-r1
new file mode 100644
index 000000000000..21fc3f6e2cb4
--- /dev/null
+++ b/app-text/sword/files/digest-sword-1.5.8-r1
@@ -0,0 +1,3 @@
+MD5 c36398c84bfb044c0c66ef3ffcf29400 sword-1.5.8.tar.gz 1714799
+RMD160 ce896322d6c4389d4db17cb3d780b8d2a305498c sword-1.5.8.tar.gz 1714799
+SHA256 aeb57fe89716807f331eb17fcf23ef1ba3ad3e7018cd2d32560677ffe6937ce9 sword-1.5.8.tar.gz 1714799
diff --git a/app-text/sword/sword-1.5.8-r1.ebuild b/app-text/sword/sword-1.5.8-r1.ebuild
new file mode 100644
index 000000000000..1574c4398484
--- /dev/null
+++ b/app-text/sword/sword-1.5.8-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sword/sword-1.5.8-r1.ebuild,v 1.1 2006/06/13 22:25:33 squinky86 Exp $
+
+DESCRIPTION="Library for Bible reading software."
+HOMEPAGE="http://www.crosswire.org/sword/"
+SRC_URI="http://www.crosswire.org/ftpmirror/pub/sword/source/v1.5/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl debug icu lucene"
+
+RDEPEND="sys-libs/zlib
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu )
+ lucene? ( dev-cpp/clucene )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ local myconf="--without-lucene --with-zlib --with-conf
+ $(use_enable debug) $(use_with curl)"
+
+ econf --with-zlib \
+ --with-conf \
+ $(use_enable curl) \
+ $(use_enable debug) \
+ $(use_with icu) \
+ $(use_enable lucene) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS CODINGSTYLE ChangeLog INSTALL README
+
+ cp -R samples examples ${D}/usr/share/doc/${PF}/
+}
+
+pkg_postinst() {
+ echo
+ einfo "Check out http://www.crosswire.org/sword/modules/"
+ einfo "to download modules that you would like to use with SWORD."
+ einfo "Follow module installation instructions found on"
+ einfo "the web or in /usr/share/doc/${PF}/INSTALL.gz."
+ echo
+}