summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-03 05:09:11 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-10-03 05:09:11 +0000
commit767b989ce892e07862a730c7bd6eaeef123ba209 (patch)
tree3bfca78c737767425c3c4cbd46aa3788494d2c5f /app-text/silvercity
parentBump to 2.4.0_rc2 (diff)
downloadgentoo-2-767b989ce892e07862a730c7bd6eaeef123ba209.tar.gz
gentoo-2-767b989ce892e07862a730c7bd6eaeef123ba209.tar.bz2
gentoo-2-767b989ce892e07862a730c7bd6eaeef123ba209.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: 14476-svn/cvs/Linux x86_64)
Diffstat (limited to 'app-text/silvercity')
-rw-r--r--app-text/silvercity/ChangeLog8
-rw-r--r--app-text/silvercity/silvercity-0.9.7.ebuild36
2 files changed, 28 insertions, 16 deletions
diff --git a/app-text/silvercity/ChangeLog b/app-text/silvercity/ChangeLog
index 56a407f344d8..49d73eeea0a1 100644
--- a/app-text/silvercity/ChangeLog
+++ b/app-text/silvercity/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/silvercity
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/silvercity/ChangeLog,v 1.24 2008/05/28 19:23:25 phreak Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/silvercity/ChangeLog,v 1.25 2009/10/03 05:09:11 arfrever Exp $
+
+ 03 Oct 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ silvercity-0.9.7.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
28 May 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing Julien Allanos (dju) from metadata.xml (as per #87168).
diff --git a/app-text/silvercity/silvercity-0.9.7.ebuild b/app-text/silvercity/silvercity-0.9.7.ebuild
index 2ec1abe39408..f2c73f3c50e0 100644
--- a/app-text/silvercity/silvercity-0.9.7.ebuild
+++ b/app-text/silvercity/silvercity-0.9.7.ebuild
@@ -1,37 +1,45 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/silvercity/silvercity-0.9.7.ebuild,v 1.7 2008/03/12 16:14:42 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/silvercity/silvercity-0.9.7.ebuild,v 1.8 2009/10/03 05:09:11 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
inherit distutils eutils python
+MY_PN="SilverCity"
+MY_P="${MY_PN}-${PV}"
+
DESCRIPTION="A lexical analyser for many languages."
HOMEPAGE="http://silvercity.sourceforge.net/"
-
-MY_P=${P/silvercity/SilverCity}
SRC_URI="mirror://sourceforge/silvercity/${MY_P}.tar.gz"
-S=${WORKDIR}/${MY_P}
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 ~ia64 ppc ~ppc64 sparc x86 ~x86-fbsd"
IUSE=""
-DEPEND=">=dev-lang/python-2.3"
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="${MY_PN}"
src_install() {
distutils_src_install
- # remove useless documentation
- rm ${D}/usr/share/doc/${P}/PKG-INFO.gz
+ # Remove useless documentation.
+ rm "${D}usr/share/doc/${P}/PKG-INFO"*
- # fix permissions
- python_version
- chmod 644 ${D}/usr/$(get_libdir)/python${PYVER}/site-packages/SilverCity/default.css
+ # Fix permissions.
+ chmod 644 "${D}"usr/$(get_libdir)/python*/site-packages/SilverCity/default.css
- # fix CR/LF issue
- find ${D}/usr/bin -iname "*.py" -exec sed -e 's/\r$//' -i \{\} \;
+ # Fix CR/LF issue.
+ find "${D}usr/bin" -iname "*.py" -exec sed -e 's/\r$//' -i \{\} \;
- # fix path
+ # Fix path.
dosed -i 's|#!/usr/home/sweetapp/bin/python|#!/usr/bin/env python|' \
/usr/bin/cgi-styler-form.py || die "dosed failed"
}