summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Ehmsen <ehmsen@gentoo.org>2006-04-24 16:15:45 +0000
committerMartin Ehmsen <ehmsen@gentoo.org>2006-04-24 16:15:45 +0000
commit1f5c6177ea6aea69df5a8a5764ba1cfb776e6009 (patch)
tree202326ade1890297d381712fd4034109673633e2 /app-text/sablotron
parentAdd ~x86-fbsd keyword. (diff)
downloadgentoo-2-1f5c6177ea6aea69df5a8a5764ba1cfb776e6009.tar.gz
gentoo-2-1f5c6177ea6aea69df5a8a5764ba1cfb776e6009.tar.bz2
gentoo-2-1f5c6177ea6aea69df5a8a5764ba1cfb776e6009.zip
Version bump to 1.0.2
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'app-text/sablotron')
-rw-r--r--app-text/sablotron/ChangeLog9
-rw-r--r--app-text/sablotron/files/digest-sablotron-1.0.23
-rw-r--r--app-text/sablotron/sablotron-1.0.2.ebuild57
3 files changed, 68 insertions, 1 deletions
diff --git a/app-text/sablotron/ChangeLog b/app-text/sablotron/ChangeLog
index 8ec8bb4a7607..713443975265 100644
--- a/app-text/sablotron/ChangeLog
+++ b/app-text/sablotron/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-text/sablotron
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/ChangeLog,v 1.47 2006/03/25 13:16:17 caleb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/ChangeLog,v 1.48 2006/04/24 16:15:45 ehmsen Exp $
+
+*sablotron-1.0.2 (24 Apr 2006)
+
+ 24 Apr 2006; Martin Ehmsen <ehmsen@gentoo.org> +sablotron-1.0.2.ebuild:
+ Version bump to 1.0.2 and fixed HOMEPAGE, thanks to F. Steinel
+ <fsteinel@flonet.net>, bug #102619.
+ Do not install INSTALL file.
25 Mar 2006; Caleb Tennis <caleb@gentoo.org> -sablotron-0.97.ebuild,
-sablotron-1.0.ebuild:
diff --git a/app-text/sablotron/files/digest-sablotron-1.0.2 b/app-text/sablotron/files/digest-sablotron-1.0.2
new file mode 100644
index 000000000000..1973fc7554e5
--- /dev/null
+++ b/app-text/sablotron/files/digest-sablotron-1.0.2
@@ -0,0 +1,3 @@
+MD5 12243bc21b149cad89e98bc89f9c103e Sablot-1.0.2.tar.gz 606814
+RMD160 314b925c46c17d23ba21507ea56c414264f3581f Sablot-1.0.2.tar.gz 606814
+SHA256 e0a6da46b89629cca907fac945a7ff6f6ec666aef6224c4b4cdea387cbd12406 Sablot-1.0.2.tar.gz 606814
diff --git a/app-text/sablotron/sablotron-1.0.2.ebuild b/app-text/sablotron/sablotron-1.0.2.ebuild
new file mode 100644
index 000000000000..7474a9d12eb4
--- /dev/null
+++ b/app-text/sablotron/sablotron-1.0.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-1.0.2.ebuild,v 1.1 2006/04/24 16:15:45 ehmsen Exp $
+
+inherit libtool gnuconfig flag-o-matic
+
+MY_PN="Sablot"
+MY_P="${MY_PN}-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="An XSLT Parser in C++"
+HOMEPAGE="http://www.gingerall.org/charlie/ga/xml/d_sab.xml"
+SRC_URI="http://download-1.gingerall.cz/download/sablot/${MY_P}.tar.gz"
+
+# Sablotron can optionally be built under GPL, using MPL for now
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc perl"
+
+RDEPEND=">=dev-libs/expat-1.95.6-r1"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-perl/XML-Parser-2.3 )"
+
+DOCS="README README_JS RELEASE src/TODO"
+
+src_compile() {
+ local myconf=
+
+ # Detect mips systems properly
+ gnuconfig_update
+
+ # Please do not remove, else we get references to PORTAGE_TMPDIR
+ # in /usr/lib/libsablot.la ...
+ elibtoolize
+
+ use perl \
+ && myconf="${myconf} --enable-perlconnect"
+
+ use doc \
+ && myconf="${myconf} --with-html-dir=${D}/usr/share/doc/${P}/html" \
+ || myconf="${myconf} --without-html-dir"
+
+ # rphillips, fixes bug #3876
+ # this is fixed for me with apache2, but keeping it in here
+ # for apache1 users and/or until some clever detection
+ # is added <obz@gentoo.org>
+ append-ldflags -lstdc++ -shared-libgcc
+
+ econf ${myconf} || die "Configure failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ einstall || die "Install failed"
+ dodoc ${DOCS}
+}