summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-04-28 04:03:38 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-04-28 04:03:38 +0000
commit59e70743cc92b4299493d80da7ccd11bbfdb3c3b (patch)
tree1fcbf05e7425ca18392ac8d3997d57fa1ceb2678 /app-text/sablotron/sablotron-0.52.ebuild
parentNew version (diff)
downloadgentoo-2-59e70743cc92b4299493d80da7ccd11bbfdb3c3b.tar.gz
gentoo-2-59e70743cc92b4299493d80da7ccd11bbfdb3c3b.tar.bz2
gentoo-2-59e70743cc92b4299493d80da7ccd11bbfdb3c3b.zip
cleanup
Diffstat (limited to 'app-text/sablotron/sablotron-0.52.ebuild')
-rw-r--r--app-text/sablotron/sablotron-0.52.ebuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/app-text/sablotron/sablotron-0.52.ebuild b/app-text/sablotron/sablotron-0.52.ebuild
index ad3d8350d80b..beb9dbc367d7 100644
--- a/app-text/sablotron/sablotron-0.52.ebuild
+++ b/app-text/sablotron/sablotron-0.52.ebuild
@@ -1,31 +1,28 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.52.ebuild,v 1.1 2001/05/06 18:24:28 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/sablotron/sablotron-0.52.ebuild,v 1.2 2002/04/28 03:59:29 seemant Exp $
-A="Sablot-${PV}.tar.gz"
-S=${WORKDIR}/Sablot-${PV}
+MY_P="Sablot-${PV}"
+S=${WORKDIR}/${MY_P}
DESCRIPTION="An XSLT Parser in C++"
-SRC_URI="http://www.gingerall.com/perl/rd?url=sablot/${A}"
+SRC_URI="http://www.gingerall.com/perl/rd?url=sablot/${MY_P}.tar.gz"
HOMEPAGE="http://www.gingerall.com/charlie-bin/get/webGA/act/sablotron.act"
DEPEND=">=sys-devel/gcc-2.95.2 >=dev-libs/expat-1.95.1 virtual/glibc"
src_compile() {
- try ./configure --prefix=/usr --host=${CHOST}
- try pmake
+ ./configure --prefix=/usr --host=${CHOST} || die
+ emake || die
}
src_install () {
- dodir /usr/lib
- dodir /usr/include
- dodir /usr/bin
- try make prefix=${D}/usr install
- dodoc README RELEASE
- dodoc Sablot/TODO
+ dodir /usr/lib
+ dodir /usr/include
+ dodir /usr/bin
+ make prefix=${D}/usr install || die
+ dodoc README RELEASE
+ dodoc Sablot/TODO
}
-
-
-