summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2010-04-20 04:23:57 +0000
committerRyan Hill <dirtyepic@gentoo.org>2010-04-20 04:23:57 +0000
commit465aaf79ab95ccefe8f755ac8cc7702603d8960a (patch)
treea532b2214dccd7fb5f6371648f54af05eb38b98b /app-text/mftrace
parentAdd new function font_cleanup_dirs, called in pkg_postrm, to clean up font di... (diff)
downloadgentoo-2-465aaf79ab95ccefe8f755ac8cc7702603d8960a.tar.gz
gentoo-2-465aaf79ab95ccefe8f755ac8cc7702603d8960a.tar.bz2
gentoo-2-465aaf79ab95ccefe8f755ac8cc7702603d8960a.zip
Revision bump to migrate to new python framework and bump to EAPI3. Patch
by Arfrever (bug #312111). (Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-text/mftrace')
-rw-r--r--app-text/mftrace/ChangeLog10
-rw-r--r--app-text/mftrace/mftrace-1.2.13-r1.ebuild53
2 files changed, 61 insertions, 2 deletions
diff --git a/app-text/mftrace/ChangeLog b/app-text/mftrace/ChangeLog
index 2ae1dbad4247..8bd21caf9cdb 100644
--- a/app-text/mftrace/ChangeLog
+++ b/app-text/mftrace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-text/mftrace
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/mftrace/ChangeLog,v 1.52 2009/09/08 18:15:26 nyhm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mftrace/ChangeLog,v 1.53 2010/04/20 04:23:57 dirtyepic Exp $
+
+*mftrace-1.2.13-r1 (20 Apr 2010)
+
+ 20 Apr 2010; Ryan Hill <dirtyepic@gentoo.org> +mftrace-1.2.13-r1.ebuild:
+ Revision bump to migrate to new python framework and bump to EAPI3. Patch
+ by Arfrever (bug #312111).
08 Sep 2009; Tristan Heaven <nyhm@gentoo.org> mftrace-1.2.13.ebuild:
Add src_configure
diff --git a/app-text/mftrace/mftrace-1.2.13-r1.ebuild b/app-text/mftrace/mftrace-1.2.13-r1.ebuild
new file mode 100644
index 000000000000..92e31f9bcd64
--- /dev/null
+++ b/app-text/mftrace/mftrace-1.2.13-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/mftrace/mftrace-1.2.13-r1.ebuild,v 1.1 2010/04/20 04:23:57 dirtyepic Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit python multilib toolchain-funcs eutils
+
+DESCRIPTION="Traces TeX fonts to PFA or PFB fonts (formerly pktrace)"
+HOMEPAGE="http://lilypond.org/download/sources/mftrace/"
+SRC_URI="http://lilypond.org/download/sources/mftrace/${P}.tar.gz"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+# SLOT 1 was used in pktrace ebuild
+SLOT="1"
+IUSE="truetype"
+
+DEPEND="|| ( media-gfx/potrace >=media-gfx/autotrace-0.30 )"
+RDEPEND="${DEPEND}
+ virtual/latex-base
+ >=app-text/t1utils-1.25
+ truetype? ( media-gfx/fontforge )"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python-2.6.patch"
+}
+
+src_configure() {
+ tc-export CC
+ econf --datadir=$(python_get_sitedir)
+}
+
+src_compile() {
+ emake CFLAGS="-Wall ${CFLAGS}" || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" PYC_MODULES="" install || die "make install failed"
+ dodoc README.txt ChangeLog
+}
+
+pkg_postinst() {
+ python_mod_optimize mftrace
+}
+
+pkg_postrm() {
+ python_mod_cleanup mftrace
+}