summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-04-02 23:42:03 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-04-02 23:42:03 +0000
commitae1fdd1088a1b251697f9859d092da53effcfc0b (patch)
treec3f05028c9267acf36d20679eafe51dde5e9c426 /app-text/ispell
parentlibtoolize (diff)
downloadgentoo-2-ae1fdd1088a1b251697f9859d092da53effcfc0b.tar.gz
gentoo-2-ae1fdd1088a1b251697f9859d092da53effcfc0b.tar.bz2
gentoo-2-ae1fdd1088a1b251697f9859d092da53effcfc0b.zip
form fixes
Diffstat (limited to 'app-text/ispell')
-rw-r--r--app-text/ispell/files/digest-ispell-3.2.06-r11
-rw-r--r--app-text/ispell/ispell-3.2.06-r1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-text/ispell/files/digest-ispell-3.2.06-r1 b/app-text/ispell/files/digest-ispell-3.2.06-r1
new file mode 100644
index 000000000000..47a0eb5fc260
--- /dev/null
+++ b/app-text/ispell/files/digest-ispell-3.2.06-r1
@@ -0,0 +1 @@
+MD5 d434e1aef1a815294d5012c60c4c414a ispell-3.2.06.tar.gz 580742
diff --git a/app-text/ispell/ispell-3.2.06-r1.ebuild b/app-text/ispell/ispell-3.2.06-r1.ebuild
new file mode 100644
index 000000000000..1773cf728ee5
--- /dev/null
+++ b/app-text/ispell/ispell-3.2.06-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author: Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ispell-3.2.06-r1.ebuild,v 1.1 2002/04/02 23:42:03 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Ispell is a fast screen-oriented spelling checker"
+SRC_URI="http://fmg-www.cs.ucla.edu/geoff/tars/${P}.tar.gz"
+HOMEPAGE="http://fmg-www.cs.ucla.edu/geoff/ispell.html"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2"
+
+src_compile() {
+
+ #This is easier and cleaner than sed'ing.
+ #Also allows user to edit local.h.gentoo for language preference
+ cp ${FILESDIR}/local.h.gentoo ${S}/local.h
+
+ make all || die "Compile failed"
+}
+
+src_install () {
+
+ #Fix config.sh to install to ${D}
+ cp config.sh config.sh.orig
+ sed \
+ -e "s:^\(BINDIR='\)\(.*\):\1${D}\2:" \
+ -e "s:^\(LIBDIR='\)\(.*\):\1${D}\2:" \
+ -e "s:^\(MAN1DIR='\)\(.*\):\1${D}\2:" \
+ -e "s:^\(MAN4DIR='\)\(.*\):\1${D}\2:" \
+ config.sh.orig > config.sh
+
+ #Need to create the directories to install into
+ #before 'make install'. Build environment **doesn't**
+ #check for existence and create if not already there.
+ dodir /usr/bin /usr/lib/ispell /usr/share/info \
+ /usr/share/man/man1 /usr/share/man/man5
+
+ make install || die "Installation Failed"
+
+ dodoc Contributors README WISHES
+}
+