summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-07-11 06:17:53 +0000
committerMike Frysinger <vapier@gentoo.org>2006-07-11 06:17:53 +0000
commit300ca6a3e8879509b10055420b24a3073b4903af (patch)
treec941f9b1cdb932fc5c1670c4518b476c573ab5fa /app-text/hd2u/hd2u-1.0.0.ebuild
parentold (diff)
downloadgentoo-2-300ca6a3e8879509b10055420b24a3073b4903af.tar.gz
gentoo-2-300ca6a3e8879509b10055420b24a3073b4903af.tar.bz2
gentoo-2-300ca6a3e8879509b10055420b24a3073b4903af.zip
Respect LDFLAGS/DESTDIR and dont strip while installing.
(Portage version: 2.1.1_pre2-r4)
Diffstat (limited to 'app-text/hd2u/hd2u-1.0.0.ebuild')
-rw-r--r--app-text/hd2u/hd2u-1.0.0.ebuild16
1 files changed, 12 insertions, 4 deletions
diff --git a/app-text/hd2u/hd2u-1.0.0.ebuild b/app-text/hd2u/hd2u-1.0.0.ebuild
index 053b9dafd98e..a4e4fdde206c 100644
--- a/app-text/hd2u/hd2u-1.0.0.ebuild
+++ b/app-text/hd2u/hd2u-1.0.0.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/hd2u/hd2u-1.0.0.ebuild,v 1.8 2006/02/06 19:35:22 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/hd2u/hd2u-1.0.0.ebuild,v 1.9 2006/07/11 06:17:53 vapier Exp $
+
+inherit eutils
DESCRIPTION="Dos2Unix text file converter"
HOMEPAGE="http://www.megaloman.com/~hany/software/hd2u/"
@@ -11,10 +13,16 @@ SLOT="0"
LICENSE="GPL-2"
IUSE=""
-RDEPEND="!app-text/dos2unix
+DEPEND="!app-text/dos2unix
dev-libs/popt"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
src_install() {
- einstall || die "make install failed"
- dodoc AUTHORS COPYING CREDITS ChangeLog INSTALL NEWS README TODO
+ emake install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS CREDITS ChangeLog INSTALL NEWS README TODO
}