summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandy Westcott <brandy@gentoo.org>2003-10-30 04:07:56 +0000
committerBrandy Westcott <brandy@gentoo.org>2003-10-30 04:07:56 +0000
commit0a3f6eff955aae07967a8df9a2212a209a6d767b (patch)
treeaa7b866ee83f255324730fa22473db3f2f7ed018 /app-text/expander
parentnew modules for tc2 (diff)
downloadgentoo-2-0a3f6eff955aae07967a8df9a2212a209a6d767b.tar.gz
gentoo-2-0a3f6eff955aae07967a8df9a2212a209a6d767b.tar.bz2
gentoo-2-0a3f6eff955aae07967a8df9a2212a209a6d767b.zip
Initial import. Closes bug #30604.
Diffstat (limited to 'app-text/expander')
-rw-r--r--app-text/expander/ChangeLog10
-rw-r--r--app-text/expander/Manifest4
-rw-r--r--app-text/expander/expander-2.0.5.ebuild62
-rw-r--r--app-text/expander/files/digest-expander-2.0.51
-rw-r--r--app-text/expander/files/expander-2.0.5-gentoo.patch59
5 files changed, 136 insertions, 0 deletions
diff --git a/app-text/expander/ChangeLog b/app-text/expander/ChangeLog
new file mode 100644
index 000000000000..0a53815c0cdd
--- /dev/null
+++ b/app-text/expander/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-text/expander
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/expander/ChangeLog,v 1.1 2003/10/30 04:07:34 brandy Exp $
+
+*expander-2.0.5 (30 Oct 2003)
+
+ 30 Oct 2003; Brandy Westcott brandy@gentoo.org expander-2.0.5.ebuild:
+ Initial import. Expander is a utility that acts as a filter for text editors.
+ Closes bug #30604.
+
diff --git a/app-text/expander/Manifest b/app-text/expander/Manifest
new file mode 100644
index 000000000000..c33788edd9d6
--- /dev/null
+++ b/app-text/expander/Manifest
@@ -0,0 +1,4 @@
+MD5 47d01def996d9f0100823b9c58abf024 expander-2.0.5.ebuild 1208
+MD5 c875bd5e0d427cf4192a7801e6cc1c46 ChangeLog 421
+MD5 e1b1684ae191201bc6a5f971c6152ad6 files/digest-expander-2.0.5 74
+MD5 70dbffef31eddd8694e602fd01a68822 files/expander-2.0.5-gentoo.patch 2067
diff --git a/app-text/expander/expander-2.0.5.ebuild b/app-text/expander/expander-2.0.5.ebuild
new file mode 100644
index 000000000000..81ee1f4703cf
--- /dev/null
+++ b/app-text/expander/expander-2.0.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/expander/expander-2.0.5.ebuild,v 1.1 2003/10/30 04:07:34 brandy Exp $
+
+DESCRIPTION="Expander is a utility that acts as a filter for text editors."
+HOMEPAGE="http://www.nedit.org"
+SRC_URI="ftp://ftp.nedit.org/pub/contrib/misc/nedit_expander_kit_2.05.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-gentoo.patch
+
+}
+
+src_compile() {
+
+ cd ${S}/src
+ make || die "make failed"
+
+}
+
+src_install() {
+
+ cd ${S}/src
+ dobin expander boxcomment align_columns align_comments where_is
+ dosym /usr/bin/boxcomment /usr/bin/unboxcomment
+
+ insinto /usr/share/${P}
+ doins ${S}/service
+ for x in defs macros misc templates ; do
+ insinto /usr/share/${P}/${x}
+ doins ${S}/${x}/*
+ done
+
+ cd ${S}/docs
+ doman *.1
+
+ cd ${S}
+ dodoc ChangeLog INSTALL README USAGE
+
+}
+
+pkg_postinst() {
+
+ einfo
+ einfo "Instructions for using expander with NEdit are in /usr/share/doc/${P}/INSTALL"
+ einfo "Macro, definition and template files can be found in /usr/share/${P}"
+ einfo
+
+}
diff --git a/app-text/expander/files/digest-expander-2.0.5 b/app-text/expander/files/digest-expander-2.0.5
new file mode 100644
index 000000000000..a27928fa6ac7
--- /dev/null
+++ b/app-text/expander/files/digest-expander-2.0.5
@@ -0,0 +1 @@
+MD5 e8a2b0ec7b23f9943a5403ac3df7b5b3 nedit_expander_kit_2.05.tar.gz 92571
diff --git a/app-text/expander/files/expander-2.0.5-gentoo.patch b/app-text/expander/files/expander-2.0.5-gentoo.patch
new file mode 100644
index 000000000000..e6c023834939
--- /dev/null
+++ b/app-text/expander/files/expander-2.0.5-gentoo.patch
@@ -0,0 +1,59 @@
+diff -ur expander/src/Makefile expander-gentoo/src/Makefile
+--- expander/src/Makefile 2003-10-30 14:52:00.000000000 +1300
++++ expander-gentoo/src/Makefile 2003-10-30 15:50:02.000000000 +1300
+@@ -3,15 +3,14 @@
+ bindir = $(BINDIR)/
+
+ copy = ln -fs
+-CFLAGS += -v -g # -DNEED_GETOPT_PROTO_TYPE
+-compiler = cc $(CFLAGS)
++compiler = gcc $(CFLAGS)
+
+ executables = expander boxcomment align_columns align_comments where_is
+
+ #--------------
+ # Build Targets
+ #--------------
+-all: verify $(executables)
++all: $(executables)
+
+ verify:
+ @if [ "$(bindir)" = "/" ]; then \
+@@ -24,32 +23,31 @@
+ # Abbreviation expansion filter program (with NEdit, language sensitive)
+ #-----------------------------------------------------------------------
+ expander: expander.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) -o $@ $?
+
+ #--------------------------------------------------------------------------
+ # Surround given text with open ended box. (with NEdit, language sensitive)
+ #--------------------------------------------------------------------------
+ boxcomment: boxcomment.c
+- $(compiler) -o $(bindir)$@ $?
+- @if [ ! -f $(bindir)un$@ ]; then $(copy) $(bindir)$@ $(bindir)un$@; fi
++ $(compiler) -o $@ $?
+
+ #-------------------------------------------------------------------------------
+ # Align ragged looking 'C' style comments (good substitute for align_equals too)
+ #-------------------------------------------------------------------------------
+ align_comments: align_comments.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) -o $@ $?
+
+ #----------------------------
+ # Align given text in columns
+ #----------------------------
+ align_columns: align_columns.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) -o $@ $?
+
+ #----------------------------------------------
+ # File locator (substitute for which, where...)
+ #----------------------------------------------
+ where_is: where_is.c
+- $(compiler) -o $(bindir)$@ $?
++ $(compiler) -o $@ $?
+
+ #------------------------------------------------
+ # Here is how to uninstall the executables built.