summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-01-02 16:33:14 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-01-02 16:33:14 +0000
commit9a8e74b9d0374369650589cb29b558f002668bc1 (patch)
treebd625be1f26757e1b54a5a700eea5fecf44b767e /app-text/dvipng
parentRemove old version. (diff)
downloadgentoo-2-9a8e74b9d0374369650589cb29b558f002668bc1.tar.gz
gentoo-2-9a8e74b9d0374369650589cb29b558f002668bc1.tar.bz2
gentoo-2-9a8e74b9d0374369650589cb29b558f002668bc1.zip
version bump
(Portage version: 2.2.0_alpha11/cvs/Linux x86_64)
Diffstat (limited to 'app-text/dvipng')
-rw-r--r--app-text/dvipng/ChangeLog9
-rw-r--r--app-text/dvipng/dvipng-1.14.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/app-text/dvipng/ChangeLog b/app-text/dvipng/ChangeLog
index 80685d264b93..e466cd1b6435 100644
--- a/app-text/dvipng/ChangeLog
+++ b/app-text/dvipng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/dvipng
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dvipng/ChangeLog,v 1.74 2010/10/02 12:41:08 grobian Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dvipng/ChangeLog,v 1.75 2011/01/02 16:33:14 aballier Exp $
+
+*dvipng-1.14 (02 Jan 2011)
+
+ 02 Jan 2011; Alexis Ballier <aballier@gentoo.org> +dvipng-1.14.ebuild:
+ version bump
02 Oct 2010; Fabian Groffen <grobian@gentoo.org> dvipng-1.13.ebuild:
Marked ~x64-macos, bug #333981
diff --git a/app-text/dvipng/dvipng-1.14.ebuild b/app-text/dvipng/dvipng-1.14.ebuild
new file mode 100644
index 000000000000..b961023f30af
--- /dev/null
+++ b/app-text/dvipng/dvipng-1.14.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dvipng/dvipng-1.14.ebuild,v 1.1 2011/01/02 16:33:14 aballier Exp $
+
+EAPI="2"
+inherit eutils
+
+DESCRIPTION="Translate DVI files into PNG or GIF graphics"
+HOMEPAGE="http://dvipng.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="t1lib truetype test"
+
+RDEPEND="media-libs/gd[jpeg,png]
+ media-libs/libpng
+ virtual/latex-base
+ sys-libs/zlib
+ t1lib? ( media-libs/t1lib )
+ truetype? ( >=media-libs/freetype-2.1.5 )"
+DEPEND="${RDEPEND}
+ virtual/texi2dvi
+ test? ( || ( dev-texlive/texlive-fontsrecommended app-text/ptex ) )"
+
+src_configure() {
+ if ! use t1lib; then
+ # The build system autodetects libt1. We don't want that if the
+ # USE flag is not set, so confuse it with a wrong name.
+ sed -i -e 's/T1_InitLib/dIsAbLe&/' configure || die "sed failed"
+ fi
+
+ if ! use truetype; then
+ sed -i -e 's/FT_Init_FreeType/dIsAbLe&/' configure || die "sed failed"
+ fi
+
+ export VARTEXFONTS="${T}/fonts"
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README RELEASE || die "dodoc failed"
+}