summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-01-01 00:39:07 +0000
committerTim Harder <radhermit@gentoo.org>2014-01-01 00:39:07 +0000
commit0759af0d58dc039b82886b20c410787d8a19c932 (patch)
tree9ef61f4a09bfd6c5d61fb1d7e783d50f2662a9e9 /app-text/dos2unix
parentVersion bump. (diff)
downloadgentoo-2-0759af0d58dc039b82886b20c410787d8a19c932.tar.gz
gentoo-2-0759af0d58dc039b82886b20c410787d8a19c932.tar.bz2
gentoo-2-0759af0d58dc039b82886b20c410787d8a19c932.zip
Version bump.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'app-text/dos2unix')
-rw-r--r--app-text/dos2unix/ChangeLog9
-rw-r--r--app-text/dos2unix/dos2unix-6.0.4.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/app-text/dos2unix/ChangeLog b/app-text/dos2unix/ChangeLog
index 8818c73fda27..48ade8cf4028 100644
--- a/app-text/dos2unix/ChangeLog
+++ b/app-text/dos2unix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/dos2unix
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.134 2013/03/16 09:00:32 jlec Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/ChangeLog,v 1.135 2014/01/01 00:39:07 radhermit Exp $
+
+*dos2unix-6.0.4 (01 Jan 2014)
+
+ 01 Jan 2014; Tim Harder <radhermit@gentoo.org> +dos2unix-6.0.4.ebuild:
+ Version bump.
16 Mar 2013; Justin Lecher <jlec@gentoo.org> -dos2unix-6.0.2.ebuild:
Dop old
diff --git a/app-text/dos2unix/dos2unix-6.0.4.ebuild b/app-text/dos2unix/dos2unix-6.0.4.ebuild
new file mode 100644
index 000000000000..68b9290e3ac9
--- /dev/null
+++ b/app-text/dos2unix/dos2unix-6.0.4.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/dos2unix/dos2unix-6.0.4.ebuild,v 1.1 2014/01/01 00:39:07 radhermit Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="Convert DOS or MAC text files to UNIX format or vice versa"
+HOMEPAGE="http://www.xs4all.nl/~waterlan/dos2unix.html http://sourceforge.net/projects/dos2unix/"
+SRC_URI="
+ http://www.xs4all.nl/~waterlan/${PN}/${P}.tar.gz
+ mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~sparc64-solaris"
+IUSE="debug nls"
+
+RDEPEND="
+ !app-text/hd2u
+ !app-text/unix2dos
+ virtual/libintl"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ dev-lang/perl"
+
+src_prepare() {
+ sed \
+ -e '/^LDFLAGS/s|=|+=|' \
+ -e '/CFLAGS_OS \+=/d' \
+ -e '/LDFLAGS_EXTRA \+=/d' \
+ -e "/^CFLAGS/s|-O2|${CFLAGS}|" \
+ -i Makefile || die
+
+ if use debug ; then
+ sed -e "/^DEBUG/s:0:1:" \
+ -e "/EXTRA_CFLAGS +=/s:-g::" \
+ -i Makefile || die
+ fi
+
+ tc-export CC
+}
+
+lintl() {
+ # same logic as from virtual/libintl
+ use !elibc_glibc && use !elibc_uclibc && echo "-lintl"
+}
+
+src_compile() {
+ emake prefix="${EPREFIX}/usr" \
+ $(use nls && echo "LDFLAGS_EXTRA=$(lintl)" || echo "ENABLE_NLS=")
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" \
+ $(use nls || echo "ENABLE_NLS=") install
+}