summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-27 00:32:24 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-27 00:32:24 +0000
commitf1a29b869455a17872dfb35df3ce2494ee9d100f (patch)
treecf40951aae94884ca19cc9774982cf40dd73cd73 /app-text/convertlit
parentmoved from app-arch (diff)
downloadgentoo-2-f1a29b869455a17872dfb35df3ce2494ee9d100f.tar.gz
gentoo-2-f1a29b869455a17872dfb35df3ce2494ee9d100f.tar.bz2
gentoo-2-f1a29b869455a17872dfb35df3ce2494ee9d100f.zip
block open_c-lit #110567
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'app-text/convertlit')
-rw-r--r--app-text/convertlit/convertlit-1.8.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/app-text/convertlit/convertlit-1.8.ebuild b/app-text/convertlit/convertlit-1.8.ebuild
index 7a5a90b4b9ad..c4ed38615025 100644
--- a/app-text/convertlit/convertlit-1.8.ebuild
+++ b/app-text/convertlit/convertlit-1.8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/convertlit/convertlit-1.8.ebuild,v 1.7 2005/10/11 18:40:42 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/convertlit/convertlit-1.8.ebuild,v 1.8 2005/10/27 00:32:24 vapier Exp $
MY_P="clit${PV//./}"
@@ -10,22 +10,22 @@ SRC_URI="http://www.convertlit.com/${MY_P}src.zip"
LICENSE="GPL-2"
SLOT="0"
-
KEYWORDS="amd64 ppc ~ppc-macos x86"
+IUSE=""
+
DEPEND="dev-libs/libtommath
>=sys-apps/sed-4
app-arch/unzip"
-RDEPEND="" # link libtommath statically
-IUSE=""
+RDEPEND="!app-text/open_c-lit" # link libtommath statically
S=${WORKDIR}
src_compile() {
- cd ${S}/lib
+ cd "${S}"/lib
sed -i -e "/^CFLAGS/s/-O3 -Wall/${CFLAGS}/" Makefile \
|| die "sed lib/Makefile failed."
emake || die "make lib failed"
- cd ${S}/${MY_P}
+ cd "${S}"/${MY_P}
sed -i -e "/^CFLAGS/s:-Wall -O2:${CFLAGS}:" \
-e "s:../libtommath-0.30:/usr/lib:g" Makefile \
|| die "sed ${MY_P}/Makefile failed."
@@ -33,6 +33,6 @@ src_compile() {
}
src_install() {
- dobin ${S}/${MY_P}/clit
- dodoc ${S}/README
+ dobin ${MY_P}/clit || die
+ dodoc README
}