summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-05 18:28:25 +0000
committerAndreas K. Hüttel <dilfridge@gentoo.org>2011-06-05 18:28:25 +0000
commit844c79173e00ee6ab8e35dde5955203416dea4fe (patch)
treef790987261381961e7a268b0167f979fcfad8556 /app-text/c2ps
parentStable for HPPA (bug #352827). (diff)
downloadgentoo-2-844c79173e00ee6ab8e35dde5955203416dea4fe.tar.gz
gentoo-2-844c79173e00ee6ab8e35dde5955203416dea4fe.tar.bz2
gentoo-2-844c79173e00ee6ab8e35dde5955203416dea4fe.zip
EAPI bump; respect LDFLAGS (bug 337917)
(Portage version: 2.1.9.50/cvs/Linux x86_64)
Diffstat (limited to 'app-text/c2ps')
-rw-r--r--app-text/c2ps/ChangeLog6
-rw-r--r--app-text/c2ps/c2ps-4.0.ebuild12
-rw-r--r--app-text/c2ps/files/c2ps-4.0-LDFLAGS.patch11
3 files changed, 23 insertions, 6 deletions
diff --git a/app-text/c2ps/ChangeLog b/app-text/c2ps/ChangeLog
index 3ee03e2d75cb..d8f17273b13a 100644
--- a/app-text/c2ps/ChangeLog
+++ b/app-text/c2ps/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-text/c2ps
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/c2ps/ChangeLog,v 1.17 2011/04/10 03:15:29 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/c2ps/ChangeLog,v 1.18 2011/06/05 18:28:24 dilfridge Exp $
+
+ 05 Jun 2011; Andreas K. Huettel <dilfridge@gentoo.org> c2ps-4.0.ebuild,
+ +files/c2ps-4.0-LDFLAGS.patch:
+ EAPI bump; respect LDFLAGS (bug 337917)
10 Apr 2011; Jonathan Callen <abcd@gentoo.org> c2ps-4.0.ebuild:
Add prefix support, bump EAPI to 3, add prefix keywords
diff --git a/app-text/c2ps/c2ps-4.0.ebuild b/app-text/c2ps/c2ps-4.0.ebuild
index 7dabf3a3387f..d7348f00df9e 100644
--- a/app-text/c2ps/c2ps-4.0.ebuild
+++ b/app-text/c2ps/c2ps-4.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/c2ps/c2ps-4.0.ebuild,v 1.17 2011/04/10 03:15:29 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/c2ps/c2ps-4.0.ebuild,v 1.18 2011/06/05 18:28:24 dilfridge Exp $
-EAPI=3
-inherit toolchain-funcs
+EAPI=4
+inherit base toolchain-funcs
DESCRIPTION="Generates a beautified ps document from a source file (c/c++)"
HOMEPAGE="http://www.cs.technion.ac.il/users/c2ps"
@@ -14,12 +14,14 @@ SLOT="0"
KEYWORDS="amd64 ~mips ppc sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos"
IUSE=""
+PATCHES=( "${FILESDIR}/${P}-LDFLAGS.patch" )
+
src_compile() {
- emake CC="$(tc-getCC)" CCFLAGS="${CFLAGS}" || die
+ emake CC="$(tc-getCC)" CCFLAGS="${CFLAGS}"
}
src_install() {
dodir /usr/bin /usr/share/man/man1
- emake MAN="${ED}"/usr/share/man/man1 PREFIX="${ED}"/usr install || die
+ emake MAN="${ED}"/usr/share/man/man1 PREFIX="${ED}"/usr install
dodoc README
}
diff --git a/app-text/c2ps/files/c2ps-4.0-LDFLAGS.patch b/app-text/c2ps/files/c2ps-4.0-LDFLAGS.patch
new file mode 100644
index 000000000000..d68002180091
--- /dev/null
+++ b/app-text/c2ps/files/c2ps-4.0-LDFLAGS.patch
@@ -0,0 +1,11 @@
+--- a/c2ps-4.0/Makefile 1997-05-15 11:50:56.000000000 -0400
++++ b/c2ps-4.0/Makefile 2010-09-24 19:42:33.000000000 -0400
+@@ -45,7 +45,7 @@
+ install -m 644 c2ps.1 $(MAN)
+
+ compile: c2ps.c
+- $(CC) $(PREP_OPTIONS) $(CCFLAGS) -o c2ps c2ps.c
++ $(CC) $(LDFLAGS) $(PREP_OPTIONS) $(CCFLAGS) -o c2ps c2ps.c $(LIBS)
+
+ clean:
+ $(RM) c2ps *.o core *~