summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2009-05-13 03:45:23 +0000
committerJeremy Olexa <darkside@gentoo.org>2009-05-13 03:45:23 +0000
commit2134c1b8b0f5ad7880e5742725aaa65994e449e2 (patch)
treee6649571366ca9f5c4c12faff3bceaeb9a63befa /app-text/bact
parent(non maintainer commit) QA fixes by Espen Hustad in bug 240071 (diff)
downloadgentoo-2-2134c1b8b0f5ad7880e5742725aaa65994e449e2.tar.gz
gentoo-2-2134c1b8b0f5ad7880e5742725aaa65994e449e2.tar.bz2
gentoo-2-2134c1b8b0f5ad7880e5742725aaa65994e449e2.zip
(non maintainer commit) QA fixes (user flags) by Espen Hustad in bug 240126
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-text/bact')
-rw-r--r--app-text/bact/ChangeLog7
-rw-r--r--app-text/bact/bact-0.13.ebuild17
2 files changed, 17 insertions, 7 deletions
diff --git a/app-text/bact/ChangeLog b/app-text/bact/ChangeLog
index 3fb9a606ca55..a460c63e8ef3 100644
--- a/app-text/bact/ChangeLog
+++ b/app-text/bact/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-text/bact
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bact/ChangeLog,v 1.5 2007/12/25 16:54:23 phreak Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/bact/ChangeLog,v 1.6 2009/05/13 03:45:23 darkside Exp $
+
+ 13 May 2009; Jeremy Olexa <darkside@gentoo.org> bact-0.13.ebuild:
+ (non maintainer commit) QA fixes (user flags) by Espen Hustad in bug 240126
25 Dec 2007; Christian Heim <phreak@gentoo.org> metadata.xml:
Removing usata from metadata.xml as per #22931. Assigning to maintainer-needed.
diff --git a/app-text/bact/bact-0.13.ebuild b/app-text/bact/bact-0.13.ebuild
index e6b70f1dfef1..c92f61620100 100644
--- a/app-text/bact/bact-0.13.ebuild
+++ b/app-text/bact/bact-0.13.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/bact/bact-0.13.ebuild,v 1.1 2005/12/24 18:58:09 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/bact/bact-0.13.ebuild,v 1.2 2009/05/13 03:45:23 darkside Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Boosting Algorithm for Classification of Trees"
HOMEPAGE="http://chasen.org/~taku/software/bact/"
@@ -12,14 +14,19 @@ KEYWORDS="~x86"
IUSE=""
DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
+}
src_test() {
make test || die
}
src_install() {
- dobin bact_learn bact_mkmodel bact_classify || die
+ dobin bact_learn bact_mkmodel bact_classify || die "dobin failed"
- dohtml index.html bact.css
- dodoc README AUTHORS
+ dohtml index.html bact.css || die "dohtml failed"
+ dodoc README AUTHORS || die "dodoc failed"
}