summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2012-11-28 03:01:35 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2012-11-28 03:01:35 +0000
commitfb6b77ce31a07e95332b6969b88c8f61d06e11c2 (patch)
tree6941fc5e09be912054ec48a191a5e7f0af4cfb65 /app-shells
parentadded prefix support (diff)
downloadgentoo-2-fb6b77ce31a07e95332b6969b88c8f61d06e11c2.tar.gz
gentoo-2-fb6b77ce31a07e95332b6969b88c8f61d06e11c2.tar.bz2
gentoo-2-fb6b77ce31a07e95332b6969b88c8f61d06e11c2.zip
Bug #424723: Bump with GCC 4.7 fixes.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/localshell/ChangeLog10
-rw-r--r--app-shells/localshell/localshell-1.3.4.ebuild31
2 files changed, 38 insertions, 3 deletions
diff --git a/app-shells/localshell/ChangeLog b/app-shells/localshell/ChangeLog
index bec688358023..ba3e09d5c01c 100644
--- a/app-shells/localshell/ChangeLog
+++ b/app-shells/localshell/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-shells/localshell
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/localshell/ChangeLog,v 1.14 2010/03/15 18:47:07 nixnut Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/localshell/ChangeLog,v 1.15 2012/11/28 03:01:35 robbat2 Exp $
+
+*localshell-1.3.4 (28 Nov 2012)
+
+ 28 Nov 2012; Robin H. Johnson <robbat2@gentoo.org> +localshell-1.3.4.ebuild:
+ Bug #424723: Bump with GCC 4.7 fixes.
15 Mar 2010; nixnut <nixnut@gentoo.org> localshell-1.3.1.ebuild:
ppc stable #309027
@@ -58,4 +63,3 @@
+localshell-1.1.ebuild:
Initial commit. Ebuild and upstream package by Robin H. Johnson
<robbat2@gentoo.org>
-
diff --git a/app-shells/localshell/localshell-1.3.4.ebuild b/app-shells/localshell/localshell-1.3.4.ebuild
new file mode 100644
index 000000000000..4f4fe06a4899
--- /dev/null
+++ b/app-shells/localshell/localshell-1.3.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/localshell/localshell-1.3.4.ebuild,v 1.1 2012/11/28 03:01:35 robbat2 Exp $
+
+EAPI=4
+
+inherit base eutils
+
+DESCRIPTION="Localshell allows per-user/group local control of shell execution."
+HOMEPAGE="http://git.orbis-terrarum.net/?p=infrastructure/localshellc.git;a=summary"
+SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+src_configure() {
+ # this is a shell, it needs to be in /bin
+ econf --bindir=/bin --sysconfdir=/etc
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ rm -f "${D}"/usr/share/doc/${PF}/{COPYING,INSTALL}
+}
+
+pkg_postinst() {
+ elog "Remember to add /bin/localshell to /etc/shells and create"
+ elog "/etc/localshell.conf based on the included configuration examples"
+}