summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2000-08-13 12:14:31 +0000
committerAchim Gottinger <achim@gentoo.org>2000-08-13 12:14:31 +0000
commitec229cd6f10ac2a6557f1af753e3bf2493d8052c (patch)
tree5e34ed5fbb5962338ca09ae96fe260041dc62a98 /app-shells
parent*** empty log message *** (diff)
downloadgentoo-2-ec229cd6f10ac2a6557f1af753e3bf2493d8052c.tar.gz
gentoo-2-ec229cd6f10ac2a6557f1af753e3bf2493d8052c.tar.bz2
gentoo-2-ec229cd6f10ac2a6557f1af753e3bf2493d8052c.zip
*** empty log message ***
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/ccsh/ccsh-0.0.4-r1.ebuild32
-rw-r--r--app-shells/ccsh/files/digest1
-rw-r--r--app-shells/esh/esh-0.8-r1.ebuild40
-rw-r--r--app-shells/esh/files/digest1
-rw-r--r--app-shells/sash/files/digest1
-rw-r--r--app-shells/sash/sash-3.4-r1.ebuild34
6 files changed, 109 insertions, 0 deletions
diff --git a/app-shells/ccsh/ccsh-0.0.4-r1.ebuild b/app-shells/ccsh/ccsh-0.0.4-r1.ebuild
new file mode 100644
index 000000000000..41aefb19ce84
--- /dev/null
+++ b/app-shells/ccsh/ccsh-0.0.4-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ccsh/ccsh-0.0.4-r1.ebuild,v 1.1 2000/08/13 12:10:49 achim Exp $
+
+P=ccsh-0.0.4
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="UNIX Shell for people already familiar with the C language"
+SRC_URI="http://download.sourceforge.net/ccsh/"${A}
+HOMEPAGE="http://ccsh.sourceforge.net"
+CATEGORY="app-shells"
+
+src_compile() {
+ cd ${S}
+
+ make CFLAGS="${CFLAGS}" all
+}
+
+src_install() {
+ cd ${S}
+ into /
+ dobin ccsh
+ into /usr
+ newman ccsh.man ccsh.1
+ dodoc ChangeLog COPYING README TODO
+}
+
+
+
+
+
diff --git a/app-shells/ccsh/files/digest b/app-shells/ccsh/files/digest
new file mode 100644
index 000000000000..25a513ed0f28
--- /dev/null
+++ b/app-shells/ccsh/files/digest
@@ -0,0 +1 @@
+MD5 042a8596065e49dccf154b661e2444a9 ccsh-0.0.4.tar.gz
diff --git a/app-shells/esh/esh-0.8-r1.ebuild b/app-shells/esh/esh-0.8-r1.ebuild
new file mode 100644
index 000000000000..fc751fcdf00e
--- /dev/null
+++ b/app-shells/esh/esh-0.8-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/esh/esh-0.8-r1.ebuild,v 1.1 2000/08/13 12:10:49 achim Exp $
+
+P=esh-0.8
+A=${P}.tar.gz
+S=${WORKDIR}/esh
+DESCRIPTION="A UNIX Shell with a simplified Scheme syntax"
+SRC_URI="http://esh.netpedia.net/"${A}
+HOMEPAGE="http://esh.netpedia.net/"
+CATEGORY="app-shells"
+
+src_compile() {
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:^CFLAGS=:CFLAGS=${CFLAGS} :" \
+ -e "s:^LIB=:LIB=-lncurses :" Makefile.orig > Makefile
+ make
+}
+
+src_install() {
+ cd ${S}
+ into /
+ dobin esh
+ into /usr
+ doinfo doc/esh.info
+ dodoc CHANGELOG CREDITS GC_README HEADER LICENSE READLNE-HACKS TODO
+ docinto html
+ dodoc doc/*.html
+ docinto examples
+ dodoc examples/*
+ insinto /usr/share/emacs/site-lisp/
+ doins emacs/esh-mode.el
+}
+
+
+
+
+
diff --git a/app-shells/esh/files/digest b/app-shells/esh/files/digest
new file mode 100644
index 000000000000..4ea7be5f1d42
--- /dev/null
+++ b/app-shells/esh/files/digest
@@ -0,0 +1 @@
+MD5 b59022b88bae24420156d25869b8be54 esh-0.8.tar.gz
diff --git a/app-shells/sash/files/digest b/app-shells/sash/files/digest
new file mode 100644
index 000000000000..d8d6a75468ab
--- /dev/null
+++ b/app-shells/sash/files/digest
@@ -0,0 +1 @@
+MD5 9c631eb171371b69276ff6692100beb6 sash-3.4.tar.gz
diff --git a/app-shells/sash/sash-3.4-r1.ebuild b/app-shells/sash/sash-3.4-r1.ebuild
new file mode 100644
index 000000000000..71049560c8d0
--- /dev/null
+++ b/app-shells/sash/sash-3.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-shells/sash/sash-3.4-r1.ebuild,v 1.1 2000/08/13 12:10:49 achim Exp $
+
+P=sash-3.4
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="A small UNIX Shell"
+SRC_URI="http://www.canb.auug.org.au/~dbell/programs/"${A}
+HOMEPAGE="http://www.canb.auug.org.au/~dbell/"
+CATEGORY="app-shells"
+
+src_compile() {
+ cd ${S}
+ cp Makefile Makefile.orig
+ sed -e "s:-O3:${CFLAGS}:" Makefile.orig > Makefile
+ make
+}
+
+src_install() {
+ cd ${S}
+ into /
+ dobin sash
+ into /usr
+ doman sash.1
+ dodoc README
+
+}
+
+
+
+
+