summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2011-01-04 04:40:24 +0000
committerJeremy Olexa <darkside@gentoo.org>2011-01-04 04:40:24 +0000
commitb43a4ef6e46bde81c6ee7d8f0fb24fa957f43b14 (patch)
tree36e28169aa485d556eb2dff6bfaf99415131e38b /app-shells
parentAdded 0.9 beta (diff)
downloadgentoo-2-b43a4ef6e46bde81c6ee7d8f0fb24fa957f43b14.tar.gz
gentoo-2-b43a4ef6e46bde81c6ee7d8f0fb24fa957f43b14.tar.bz2
gentoo-2-b43a4ef6e46bde81c6ee7d8f0fb24fa957f43b14.zip
revision bump to remove eix completion and block older eix versions to prevent file collisions, bug 350129
(Portage version: 2.1.9.27/cvs/Linux x86_64)
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/zsh-completion/ChangeLog11
-rw-r--r--app-shells/zsh-completion/zsh-completion-20091203-r1.ebuild40
2 files changed, 49 insertions, 2 deletions
diff --git a/app-shells/zsh-completion/ChangeLog b/app-shells/zsh-completion/ChangeLog
index 6de1bba8cbf7..29516947f611 100644
--- a/app-shells/zsh-completion/ChangeLog
+++ b/app-shells/zsh-completion/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/zsh-completion
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh-completion/ChangeLog,v 1.43 2010/08/14 07:08:02 cla Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh-completion/ChangeLog,v 1.44 2011/01/04 04:40:24 darkside Exp $
+
+*zsh-completion-20091203-r1 (04 Jan 2011)
+
+ 04 Jan 2011; Jeremy Olexa <darkside@gentoo.org>
+ +zsh-completion-20091203-r1.ebuild:
+ revision bump to remove eix completion and block older eix versions to
+ prevent file collisions, bug 350129
14 Aug 2010; Dawid Węgliński <cla@gentoo.org>
zsh-completion-20080310.ebuild, zsh-completion-20091203.ebuild:
diff --git a/app-shells/zsh-completion/zsh-completion-20091203-r1.ebuild b/app-shells/zsh-completion/zsh-completion-20091203-r1.ebuild
new file mode 100644
index 000000000000..4ab4d5bb417e
--- /dev/null
+++ b/app-shells/zsh-completion/zsh-completion-20091203-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/zsh-completion/zsh-completion-20091203-r1.ebuild,v 1.1 2011/01/04 04:40:24 darkside Exp $
+
+MY_PV="20080310"
+DESCRIPTION="Programmable Completion for zsh (includes emerge and ebuild commands)"
+HOMEPAGE="http://gentoo.org"
+SRC_URI="mirror://gentoo/${PN}-${MY_PV}.tar.bz2"
+
+LICENSE="ZSH"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc64-solaris"
+IUSE=""
+
+DEPEND=">=app-shells/zsh-4.3.5"
+RDEPEND="${DEPEND}
+ !<app-portage/eix-0.22.6"
+
+S="${WORKDIR}"/${PN}-${MY_PV}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ rm _eix
+}
+
+src_install() {
+ insinto /usr/share/zsh/site-functions
+ doins _*
+
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ elog
+ elog "If you happen to compile your functions, you may need to delete"
+ elog "~/.zcompdump{,.zwc} and recompile to make zsh-completion available"
+ elog "to your shell."
+ elog
+}