summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Birchinger <joker@gentoo.org>2003-09-09 23:08:19 +0000
committerChristian Birchinger <joker@gentoo.org>2003-09-09 23:08:19 +0000
commitb161e6d3cd1fb9c8825911830aa45f7b02dae953 (patch)
tree14b1791e42cf26019328211c441043c8c5f4a639 /app-shells
parents/obconf-1.0/${P} (diff)
downloadgentoo-2-b161e6d3cd1fb9c8825911830aa45f7b02dae953.tar.gz
gentoo-2-b161e6d3cd1fb9c8825911830aa45f7b02dae953.tar.bz2
gentoo-2-b161e6d3cd1fb9c8825911830aa45f7b02dae953.zip
Version bump and new version of gentoo.completion which has limmited init.d support
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/bash-completion/ChangeLog9
-rw-r--r--app-shells/bash-completion/Manifest6
-rw-r--r--app-shells/bash-completion/bash-completion-20030821.ebuild55
-rw-r--r--app-shells/bash-completion/files/digest-bash-completion-200308211
-rw-r--r--app-shells/bash-completion/files/gentoo.completion7
5 files changed, 75 insertions, 3 deletions
diff --git a/app-shells/bash-completion/ChangeLog b/app-shells/bash-completion/ChangeLog
index bdea187fd213..b4b7871598de 100644
--- a/app-shells/bash-completion/ChangeLog
+++ b/app-shells/bash-completion/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-shells/bash-completion
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.37 2003/07/21 12:06:19 joker Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/ChangeLog,v 1.38 2003/09/09 23:08:13 joker Exp $
+
+*bash-completion-20030821 (10 Sep 2003)
+
+ 10 Sep 2003; Christian Birchinger <joker@gentoo.org>
+ bash-completion-20030821.ebuild, files/gentoo.completion:
+ Version bump and new version of gentoo.completion which has
+ limmited init.d support
*bash-completion-20030721 (21 Jul 2003)
diff --git a/app-shells/bash-completion/Manifest b/app-shells/bash-completion/Manifest
index 3d78469cfb9f..97548bb36995 100644
--- a/app-shells/bash-completion/Manifest
+++ b/app-shells/bash-completion/Manifest
@@ -1,10 +1,12 @@
-MD5 85c90af82f4e00938e95fbbf7365bf1a ChangeLog 4486
+MD5 d097c80e6bbafabec32b52a64d805188 ChangeLog 4731
MD5 822273ec32f2d50fd50a34a3e91fd585 bash-completion-20030505-r1.ebuild 1464
MD5 404e3e265fe61db29a8d6557f018a9c9 bash-completion-20030713.ebuild 1466
MD5 4e281359f4e0adb7356cab7bb57b4c5c bash-completion-20030721.ebuild 1466
+MD5 7672ca4c101564f634ebee46fee2fd08 bash-completion-20030821.ebuild 1466
MD5 c85a85bd33aac22ae4872c85733e581f files/README.gentoo 491
MD5 9b22241df7258cb9677cf9a1497e07c5 files/bash-completion 625
MD5 86466a747ec82cd05ba511f06125c947 files/digest-bash-completion-20030505-r1 76
-MD5 58c57aafa06a6e59c9f607bd90f68dde files/gentoo.completion 14919
+MD5 3df1918a609a7b2fb8a30f9dd59f552f files/gentoo.completion 15096
MD5 069e386b2f6e85a4b86d4929bfb1f585 files/digest-bash-completion-20030713 76
MD5 60d3ff2b99d75697ce01c2ca72ade293 files/digest-bash-completion-20030721 76
+MD5 27ea6237a77a7e7edf98246e855b0a82 files/digest-bash-completion-20030821 76
diff --git a/app-shells/bash-completion/bash-completion-20030821.ebuild b/app-shells/bash-completion/bash-completion-20030821.ebuild
new file mode 100644
index 000000000000..a7845ba9a26d
--- /dev/null
+++ b/app-shells/bash-completion/bash-completion-20030821.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/bash-completion/bash-completion-20030821.ebuild,v 1.1 2003/09/09 23:08:13 joker Exp $
+
+S=${WORKDIR}/${PN/-/_}
+DESCRIPTION="Programmable Completion for bash (includes emerge and ebuild commands)."
+HOMEPAGE="http://www.caliban.org/bash/index.shtml#completion"
+SRC_URI="http://www.caliban.org/files/bash/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm ~amd64"
+
+DEPEND="sys-apps/tar
+ sys-apps/bzip2"
+
+RDEPEND=">=app-shells/bash-2.05a"
+
+src_install() {
+ insinto /etc
+ doins bash_completion
+
+ insinto /etc/bash_completion.d
+
+ doins contrib/unrar
+ doins contrib/harbour
+ doins contrib/isql
+ doins contrib/larch
+ doins contrib/lilypond
+ doins contrib/p4
+ doins contrib/ri
+
+ newins ${FILESDIR}/gentoo.completion gentoo
+
+ insinto /etc/profile.d
+ doins ${FILESDIR}/bash-completion
+
+ dodoc COPYING Changelog README
+}
+
+pkg_postinst() {
+ echo
+ einfo "Add the following line to your ~/.bashrc to"
+ einfo "activate completion support in your bash:"
+ einfo "[ -f /etc/profile.d/bash-completion ] && source /etc/profile.d/bash-completion"
+ echo
+
+ if [ -f /etc/bash_completion.d/gentoo.completion ]
+ then
+ echo
+ ewarn "The file 'gentoo.completion' in '/etc/bash_completion.d/' has been"
+ ewarn "replaced with 'gentoo'. Remove gentoo.completion to avoid problems."
+ echo
+ fi
+}
diff --git a/app-shells/bash-completion/files/digest-bash-completion-20030821 b/app-shells/bash-completion/files/digest-bash-completion-20030821
new file mode 100644
index 000000000000..5a9dfd23a577
--- /dev/null
+++ b/app-shells/bash-completion/files/digest-bash-completion-20030821
@@ -0,0 +1 @@
+MD5 62208abed378d4441d9cf5907dbe5129 bash-completion-20030821.tar.bz2 71045
diff --git a/app-shells/bash-completion/files/gentoo.completion b/app-shells/bash-completion/files/gentoo.completion
index e1fcd56da758..d3e5e32d83c3 100644
--- a/app-shells/bash-completion/files/gentoo.completion
+++ b/app-shells/bash-completion/files/gentoo.completion
@@ -10,6 +10,13 @@
#
#
+# simple completion for Gentoo style init
+#
+complete -W "start stop restart pause zap ineed needsme iuse usesme broken" \
+ $(for i in /etc/init.d/*; do echo ${i##*/}; done)
+
+
+#
# emerge completion command
#
_emerge()