summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-05-31 17:48:11 +0000
committerMike Frysinger <vapier@gentoo.org>2004-05-31 17:48:11 +0000
commit369d350e26d3d13aa687dbddc5531acbd3b35af6 (patch)
tree4d9c5ab2a66151e1db654c1430f36039163ed2cf /app-shells
parentAdding SILC support, but silc-toolkit needs to be approved to a lot more arch... (diff)
downloadgentoo-2-369d350e26d3d13aa687dbddc5531acbd3b35af6.tar.gz
gentoo-2-369d350e26d3d13aa687dbddc5531acbd3b35af6.tar.bz2
gentoo-2-369d350e26d3d13aa687dbddc5531acbd3b35af6.zip
arm KEYWORDS
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/ash/ash-1.6.ebuild5
-rw-r--r--app-shells/csh/csh-1.29-r3.ebuild4
-rw-r--r--app-shells/tcsh/tcsh-6.12-r3.ebuild15
3 files changed, 12 insertions, 12 deletions
diff --git a/app-shells/ash/ash-1.6.ebuild b/app-shells/ash/ash-1.6.ebuild
index 5fe5e24920a9..7a86a62959dd 100644
--- a/app-shells/ash/ash-1.6.ebuild
+++ b/app-shells/ash/ash-1.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/ash/ash-1.6.ebuild,v 1.9 2004/05/12 19:18:44 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/ash/ash-1.6.ebuild,v 1.10 2004/05/31 17:44:36 vapier Exp $
inherit eutils
@@ -12,7 +12,8 @@ SRC_URI="ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-release-1-6/tar_files/src/bin.ta
LICENSE="BSD"
SLOT="0"
-KEYWORDS="x86 ~ppc alpha sparc ~mips"
+KEYWORDS="x86 ~ppc sparc ~mips alpha arm"
+IUSE=""
DEPEND="sys-devel/pmake
sys-apps/sed
diff --git a/app-shells/csh/csh-1.29-r3.ebuild b/app-shells/csh/csh-1.29-r3.ebuild
index f7c69e6676b8..90a195367fb1 100644
--- a/app-shells/csh/csh-1.29-r3.ebuild
+++ b/app-shells/csh/csh-1.29-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r3.ebuild,v 1.4 2004/05/15 09:53:08 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/csh/csh-1.29-r3.ebuild,v 1.5 2004/05/31 17:45:11 vapier Exp $
inherit flag-o-matic eutils ccc
@@ -10,7 +10,7 @@ SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="x86 alpha ia64 ~amd64"
+KEYWORDS="x86 alpha arm ~amd64 ia64"
IUSE="static doc"
DEPEND="sys-devel/pmake !app-shells/tcsh"
diff --git a/app-shells/tcsh/tcsh-6.12-r3.ebuild b/app-shells/tcsh/tcsh-6.12-r3.ebuild
index 389fb98725bb..26386997cf7c 100644
--- a/app-shells/tcsh/tcsh-6.12-r3.ebuild
+++ b/app-shells/tcsh/tcsh-6.12-r3.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.12-r3.ebuild,v 1.5 2004/05/12 20:13:59 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/tcsh/tcsh-6.12-r3.ebuild,v 1.6 2004/05/31 17:48:11 vapier Exp $
+
+inherit eutils
MY_P="${PN}-${PV}.00"
DESCRIPTION="Enhanced version of the Berkeley C shell (csh)"
@@ -9,7 +11,7 @@ HOMEPAGE="http://www.tcsh.org/"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="x86 ~ppc sparc alpha ia64 amd64 hppa ppc64"
+KEYWORDS="x86 ~ppc sparc alpha arm hppa amd64 ia64 ppc64"
IUSE="cjk perl"
RDEPEND="virtual/glibc
@@ -21,11 +23,8 @@ S="${WORKDIR}/${MY_P}"
src_unpack() {
unpack ${A}
cd ${S}
- patch -p0 < ${FILESDIR}/${P}-tc.os.h-gentoo.diff || die
- if [ "`use cjk`" ]
- then
- patch -p0 < ${FILESDIR}/tcsh_enable_kanji.diff || die
- fi
+ epatch ${FILESDIR}/${P}-tc.os.h-gentoo.diff
+ use cjk && epatch ${FILESDIR}/tcsh_enable_kanji.diff
}
src_compile() {
@@ -36,7 +35,7 @@ src_compile() {
src_install() {
make DESTDIR=${D} install install.man || die
- if [ "`use perl`" ] ; then
+ if use perl ; then
perl tcsh.man2html || die
dohtml tcsh.html/*.html
fi